Skip navigation

ARD 3.6 not creating Reports

2892 Views 16 Replies Latest reply: Oct 19, 2012 1:42 PM by Joe Pyrdek RSS
1 2 Previous Next
Me&My_Mac Calculating status...
Currently Being Moderated
Aug 15, 2012 2:26 AM

I am not able to creat any Reports exept the Administrator Report.

Do I have to correct any Settings?

  • iToaster Level 3 Level 3 (585 points)
    Currently Being Moderated
    Aug 18, 2012 5:35 AM (in response to Me&My_Mac)

    There is a tick box on the report to force ARD to fectch new data

    Sorry I can't remember the exact title and were it is

    I'll have a look when I'm back at work

  • iToaster Level 3 Level 3 (585 points)
    Currently Being Moderated
    Aug 19, 2012 3:35 PM (in response to Me&My_Mac)

    not sure what you mean by administrator report. If your running ARD admin

    as a stnd user, login as admin and change ARD admin preferences to enable what you need

    when using as a stnd user


    I had a look at report generating

    when you open the report generator there is a tick box that says "rebuild data for report"

    this will regenerate the report


    client side check  remote management, options  generate reports enabled

  • iToaster Level 3 Level 3 (585 points)
    Currently Being Moderated
    Aug 21, 2012 4:20 AM (in response to Me&My_Mac)

    try deleting from your user acount

    beware this will remove your list of computers

    make a backup of it first

  • Seth Robson Calculating status...
    Currently Being Moderated
    Aug 21, 2012 7:27 AM (in response to iToaster)

    I have the exact same problem as the original poster: ever since I upgraded my ARD Admin application to 3.6, I have lost the ability to generate reports from my client systems. My symptoms are the same: after selecting a client system and clicking "Get Report", ARD gets stuck on "Waiting for report data" without responding.


    I have not changed any of the settings on my clients, or in the ARD Admin application. Since almost all of our client systems are still running Snow Leopard, the ARD Client I'm generally trying to connect to is 3.5.3.


    I already tried deleting my file and rebuilding my client list from scratch, but I still can't generate reports. I also tried installing the Remote Desktop Admin 3.6.1 update yesterday, but that didn't fix the issue.


    At least I can still remotely control client systems, push files and software installation packages, and so forth.

  • FSU IT Help Desk Calculating status...
    Currently Being Moderated
    Sep 18, 2012 9:11 AM (in response to Me&My_Mac)


    Having the same issue.

    I have ARD v 3.6.1 running on MT Lion on my local system and 3.5.2 running on a SL Server running as a task server. Neither version I have is able to pull reports from systems. I'm looking to get info from MT Lionand Lion. I am able to control the systems remotly and everything is checked in remote management.


  • larteaga69 Calculating status...
    Currently Being Moderated
    Sep 26, 2012 8:16 AM (in response to FSU IT Help Desk)

    Hi I am having the same issue

    I recently installed ARD 3.6 so I could help my parents with their Mac(10.7.4) over the internet.

    I am able to observe and control their Mac but I am not able to copy files, install packages, run reports, send messages...

    They have a linksys router and the ports 3283 and 5900 are open, TCP and UDP.

    I also opened port 22 and 20 TCP (I read it on one site, and saw the list on the Apple site)

    I am logging in to her Mac with her Admin user-name, and I checked under preference/sharing Remote Login, Remote Management, Remote Apple events and her user is selected as well.

    I ran the Adminstration Settings Report on my Mac(10.8) and the settings are Off for running reports....

    It looks like I have to change some settings on my configuration, but I am not sure how to do it exaclty.

    Any ideas?




  • marimbaguy Calculating status...
    Currently Being Moderated
    Sep 26, 2012 10:38 AM (in response to Me&My_Mac)

    Same problems on our install of 3.6.1

  • Ben Rigsby Level 2 Level 2 (440 points)
    Currently Being Moderated
    Sep 27, 2012 4:31 PM (in response to Me&My_Mac)

    I was having the same problem in my lab at school. I went into the preferences folder on my mac and deleted everything that had Remote Desktop in the name. I had to enter all the passwords again to connect to the client computers but all is well now. I can generate reports and the connection to the clients seems  better.

    Hope this does the trick for you all. I did not need to renter the serial number.

  • pknz4 Calculating status...
    Currently Being Moderated
    Oct 1, 2012 8:59 PM (in response to Ben Rigsby)

    Deleting your file seems to solve this issue, however you will lose your settings.

  • FSU IT Help Desk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2012 11:53 AM (in response to pknz4)

    Tried this a couple times still having the issues. Reinstalled ARD as well. Removed the prefrences from user. just doesnt feel like working. Im keeping at it.


    Glad its working for others!

  • sdmichael Calculating status...
    Currently Being Moderated
    Oct 2, 2012 12:07 PM (in response to FSU IT Help Desk)

    I FINALLY got it all worked out. Unfortunately, removing and other files as some folks have done here did not do it for me. I suspected there may have been issues with the database files in var/db/RemoteManagement/, so I took the plunge, followed the directions here:



    and completely removed ARD Admin from my computer. Then I reinstalled it and added all of my computers back. I only had 52. I'm glad I didn't have hundreds, like at my old job.


    I have reports back now and it's a lot snappier. I'm going to try and put my saved tasks back in using Property List Editor.


    I don't know if just deleting the database files would have prompted ARD to reinstall them anew or if deleing them and running the ARD installer would have reinstalled them. I just decided to cut to the chase and put this behind me.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.