10 Replies Latest reply: Feb 3, 2015 10:33 AM by didgeman
bob.ashrak Level 1 Level 1 (0 points)

My IT folks provided a bootable CD to run an emulation on my iMac.

Didn't work properly (froze).

Could not eject CD.

Tried USB mouse holding down mouse button while restarting.

Did not eject CD.

Open to any options.

(Normal mouse & keyboard are wireless)


iMac, Mac OS X (10.7.4), wireless keyboard and mouse
  • Kappy Level 10 Level 10 (249,660 points)

    Five ways to eject a stuck CD or DVD from the optical drive

     

    Ejecting the stuck disc can usually be done in one of the following ways:

     

    1. Restart the computer and after the chime press and hold down the left mouse button until the disc ejects.

     

    2. Press the Eject button on your keyboard.

     

    3. Click on the Eject button in the menubar.

     

    4. Press COMMAND-E.

     

    5. If none of the above work try this: Open the Terminal application in your Utilities folder. At the prompt enter or paste the following:

     

     

      /usr/bin/drutil eject

     

    If this fails then try this:

     

    Boot the computer into Single-user Mode. At the prompt enter the same command as used above. To restart the computer enter "reboot" at the prompt without quotes.

  • bob.ashrak Level 1 Level 1 (0 points)

    Thanks,

     

    Tried holding down left mouse button but it did not work

    iMac Keyboard is wireless, so I am using standard USB keyboard

    Is there an equivalent key or key combination to the eject key on Apple keyboard?

    Cannot get to menubar

    With non-Apple keyboard, which keys would equate to COMMAND-E?

    Cannot get into OS-X, so cannot use Utilities

    I will see if I can boot into Single-User Mode

  • bob.ashrak Level 1 Level 1 (0 points)

    Kept repeating the process of rebooting and holding down mouse button

    Eventually (after several attempts), the CD ejected

     

    Thanks for your support

  • Kappy Level 10 Level 10 (249,660 points)

    Glad I could help.

  • joshe123 Level 1 Level 1 (0 points)

    Thanks Kappy.

    Just had the same problem with a CD and nothing was working to eject it.

    Came to the Community, as one does and the method of going to utilities and entering the line worked at the fourth attempt.

    That will teach me not to play promotional CDs.

    Thanks again.

    joshe.

  • t. jeremy Level 1 Level 1 (0 points)

    I tried above helpful suggestions, but without success. After trying restart several times and pressing the mouse, I then tried turning the iMac off completely and then restarted -- pushing down on the mouse. The disk ejected first time. I don't know whether that was a coincidence or turning it off made a difference -- but it worked for me.

  • BDAqua Level 10 Level 10 (119,655 points)

    Thanks for the tip!

  • PatrickCollins Level 1 Level 1 (0 points)

    Thank you Kappy. Your terminal script worked for me!

    /usr/bin/drutil eject

    Patrick

  • dfoi Level 1 Level 1 (5 points)

    My thanks for your ways to eject disc.

    Still new to the Apple system........learning new things everyday.

  • didgeman Level 1 Level 1 (0 points)

    Tried all your advice and in the end what freed the DVD was a tap on the top of the computer!!!!