8 Replies Latest reply: Mar 29, 2006 12:34 PM by Paul - UK
Anele Level 1 Level 1 (5 points)
Mysteriously my iPhoto '06 e-mail icon switched from Apple's Mail to Entourage. Cannot make the change in Preferences, nor via the Library or the .plist as I loose a certain amount of photos. Advice will be greatly appreciated as dragging the pictures to desktop as attachments, to use Mail, is getting to be an annoying step.

G5   Mac OS X (10.3.9)  
  • kworley Level 4 Level 4 (2,105 points)
    the place to set the default e-mail application is in the preferences for Mail (yeah, kind of weird, but that's where it is). Check the "General" tab in the Mail app preferences and see what it says... I'm guessing it got switched somehow.

    Katrina
  • Old Toad Level 10 Level 10 (125,810 points)
    Anele:

    Welcome to the Apple Discussions. Make sure your Mail application is not is a folder other the your Applications folder. Also check to see if you have the Entourage application on your HD and if so delete it, unless you need it for something else. In that case you can rename it.
  • Anele Level 1 Level 1 (5 points)
    Thanks Katrina for your suggestion, however I did go to Mail app preferences and the menu had Mail (1.3.11) with an alternative choice of Mail (1.3.9). Tried switching them, but that did not do the trick either. Still stuck with Entourage.
  • lori_diloreto Level 6 Level 6 (17,005 points)
    Did you do an Archive and Install recently and still have the previous System folder on your hard drive? If you did, you need to navigate through that folder and delete the old Mail.app that is in there.
  • Anele Level 1 Level 1 (5 points)
    Appreciate your directions, and followed them twice over, Toad, however, I still am stuck with Entourage. I did move Entourage to the Trash from the applications, at which time I got a Finder message : " Where is Microsoft Entourage, choose application, chose 1 of 2 Mail icons (1.3.11 or 1.3.9), afterwhich I get a bopping Finder message: SArgumentWrongScriptError. From the iPhoto preferences themselves the e-mail chosen for me is AOL to which I don't currently subscribe and of course the others are grayed out. Any other route to go? Thank you.
  • Old Toad Level 10 Level 10 (125,810 points)
    OK. Try the following:

    1 - download and run Pref Setter.
    2 - type "ip" in the text search box at the top.
    3 - click on com.apple.iPhoto
    4 - in the next window type "mail" in the text search box.
    5 - Manually change the string for the key MailApp to "Mail"
    6 - now do a save, Command-S/.

    Now see if you can get Mail to be the default email application.

    If that doesn't work you may have a damaged iPhoto preference file what won't let you change it so you'll have to delete it, com.apple.iPhoto.plist, from your User/Library/Preferences folder and launch iPhoto again and reset your preferences. Good luck.
  • Anele Level 1 Level 1 (5 points)
    Mr. Toad, Sir, it worked! Followed you steps precisely and upon checking with the iPhoto window, there was Mail as my e-mail directive. You put a big smile on my face. Thank you. I did notice that in step #5, under the Value category, Microsoft Entourage was still listed. Is that of any consequence? I'm probably worrying that it'll do that switch-aroo on me. Thank you again.
  • Paul - UK Level 2 Level 2 (200 points)
    Actually you set the email preferences for iPhoto in iPhoto. It's independent of the system mail program. No idea why Apple thought this was a good idea.

    Look in iPhoto preferences...General...Email photo's using...