4 Replies Latest reply: Sep 1, 2012 12:04 AM by William Wood
mwheelerk Level 1 Level 1

I have both a Mac Mini and an iMac.  This problem has actually been present since my original upgrade to Lion but remains an issue with Mountain Lion.  When opening Safari it always opens to the last page I visited rather than opening to the home page and new windows might open on any thing I recently visited instead of the home page.  In Safari Preferences my preferred home page is selected and show.  Under "New Windows Opens With" home page is selected.

 

Why won't Safari on both of my Macs open to the home page?


iMac (20-inch Mid 2007), Mac OS X (10.7.3), Time Capsule, iTunes 10.2.1
Solved by thewhitealbum on Aug 30, 2012 7:18 AM Solved

mwheelerk:  I had the same issue.  Under System Preferences>General, there is a choice of "Close windows when quitting an application."  It was un-checked.  When I checked it, that seems to have corrected the issue and Safari is now opening to my Homepage.

  • mwheelerk Level 1 Level 1

    Help!

     

    I went to the Genius Bar this afternoon.  I thought everything was going to be okay.  The Apple Genius told me about a setting (System Preperences>General>there is a box near the bottom of the window that by default in Lion and Mountain Lion that is checked that starts out...Restore Windows...and I was to uncheck it.

     

    The only problem is in my System Preferences>General> there is no Restore Windows box to check, it isn't there.

     

    We tested this at the store on their MacBook.  With this checked it opened Safari to the last site or sites visited.  With it unchecked it opened to the Home Page selected.  Why in the world do I not have that selection present.

  • thewhitealbum Level 1 Level 1
    expertise.notebooks
    Notebooks

    mwheelerk:  I had the same issue.  Under System Preferences>General, there is a choice of "Close windows when quitting an application."  It was un-checked.  When I checked it, that seems to have corrected the issue and Safari is now opening to my Homepage.

  • mwheelerk Level 1 Level 1

    Yes, that was it apparently.

  • William Wood Level 1 Level 1

    Same for me. As soon as I checked that box, the problem disappeared! So simple, yet so damned frustrating!!Thanks for your assistance, though. Kept me from having a coronary,LOL!