Previous 1 2 3 4 Next 46 Replies Latest reply: Jul 15, 2015 9:13 AM by Ulrich S. Kapp Go to original post
  • embea Level 1 Level 1

    got this solution from  (and it worked for me)..when the "terminal page comes up just click in the box and paste the command (below)..mail is working fine for me now. The last time I used a tip from here, but this time it did not I searched more and found this solution.

    First quit Mail – then:

    For OSX Lion (10.7) and Mountain Lion (10.8) you need to do the following:

    1. Open the Terminal App – You can find this by using spotlight and typing terminal.
    2. Copy and paste this command into the command line of Terminal:
      sqlite3 ~/Library/Mail/V2/MailData/Envelope\ Index vacuum;

    For Snow Leopard (10.6) you need to do the following:

    1. Open the Terminal App – You can find this by using spotlight and typing terminal.
    2. Copy and paste this command into the command line of Terminal:
      /usr/bin/sqlite3 ~/Library/Mail/Envelope\ Index vacuum;

    You should now find that Mail runs much faster.

  • Svante_in_Stockholm Level 1 Level 1

    Hi all.


    I´ve had this problem as well with mail running in slowmotion. Read forums and tried a number of fancy fixes even in the terminal which is scary to me. Last night I sat and looked at the mail window and for some reason dragged the window down. Normally I prefer to switch between apps rather than having lots of windows visible at the same time. When the window after a couple of minutes moved down a bit I discover there was a similar window behind, hidden by the one I just managed to move. To make this slowmotion story shorter: There were maybe a hundred mail windows on top of one other. How that had come to be I don´t know. When I had managed to delete them one by one everything was back to normal. Hope this help someone, at least it helped me!

  • sberman Level 7 Level 7

    Svante, to avoid this in the future, I suggest opening System Preferences (under the Apple logo in the menu bar), choosing "General", and checking "Close Windows When Quitting an Application".

  • CharisLi Level 1 Level 1

    embea's solutions seems to work for me~ Just don't know what's the mechanism here?

  • pahammer Level 1 Level 1

    Just upgraded to OS X Maverick (10.9) and my Apple Mail was terribly slow. Rebuild the mailboxes, as already  mentioned by others for older OS X versions, did the trick.


    Go to "Mailbox" in the menu bar and choose "Rebuild".

  • incinerate Level 1 Level 1

    I also have this incredibly irritating problem. I basically can not use my mail app, because when it's running it(and my whole mac) get's stupidly slow very fast.


    I had this problem before as well, I think I managed to fix the problem that time by randomly deleting some (corrupt?) mails.


    I have no copy of mail.plist in my system.

    I have rebuilt my inbox with no results


    I don't know how to fix this, it's really bothering

    Apple should come up with a solution.


    I have: Snow Leopard v. 10.6.8.

  • susanfrommartinez Level 1 Level 1

    This solved my problem. Thanks! I also tried to rebuild my mail and it erased everything in my inbox. THankfully, I also have it on icloud so I can recover it. Now I just have to figure out why my iphone, macbook air and intel imac are not seeing the same mail.

  • landonkk Level 1 Level 1

    Add me to the list of people who had this problem.  I am running 10.8.5.  Nothing had worked until I followed embea's instructions.  I have no idea what it did but Mail is running somewhat normal now.

  • xskx Level 1 Level 1

    Thank you Embea! I'm been loking for a answer for this and it's been killing me! Finally some progress.

    I'm amazed, that this big problem still exsists and apple lets this happen.

  • Mateod Level 1 Level 1

    I used the index vacuum command noted above. Made the mail run much faster. However, I noticed that spotlight is now rebuilding its index. Fine with that if the mail program keep running at speed. Hope Mac is not becoming the new Windows, where it's a succession of chewing gum and bailing wire fixes to keep it riding between the ditches.

  • Apple Orange Level 1 Level 1

    My icloud is now unusable. The reason I switched to Apple was because of problems with Windows crashing and going slow. It seems that the technology behemoths just can't help but get complacent.


    I don't want to know how to improve icloud. How do I extricate myself from it?


    Any advice or ideas are welcome.


    Old Apple Fan fast becoming an Android user

  • sberman Level 7 Level 7

    Apple Orange wrote:


    I don't want to know how to improve icloud. How do I extricate myself from it?

    Turn it off -


    On your Mac, System Preferences > iCloud > Sign Out


    On your iPhone, iPad, etc., Settings > iCloud > Delete Account


    Enjoy Android.

  • Apple Orange Level 1 Level 1

    Ha ha! Great solution! Thank you suberman, I'd never thought of that.

  • dweezilmoon Level 1 Level 1

    I just tried the command line for OSX 10.9.2 Mavericks and it still seems to help! Program starts faster en checks mail faster... now I just hope that nothing was unknowingly messed up. So far so good! So, that was:  sqlite3 ~/Library/Mail/V2/MailData/Envelope\ Index vacuum;

  • wolfedales Level 1 Level 1

    Ok, it's not funny anymore. I'm using Mail Version 7.3 (1878.2) on 10.9.3 and it working really really slow. I'm doing every day vacuum but it not help too much.

    I never had a problem 3-4 years ago! Is there any way to improve Mail? I already tired vacuum and rebuild options, I even deleted from my imap server a lot of e-mails but problem still exist. This is nightmare, I cannot work!