10 Replies Latest reply: Apr 24, 2013 2:37 AM by tobbiii
wsylvest Level 1 (0 points)

When mirroring from my MacBook Pro Retina to my Apple TV 2nd Gen (Software version 5.0.2) the resolution adjusts but the Apple TV screen goes black, system sounds stream. When I deselect audio streaming the Airplay icon changes color. I have tried manually setting color, resolution, etc on both Apple TV and Macbook Pro. It appears that mirror is enabled for audio only. I can however stream music and video from Apple iTunes on the computer fine. But the mirroring function does not appear to have video. Apple TV is hardwired to the network, Macbook Pro is connected to Airport Extreme through Wifi.


How do we enable video for Airplay mirroring?

AppleTV 2, OS X Mountain Lion
  • lowry0031 Level 1 (0 points)

    I have the same setup as you, Retina and 2nd Gen ATV. With my old MacBook Pro, I was able to mirror by clicking the icon and selecting your ATV. But ever since I got the Retina, I am experiencing the same problem as you. It should just work as your are doing it right, but there has to be a bug with the 2nd ATV and the Retina. The 2nd Gen, ATV is only 720p, so we can assume if you get the latest ATV (1080p), it would work (not sure if you have to have a 1080p TV).

  • wsylvest Level 1 (0 points)

    Upgraded to 10.8.1 still have the same issue. I am wondering if this is a problem between the MBP Retina and my Airport Extreme which is a 2nd gen Airport Extreme. It is still on my list to hardwire into my network and see if I can confirm or rule out the access point. Airplay works fine for iTunes, just not desktop mirroring.

  • wsylvest Level 1 (0 points)

    Ruled out the 2nd gen airport extreme, and found a solution.


    The solution I found to work was to remove all the items from both LaunchAgents and LaunchDaemons in the system Library folder. I created backup directories and moved items into their respective backup directories. Testing moving back confirmed the issue. I have not isolated the exact incompatibility but started to narrow down. Parts of xwindows have not been ruled out. Parallels is also a suspect. Will post again if able to confirm.

  • lowry0031 Level 1 (0 points)

    That fixed it for me too! Thanks a bunch!

  • digitalcore_ Level 1 (0 points)

    I don't have a Retina, but I do have a 17inch MBP with high resolution.


    For me, Problem solved... sorta!



    It appears that Parallels 7 is not compatible with Airplay Desktop Mirroring in ML


    If you remove this file com.parallels.desktop.launchdaemon.plist






    then reboot.

    ATV3 now works again with Airplay Mirroring.

    However, it breaks Parallels.  And you simply cannot put the com.parallels.desktop.launchdaemon.plist file back inside /Library/LaunchDaemons.  You need to re-install Parrallels. Could be a permissions thing, but I tried to repair permissions and follow Parallels instructions on how to start and stop the service. Even chown root and chgrp system. But only a ReInstall fixed Parallels. Which then kills Airplay Desktop Mirroring.


    I Hope this helps...  If you don't use parallels, then it still could be something in the /Library/LaunchDaemons or /Library/LaucnhAgents directories

  • lowry0031 Level 1 (0 points)

    Now my MacBook ProRetina is stuck in boot after doing this. Help!


    From Verbose mode...


    BootCacheControl: Unable to open /var/db/BootCache.playlist


    Repaired Permissions in Disk Utility and Repaired the Disk. Still no dice

  • conwaycd Level 1 (0 points)

    I am having the same issue. Scared to touch those folders though!

  • School Psych MN Level 1 (0 points)

    My Apple TV was driving me nuts. I have a brand new 3rd generation Apple TV and a 15" Macbook Pro Retina and an iPad 3. My iPad was mirroring just fine. It'd show up on my telvision no problem, but my Macbook would not. Whenever I tried to get it to connect to my Apple TV, my Macbook would respond by switching screen types, but my TV would either do nothing, go black, or after about 10 seconds throw up a static picture of some image of my desktop. The sound would come through just fine, but that was it.


    I tried all the "helpful" hints offered on the Apple site, but nothing worked. I even tried moving some files from my Launch folders in the systems library, but nothing helped. Then after what felt like weeks of work I tried the obvious. My Apple TV was on a wireless network, so I bought an ethernet cord and plugged it into the Apple TV and my router. Now it streams perfectly.


    Score one for the Ethernet cord, huh?

  • robertmccormick Level 1 (20 points)

    THANKS I was having the same issue as you.  After using the migration assistant to transfer from my older mac I got an error that VMWare was not compatible with the OSX on this new mac (i was using an older vmware version.)  After reading your post I searched and found a vmware file in /Library/LaunchDaemons, deleted it, rebooted and now everything is working!

  • tobbiii Level 1 (0 points)

    Hello digitalcore,

    I have the same Problem, it broke my parallels, saving now my Windows instalation, but what happens when I reinstall Parallels? Does it break the mirroring again?


    Prallels or Airplay Mirroring??