13 Replies Latest reply: Oct 11, 2013 7:59 PM by lannyv Branched to a new discussion.
Rayliegh Level 1 (0 points)

It is sad that I have upgrade my Mac from 10.4.11 Tiger G4 PPC now I have to upgrade them again since most plug-in are outdated and could not use my mac properly.

 

Do I just buy the Snow Leopard CD and install this my Mac PPC ? Then after it will be Intel mac not PPC anymore?


Mac OS X (10.5.8)
  • John Galt Level 8 (45,943 points)

    Snow Leopard requries an Intel CPU. There is no way to upgrade a G4 to some other CPU.

     

    You can upgrade to Leopard if you want, but obtaining an installation disc at a reasonable price is going to be a challenge.

  • Rayliegh Level 1 (0 points)

    What I meants is I already upgrade my mac from 10.4.11 G4 into Leopard Mac PPC 10.5.8 G5...

     

    Now Im just wondering if Mac Leopard 10.5.8 G5 can be upgrade into Snow Leopard? As in Installing Snow Leopard CD...

  • Niel Level 10 (298,407 points)

    No, it can't. Mac OS X 10.5 is not G4, G5, or Intel; it is an OS.

     

    (68945)

  • Rayliegh Level 1 (0 points)

    Whatever... Its says on my MAC and Quote... "Mac OS X Server Version 10.5.8... PowerPC G5"

     

    Can my version of Mac PPC be upgrade into intel program?

  • Niel Level 10 (298,407 points)

    As stated above, no.

     

    (68946)

  • John Galt Level 8 (45,943 points)

    If you're running OS X 10.5.8 that's as good as it gets for your PowerPC G5.

     

    The PowerPC G5 is your CPU (hardware). OS X 10.5.8 "Leopard" is the operating system (software) it runs.

     

    Snow Leopard was written for an Intel CPU. As Niel says, the answer to your question is no.

  • MlchaelLAX Level 4 (2,022 points)

    Why do you want to run Snow Leopard on your PowerPC Mac?

  • Brendon Dellar Level 1 (85 points)

    You can't upgrade to snow leopard. Your mac is too old. You need to buy a newer one.

  • amjidmaster Level 1 (0 points)

    hiCopy of 10180 copy.jpg

  • lannyv Level 1 (0 points)

    Question was asked "why do i want to upgrade my G5 PPC to Snow Leopard", answer: the fine folks at Apple have forgotten their dedicated customers. With the introduction of iOS 7 for the iPhone they, Apple failed to inform that to use iOS 7 on the cell phone with iTunes to update and backup you must have iTunes 11.1 and in order to load iTunes 11.1 you must have OS higher than 10.5.8, which is Snow Leopard. Funny that their work around was to use a windows machine. They will support Windows users but have thrown the Mac folks out with the bath water. I guess iOS 7 is not really for free. Time to buy a new computer, MAC or Windows whats a user to do.

  • John Galt Level 8 (45,943 points)

    lannyv wrote:

     

    ... Time to buy a new computer, MAC or Windows whats a user to do.

     

    I have just the thing for you lannyv: http://www.commodoreusa.net/CUSA_C64.aspx

  • moofmama Level 1 (20 points)

    Wow, you have had that puppy for a long time.  Apple hasn't made PPC machines since early 2006.  Realistically, you would benefit greatly by upgrading as the performance difference will be gigantic. 

     

    Supporting the PC's are a bit easier as those users update hardware about every 2 years.  It is almost a requirement for PCs as the things won't run anything worthwhile after the release of a subsecquent version of Windows.

     

    Your Mac has had a good run and lasted a long time.

     

    Not sure if a Commodor is exactly what you need, but there is a new Mac Pro awaiting it's debut.

  • lannyv Level 1 (0 points)

    I understand it's old but like voyager still does all I need a computer for. My complaint is Apple does not advise when you update one thing, in this case my iPhone then everything else has to be updated. I guess it's apples strategy to get people to upgrade. Kinda crappy to find out your Mac just became useless after you upgrade the iPhone OS which by the way is not all that great. My days of having to have cutting edge tech are gone. Still have my "Lisa" maybe there is an upgrade for it.