Previous 1 2 3 Next 98 Replies Latest reply: Dec 8, 2013 9:46 PM by Patrick123
Rumboogy22 Level 1 Level 1

I am getting the following error when running Disk Utility (under ML) on an exteral USB hard drive:

Error: Partition map repair failed while adjusting structures to fit current whole disk size.


I get thsi when I ask Disk Utility to "Repair Disk" at the top level of the disk hierarchy (i.e. not on one of the partitions within the disk but on the disk itself).  I was not getting this error with Lion on the same disk before I upgraded from Lion to ML.


It seems like a bug in ML.  I found websites where they suggest that you just run Lion's Disk Utility and it will show the disk to be fine.


Any thoughts?

MacBook Pro, OS X Mountain Lion
  • VikingOSX Level 6 Level 6
    Mac OS X

    Is this a hybrid disk with Windows NTFS and Linux partition types which are incompatible with Disk Utility?


    If not, try a different USB port, and then verify/repair on individual partitions to see if your error message is reproduced, and if so, which partition?


    If the data on the drive is crucial, you should invest in DiskWarrior (alsoft dot com) and run it in recovery mode on this drive. I use DiskWarrior and there have times when it proved invaluable.


    If the data is not crucial, try reformatting the drive as a single partition in Mountain Lion, with GUID option and HFS Plus Journaled.

  • Rumboogy22 Level 1 Level 1

    No NTFS or anything else non-Mac.  I booted into a old Lion partition and ran Disk Utility and found no problem with this USB drive's partitions.


    I then called Apple support and spent an hour on the phone with them.  They essentially did not have a clue.


    I think this is a bug in ML and there is no problem with my USB drive.  But it is an obscure bug so not many people are hitting it.  The USB drive that I am seeing this on has had lots of changes over time.  I have added and deleted paritions (6 currently).  Also when I upgraded to Lion it added hidden recovery partitions.  So much has happened to this disk and something along the way is not agreeing with ML.


    All the partitions on this USB disk come out clean when running "Repair" in either Lion or ML.

  • Cowtipper Level 1 Level 1

    I am having what seems like the identical problem (with a Hitachi Touro 2TB USB  Disk). And I have scrubbed the disk, reformatted with with a single partition and ... still the error persists.



  • JC-Avila Level 1 Level 1

    I have this problem with a Seagate GoFlex Desk 3TB USB 3 in a MacBook Pro Retina, I'm really angry because this bug has generated in some important files has been corrupted.

  • Rumboogy22 Level 1 Level 1

    This problem has not caused me to lose data, it is just irritating that a newer version of Disk Utility flags a disk as having an error while an older version says there is no error.

  • Krutsch Level 1 Level 1

    I am having the same issue with the Seagate GoFlex Desk 4TB Firewire 800 in a early 2011 MacBook Pro 17".


    I deleted the partition, recreated the partition as GUID Partition Table, HFS+ Journaled and the re-ran the verify from the top-level and see the same error - with no data on the disk (other than what's placed on there by Disk Utility).


    If I ignore this warning and copy a bunch of data on the disk, it eventually gets corrupted and I lose everything.


    One thing I've noticed is that if I explicitly unmount the drives, prior to shutdown, everything is fine.  If I forget and leave the drives mounted (I have a 3TB model and a 4 TB model that are Firewire-chained), on a subsequent reboot the 4TB drive will report that it's unreadable and the fun starts over.


    This was all new to Mountain Lion - man, I am sooooo sorry I upgraded to ML - this is one many serious problems I am having with ML (the others being Exchange support and external screen support w/ mission control). 


    I think Apple has finally released their own version of Vista.

  • zinnerear Level 1 Level 1

    I am having the identical problem with a 3 TB Seagate GoFlex Desk Media drive.  This only occurred after upgrading to ML.  What prompted me to use Disk Utility is that I cannot transfer files to the drive any more.  Wish I had stayed with Lion -- no problems and every app seemed to run faster, I had more confidence.

  • endlessmik Level 1 Level 1

    Can I just add a "me too" to this problem. Happening on a 3TB Seagate USB3 drive on my 2007 era MacBook Pro. Could it be something to do with a USB3 drive plugged into a USB2 port?

  • Krutsch Level 1 Level 1

    So, I finally seemed to have resolved things with the Seagate 4TB Firewire external drive.  If you Google about, you will find a thread on Seagate's own support forum that describes how to disable the sleep function on the drive.  You CANNOT ALLOW THE DRIVE TO SLEEP WHILE CONNECTED TO YOUR MAC.


    After a lot of reading, here's what I think is happening: the drive goes to sleep, after some period of inactivity, and when you shutdown your Mac, OS X tries to write something to the drive as part of the dismount / disconnect / shutdown process.  That fails in some manner, leaving the drive 'corrupted' at the filesystem or partition level.


    Then, on the next boot-up, Mountain Lion tells you that it cannot repair the drive and it mounts as read only.  Your only fix at that point is to re-partition / re-format and start over (which is big fun with 3TB of data to copy back on to the drive).


    If you prevent the drive from sleeping, whenever it's connected to the MacBook, then the above process doesn't occur and voila, the drive just works.  So far, I haven't had any problems with about a week of starting / shutting down my MacBook connected to the offending drive (translation: I was going to return the drive, but the problem is clearly with Mac OS X Mountain Lion).

  • endlessmik Level 1 Level 1

    So how do you prevent your drive from sleeping?

  • Rumboogy22 Level 1 Level 1

    I don't.  This is not the cuase of the problem.

  • Rumboogy22 Level 1 Level 1

    I don't see how this relates to the problem.  The issue I am having is with a WD drive with no drivers installed.  Just took the bare drive formatted it under SL and have been using it withoug problem.  But now with ML, when I run Disk Utility repair at the drive's top level I get an error. But if I switch back to Lion I don't get the error.  Clearly this is a bug in ML's version of Disk Utility - a disk which is formatted and is valid under an earlier verssion of Disk Utility starts flagging errors in a later version.


    Note also that although I get this error from Disk Utility, the disk does not show any problems at all and has been working flawlessly under SN, Lion and now ML.

  • j0wens Level 1 Level 1

    Have you tried checking the disk with another utility?  I discovered this error message when trying to repair permissions trying to figure out why Timemachine was telling me the drive was read only.  I have been using it as a timemachine back up since March. I have since run Techtool on the drive and it is comming up with bunch of broken or incompatible files on the drive from lion back ups.   It still discovering them but they range from various image filetypes to plists.


    I ran Techtool on a whim.  After restarting the mac it was able to see the drive as writable and did a timemachine back up uniteruppted.  If it's corrupted as some clain I ahve yet to see. Iamwaiting to see what Techtool says...

Previous 1 2 3 Next