Previous 1 2 3 4 Next 98 Replies Latest reply: Dec 8, 2013 9:46 PM by Patrick123 Go to original post
  • polyglotinc Level 1 Level 1

    I have the same problem. I have a couple of WD Ext HDD 1021 drives that were formatted and formerly used with no complaints on Leopard.  Just moved everything over to a new 27" iMac with Mtn Lion. On the drive that has a single partition, no complaints from Disk Utility. The other drive has 2 mac partitions and I get the same error as other people. The volumes have no errors so I am leaving it alone until something definitive happens or gets published.

  • Luigino il Pazzo Level 1 Level 1

    Have run ML since the end of July and only now has Time Machine reported that it cannot write to my external 2TB Iomega. TechTool Pro reports no errors but neither Disk Utility nor Time Machine want to play with it.


    I have reformatted, repartitioned and still get the partition map error.


    I wouldn't mind so much Disk Utility flagging an error when there isn't one but as TimeMachine will not write to the disk I'm stuck without my backup.

  • Rumboogy22 Level 1 Level 1

    The new release of 10.8.2 did not change anything for me - still get the same error message when I run Disk Utility at the top level of my USB drive.


    My plan, when I have the time, is to copy all the data off this drive, reformat it under 10.8.x and then put the data back - of course checking with Disk Utility.  If I ever get around to doing this I will post the results here.

  • Avendanio Level 1 Level 1

    I have tried reformatting my 2TB iOmega but it still doesn't work. I connected it to 10.7 Lion and ran disk utility which reported no errors. I reformatted and connected it to 10.8.2. It worked! However, after doing the initial backup it reports that it cannot backup to the damaged disk. Disk Utility on 10.8.2 reports '

    Error: Partition map repair failed while adjusting structures to fit current whole disk size.' again.

  • Cowtipper Level 1 Level 1

    Rumboogy22 and Avendanio, et al.,


    I have done all these things with my Hitachi Touro 2GB USB 3 drive and none of them have worked. I was hopeful that something might have changed with 10.8.2, but no. If I do a disk repair under Mountain Lion, I get the error; if I do it under Snow Leopard, no error. Run it the reformatted disk through Disk Warrior, no errors. Hook it up to Airport Extreme and try to use it for Time Machine: it simply doesn't work more than once, tell me that the existing file cannot be fixed and that it wants to create a new one—over and over again. IN fact, right now it's trying to mount the disk over the wi-fi connection and it's just spinning and spinning.


    The fact that so many of us are experiencing such a consistent set of errors across a variety of external HDs indicates that, really, this is Apple's problem.

  • cRose007 Level 1 Level 1

    short form:  me too!

    longer form:

    I have an exsternal 3TB seagate goflex desk media usb drive.  3 partitions on it, one of them dedicated to time machine backups.  all of a sudden this morning, time machine backups started failing, claiming the drive was read only (does not appear to be true).  suggested to run disk utility, which fails at the the drive level with the same comment of :

    Error: Partition map repair failed while adjusting structures to fit current whole disk size.


    This does seem like an apple issue, but all I know for sure right now is I'm stuck without backups and I can't see how to fix this myself.  suggestions?

  • rrgomes Level 1 Level 1

    And, again: me too, and also on a Mountain Lion system.  As with several other people here I'm using a Seagate 3TB GoFlex USB 3.0 drive.  Mine is connected to a USB 3 port on a CalDigit PCIe card in a 2008 Mac Pro. There's one partition on the drive, devoted to Time Machine backups.  Suddenly, this morning, TM started to report "ran out of space unexpectedly" and since then has been unable to complete any backups.  And Disk Utility reports that error which is in the title of the thread.


    Very frustrating, and I'm not sure at all how to proceed.  I also run daily backups with CCC but I rely on TM as well and I need to get this working again.  I don't know if the file system on the TM drive is actually corrupted at this point.


    It's not entirely clear from what I read here: are we all using USB 3, or are people seeing the same problem with other interfaces as well?

  • Luigino il Pazzo Level 1 Level 1

    Mine is a 2TB Iomega connected via USB 2 to a 2009 iMac 27".

  • notrslau Level 1 Level 1

    Ditto.  Not fixed in 10.8.2.  I have a 3TB Seagate Backup Plus, with 4 partitions (partition #1 boots Lion), connected via FW800.  I was bitten by this bug when I tried to upgrade from Lion to ML.  After the upgrade downloaded and rebooted, the installer would not allow me to select the 3TB drive as the target.  Booted 10.7 installer from a USB stick and the 3TB drive verifies and repairs just fine.  Plugged 3TB drive into a 10.8.1 machine and Disk Utility fails to repair but verifies just fine.  Even asked an ex-Apple engineer at work take a look and he was stumped.


    From all of the other posts, it seems the problem is either with USB/FW connected drives and/or with >1TB drives.  I had no problems upgrading from Lion to ML on a half dozen other Macs that had internal SATA drives 1TB or smaller.  My MacPro1,1 has a 2TB drive but cannot (easily) run ML.  I am guessing many people have modern MacPros with a >2TB boot drive, and successfully upgraded to ML?  There would probably be far more complaints if that didn't work.



  • rrgomes Level 1 Level 1

    I disconnected the misbehaving disk from the USB 3 port, connected it to a free USB 2 port, and ran Time Machine again.


    TM decided it had to do a "deep scan" which always take a long time, and then it went into an iteration removing old backups, which also took a long time.  The whole process basically took all night, but by the morning it had successful backed up again after removing a couple of older backups.


    It continues to behave properly, i.e. to back up without error.  I have NOT tried running Disk Utility because I don't want to risk perturbing this right now.


    I'm not sure what to conclude from this.  I'd certainly prefer this drive to be connected to the much faster USB 3.0 interface, but for now I need it functioning properly even if more slowly.  And that sort of thing matters less with a TM backup than it does with other things.

  • Krutsch Level 1 Level 1

    I am using Firewire 800 and have three drives daisy-chained (3 TB Seagate GoFlex, 4 TB Seagate GoFlex Backup Plus and a 4-bay Drobo).  I recall posting something on this already, but the bottom line is this: you CANNOT ALLOW your external Seagate drive to sleep on its own - Mac OS X ML will correct the drive when I attempts to write to the drive just prior to shutdown - the drive takes too long to spin up and something goes wrong.


    I noticed that when I manually unmounted the drives and disconnected the Firewire cable, before shutting down my Mac, I never had the problem.  Failure to do this would, eventually, cause all of the problems folks are describing above (read-only mounting on reboot and inability to correct with Disk Utility).  I doesn't matter if you wipe / re-partition and reformat.


    So... all of my problems went away when I performed the following steps (I found these on a Seagate support forum):


    1. Connect the drive (I use FW800)


    2. Install the included Seagate Drive Settings software and make sure you reboot your computer afterward


    (Software also available from Seagate with your drive)


    3. Seagate does not make the next steps obvious, you have to search for them.


    Confirm that your drive is connected directly and correctly.


    The drive must be connected directly to the Mac's USB or Firewire port to ensure that the spin-down command is sent to the drive. Do not connect the drive to a USB or Firewire port on the computer monitor or on the keyboard.


    Click on the Apple > Choose System Preferences.


    Click on the Energy Saver Icon.


    There is Check box that says Put the hard disk(s) to sleep when possible.

    Check the box here to set the drive(s) to sleep after 10 min of inactivity.

    (Removing the check mark will disable disk sleep.)


    Check what the disk sleep settings are now (if desired).


    Click on the Apple > About this Mac.


    Open the System Profiler.


    Click on More Info.


    Click on Power in the left column. The current Disk Sleep time is displayed in minutes on the right.


    4. Another absolutely critical step that Seagate does not tell you anywhere is that in order for the firmware update from the last step to actually take effect (regardless of what the System Profiler says), you must power the drive down (disconnect the power supply from the hard drive and wait 10+ seconds) and then plug it back in.


    5. Erase the drive using Disk Utility and partition as desired (you may be able to get away without this but this is what I did and it worked)


    6. Go back to System Preferences, select Time Machine, click Select Disk and choose your new Seagate drive.


    Yikes!  However, when I did the above steps, everything works and I can boot / reboot / whatever without corrupting my Seagate drives (I never had these issues with my Drobo) and I have since filled all of the Seagate drives with data - no issues and they checkout fine with Disk Utility.

  • rrgomes Level 1 Level 1

    What if I just tell OS X never to let any disks go to sleep? Will that solve the problem as well?

  • Krutsch Level 1 Level 1

    No, because the problem stems from the fact that the drives are going to sleep on their own, not because Mac OS X is telling them to.


    To be honest, I don't think anyone knows what's really going on, but the procedure I outlined above has proven reliable for me over the past few weeks.


    Maybe things will get better in the future, but the issues I had with external monitors, external firewire drives, Exchange support in Mail, etc, etc, means that I will no longer jump on the upgrade bandwagon until a few months have passed when 'Mountain Snow Leopard' comes out, or whatever the next incremental update is called - Apple has lost their touch, in this regard.

  • Rumboogy22 Level 1 Level 1

    We are getting off topic here.  Drives going to sleep and causing trouble is a whole other problem - and topic.  I have had that issue too, but not with this drive.  I encourage those who are having the sleep problem to start a new thread to cover that specifically.


    This thread was started to discuss the problem with ML Disk Utility giving the following error where Lion did not have this behavior:


        Problems were encountered during repair of the partition map

        Error: Partition map repair failed while adjusting structures to fit current whole disk size.


    I am still getting this error with the latest update to ML.  I am debating if I should move the data off the drive, reformat under ML and move the data back on.  It is very time consuming to do this and it is not clear it will solve the problem given what some of you have posted.

  • CraigFromUK Level 1 Level 1

    I'm having the same trouble with my brand new GoFlex Desk for Mac 3TB. It's telling me...


    "The disk you inserted was not readable by this computer"


    With options to either Initalize, ignor or eject.


    Has anyone found a solution for this? I can't access my drive at all, not even to drag the files off to reformat the drive :-/



Previous 1 2 3 4 Next