Previous 1 2 3 4 5 Next 98 Replies Latest reply: Dec 8, 2013 9:46 PM by Patrick123 Go to original post
  • Avendanio Level 1 (0 points)

    That's not quite the problem we're discussing here.

     

    However, I thought I had a solution to the partition problem. I used Disk Utility to change the partition map from 'Current' to '1 partition' (the Current setting was one partition anyway).

     

    Repartitioning solved the problem and my Time Machine backup started again with a full backup.

     

    After five days of backing up, Time Machine goes back to telling the disk is not available and Disk Utility goes back to

    Error: Partition map repair failed while adjusting structures to fit current whole disk size

    So, repairing the disk with Disk Utility on OSX 10.7 works, as does repartitioning with Disk Utility on OSX 10.8.2. But neither fix holds for more than a few days before the problem resurfaces.

  • CraigFromUK Level 1 (0 points)

    Yeah, I get the same result on trying to repair the permissions, stating that it's a

    Error: Partition map repair failed while adjusting structures to fit current whole disk size

     

    I'm heading into the mac store tomorrow to resolve it all as this was caused I believe from my mbp consitantly kernel panicing out. Frustrating as I've never had this problem with apple and I've over a 100 gb of client information at stake on this external drive.

  • Rumboogy22 Level 1 (0 points)

    It seems many people are having issues with Time Machine not being able to use there disk.  I am not having that.  My only symptom so far is that I get the error message with Disk Utility.

  • Rumboogy22 Level 1 (0 points)

    CraigFromUK wrote:

     

    I'm having the same trouble with my brand new GoFlex Desk for Mac 3TB. It's telling me...

     

    "The disk you inserted was not readable by this computer"

     

    With options to either Initalize, ignor or eject.

     

    Has anyone found a solution for this? I can't access my drive at all, not even to drag the files off to reformat the drive :-/

     

     


    This is not the same problem.  What you are seeing is a disk that is not in a format that the Mac can read.  If you don't have any data on it then go ahead and initialize it.

  • CraigFromUK Level 1 (0 points)

    I see.

     

    I believe that the problem on the external drive was caused by the Kernel Panics previously.

     

    I actually have my entire life on this external drive, as I bought it last week to transfer everything from computer onto it... and then delete what was on my comp to free up space. I did this because of the crashes and I didn't want to lose eveything

     

    Any ideas what to do next and how to get the external drive working again?

  • CraigFromUK Level 1 (0 points)

    I took my computer into Apple who said that it was my RAM that the they thought was most likely to be causing the problem based on my Kernel Reports being so varied. I upgragded the RAM 7 months ago so I just put my old apple ram of 4gb back in.

     

    So far so good. Fingers crossed.

     

    As for the one week old seagate goflex 3T external drive... that's apparently pooped and I have to take it to some hard drive recovery center - non apple affiliated.

     

    Grrrrr

  • Petelab Level 1 (0 points)

    I am getting this same error message in disk utility. On a 2011 iMac running ML. Trying to partition a 3TB  Seagate Backup plus external HD for Mac firewire 800. It's a brand new HD.

    Disk utility won't let me make any partition bigger than 1.5 TB. I want to set up a 2.9 TB partition , and a smaller 10GB partition.So I ran" Repair Disk" and got this same message.

    Called Applecare and they're telling me it's a defective HD!!

  • CraigFromUK Level 1 (0 points)

    yeah, after reading alot of reviews, this product seems to have a lot of bugs! :-/. Taken mine back after loosing info on it. Apple couldn't repair it so gave me back my money.

     

    I'd look into another drive if I was you.

  • Avendanio Level 1 (0 points)

    As a number of reports wer about the size of the partition, I repartitioned yet again. This time into two 1GB partitions and TimeMachine would alternate backing up between one and the other. That workef for a whole week but I just got the dreaded

     

    Error: Partition map repair failed while adjusting structures to fit current whole disk size.

     

    yet again, after TimeMachine reported, as before that it couldn't write to a read only disk.

     

    Back to square one.

  • robfromoswestry Level 1 (0 points)

    2 Gb HitatchiG ST external drive. Same issue/s:

     

    Partition map repair failed while adjusting structures to fit current whole disk size.

     

    and

     

    Time Machine (TM) fails to backup, after the initial backup, when disk is in Airport Extreme (AE).

     

    I've just repaired the Volume sucessfully in Disk Utility, but the error persists when attempting a repair on the disk itself. I will be trying the disk again for a TM backup on the AE.

     

    Will report back...

  • robfromoswestry Level 1 (0 points)

    I forgot to mention that I also Changed the root permissions to allow 'everyone' read and write access. I also retyped the user account passwords in the Airport Extreme disk sharing configuration.


    Despite the persistent error in Disk Utility (on the disk itself, not the volume), TM is backing up sucessfully via the Airport Extreme.

     

    Hopefully, this will continue to function correctly...

  • robfromoswestry Level 1 (0 points)

    Unfortunately, the issue is not resolved. I therefore moved all data from the disk and performed a 'zero out' erase, which took 20 hours! Disk utility continues to report the same error:

     

    Error: Partition map repair failed while adjusting structures to fit current whole disk size.

     

    I will try the disk back in the AE, but I am not hopeful.

     

    Any joy anyone?

  • Rumboogy22 Level 1 (0 points)

    I had a similar plan.  I cleared out a WD 2T disk and started to copy the partitions using Disk Utility "restore" function from the old WD 3T disk to the new blank WD 2T.  When I got to my active TM partitions I get the message about "input/output" error.  So now I am stuck.  My TM disk has an error at the top level when running "repair" in Disk Utility and I can't copy all the partitions off - at least not using Disk Utility.

     

    I think I will next try copying the TM partition off using the Unix dd command.  If that fails perhaps I will buy DiskWarrior.

  • Cowtipper Level 1 (0 points)

    I doubt you'll have any luck with Disk Warrior—I haven't.

     

    Sigh.

     

    So, owing to some other issues related to the ML upgrade, I completely wiped my McBook Pro and reinstalled all my apps and the like. The good news? It seemed to have solved those problems. The bad news: It hasn't affected my ability to format and use this Hitachi Touro 2TB drive with Aiport Extreme.

     

    I did however set it up as a Time Machine drive via the USB connection and that sort of works: TM will back up to the drive a few times and then seemingly the drive jams and my laptop won't recognize it unless I unplug the drive, turn it on and off, and reconnect. Then it works fine for TM—for a while it seems.

     

    I just ran Disk Utility on the drive and, oddly everything checks out if I just verify and repair the drive; but if I check the partition, I get the same error message: Error: Partition map repair failed while adjusting structures to fit current whole disk size.

     

    Because I wanted to be able to back up via the wi-fi my real solution was to just go buy a Seagate drive. It's working fine. 

  • Tim Krynicki Level 1 (30 points)

    I am getting the same error. Any solution yet?

     

    Running 10.8.2 ML, iMac i5 with a Seagate 3tb external on USB 2.0.

     

    What I am scared about is this is an exact mirror of my main, which is the same exact drive, model and size. I bought them at the same time.

     

    What's odd is the main is not having any problems. I did a repair on it and it came back with no errors. The difference between the two is I keep the main plugged in and on at all times. The backup is an offline mirror that I sync with cronosync every couple weeks or so.

     

    I started looking into this problem because chronosync would not sync files, giving me an error on any file that it needed to put into the trash (chronosync does a sync and if it finds an out of date file, it trashes it and replaces it with the new one from the main).

     

    Now I can't use chronosyn and have to do complete backups of folders (which are terebytes and also puts extra strain on my main drive).

     

    What I am thinking of trying is putting my backup into the main cradle. These seagates have the removable dock, and I thought maybe it is the dock.

     

    Man I hope we can figure this out.

Previous 1 2 3 4 5 Next