Previous 1 2 3 4 5 6 7 Next 98 Replies Latest reply: Dec 8, 2013 9:46 PM by Patrick123 Go to original post
  • Tim Krynicki Level 1 Level 1

    I just read here, 0-8-and-4TB-Goflex-desk-for-mac-with/td-p/168362


    This guy was able to repair it through Lion.


    I don't have a machine running Lion but what I might try is botting from a Lion disk I made and using disk utility from that. Hopefully that will do it.


    I might also try doing a command-r boot and using ML disk utility through that.


    I also have an SL disk I could also try using to do a repair.


    I will report back what I find. My only worry is how to prevent this from happening again, as I don't want to have to keep repairing this drive to backup to.

  • Mac Admin1 Level 1 Level 1

    Following the above suggestion I run a 'Repair Disk' command with Disk Utility under 10.7.x on my USB 3 attached MyBook Essential 3TB hard drive - I was having ""Error: Partition map repair failed while adjusting structures to fit current whole disk size" error previously under 10.8.2...


    The strange thing is, that under 10.7.x Disk Utility finds no error at all !!!

    So the obvious question is, perhaps this error code we are talking about is a pure 'cosmetic' bug of 10.8's Disk Utility?


    Because after the repair attempt under 10.7.x if I connect this drive to 10.8.2, Mountain Lion's Disk Utility reports the same error again when checking with 'Repair Disk' command.

  • Tim Krynicki Level 1 Level 1

    I tried all the things I had mentioned above and still couldn't get the error to go away.


    Weirdly enough, I tried a Lion install disc I made and used Disk Utility from it to try and repair the error and it gave up.


    I have a copy of Snow Leopard but I am out of dual layered dvds to burn it to. So I couldn't test with that.


    It seems cosimetic, but mine has given me some funny errors. I use ChronoSync to sync this drive to another that is exactly the same. Chrono gives me errors on certain files saying it can't trash them (it is trying to trash the older version to replace it with the new one). This never used to happen till recently and then I find this error on this drive alone, the main one has no errors.


    So frankly, I can't tell if this is something we're wasting our time on, or something that could get worse. I have read plenty of threads and it seems like some are actually having real problems after the discover the error, like the partiton gets corrupted, etc. So this is why I am concerned. Thought it is my backup, it is as important as the main.

  • Alan Klein1 Level 1 Level 1
    Mac OS X

    Unfortunately this is not just a cosmetic bug with ML Disk Utility. This issue occurred for me after attempting to clone my startup volume to a new WD 2.5" 500GB HDD. The clone was successful but due to the "Partition map repair failed while adjusting structures to fit current whole disk size" bug, my MacBook Pro wouldn't start up from the new WD disk once I installed it internally due to the partition map having become corrupted. Neither the GUID or Recovery partitions were able to be seen by my MBP -- only a corrupted Master Boot Record partition that could neither be verified or repaired.


    Here are the details:


    The drive is a brand new 500GB Western Digital Black WD500BPKT installed on my Late 2008 MacBook Pro running Mountain Lion 10.8.2.


    Here's what happened:


    - Used a new Rosewill SATA to USB adapter to connect the drive to the computer. (I'm not happy with the Rosewill adapter which, if moved, will disconnect the drive. It is being returned.)

    - Formatted the drive as Mac OS Extended (Journaled) with one GUID partition.

    - Scanned the drive for bad blocks and ran integrity test with Drive Genius. (Passed both tests.)

    - Cloned my startup drive to the new WD drive using Carbon Copy Cloner with no issues. (CCC created a ML Recovery Partition using CCC with no issues.)

    - Shut down the computer while the WD was connected via the SATA USB adapter.

    - Installed the WD drive in the MacBook Pro.


    The MacBook Pro would not see the WD cloned startup volume or the cloned Recover Volume, only a small Master Boot Record partition. I was able to use my original HDD's Recovery Partition (connected via the SATA USB adapter) in order to use Disk Utility to investigate the issue I was experiencing with the WD disk. Disk Utility reported only a Master Boot Record partition that could not be Verified or Repaired.


    I then:


    - Reinstalled my original hard drive into the MacBook Pro, which then booted normally.

    - Connected the WD to my computer using the SATA USB adapter.

    - Ran Disk Utility and received this error when trying to verify the MBR: "Partition map repair failed while adjusting structures to fit current whole disk size." (There seem to be a few Apple Discussions regarding an issue that may be causing partition map corruption with some external disks that involvers having the drives connected while Mountain Lion sleeps or wakes from sleep.)

    - I then re-formatted the WD disk using Disk Utility. (Mac OS Extended (Journaled) with one GUID partition. Successfully formatted.)

    - Verified the MBR partition. (It verified successfully.)


    Now here's the kicker:


    - I put my Mac to sleep with the WD disk still attached via the SATA USB adapter.

    - Woke up the MacBook Pro and the WD appeared on the Desktop and in Disk Utility normally.

    - Re-Verified the partition map partition and -- guess what -- received the following error: Partition map repair failed while adjusting structures to fit current whole disk size."


    So it seems that under some circumstances, with some disks, Mountain Lion and Sleep may indeed corrupt the partition map.



  • Mac Admin1 Level 1 Level 1

    As I wrote before, running the 'Repair Disk' command of Disk Utility under 10.7.x finds no error at all. Doing the same after this on 10.8.2 reports the known error message again - however no date has been copied in the meantime to this disk.


    My confidence this might be a cosmetic bug is even stronger since 5 minutes, when Disk Warrior 4.4 finished Repairing this disk and found no error at all.


    I'm not saying it's the case with everyone on this thread, but seems like my HD is healthy.

  • COOH Level 1 Level 1

    Same Problem. ML and a 3TB Seagate BackupPlus.

  • Stephen Spector Level 1 Level 1

    Let me add my two cents to this ... as others have said, running the 'Repair Disk' command of Disk Utility under 10.7.4 finds no error at all. Doing the same after this on 10.8.2 reports the known error message again - however no data has been copied in the meantime to this disk. What is even worse is that it casues a kernal panic if the drive is inserted when running. If the system boots while the drive is attached, no problems. But connect it after boot --- BAM ... KP.

  • nycmacmini Level 1 Level 1

    Ugh. This problem has persisted for months with no solution. How do we escalate this problem so that Apple at least knows about it and can address it?

  • William Beecham Level 1 Level 1

    I second the motion to escalate. I have same issue and have been watching thread hoping for a solution.

  • DocJekl Level 1 Level 1

    I third this motion to escalate the issue.

  • Cowtipper Level 1 Level 1

    I'll make a fourth, although I do not know how someone actually escalates it to a point that it get anyone's attention.


    But yes, I have fiddled and formatted, and reformatted, and got it to work—but never for very long, and lost data.

  • Emergent Level 1 Level 1

    I'll chime in on my own to ALSO say that I've experienced this error message/pattern.


    The problem is (at least in part) with Disk Utility on Mountain Lion. I found a computer running 10.7.5, and used that version of Disk Utility to complete success - fixed up my external HD for use with whichever computer.

  • dahmooser Level 1 Level 1

    Mountain Lion (ML). Ugh.


    I spoke with G-Tech today. They explained that if you have a drive that has the PART NUMBER 0G02537, their drive will require a FIRMWARE UPDATE to correct this issue. Otherwise, the drive will not work properly with firewire, and could result in the formatting issues we've all experienced, and at the worst, cause the drive to be completely unreadable, which happened to me.


    For me, these were 4TB drives. I had used them on Snow Leopard (SL) without any issues. I copied data via USB over to the drive for delivery. The person receiving the drive mounted it in ML and stated the drive was unreadable, would they like to format it!!?  I received the drive back, plugged it into my ML system (not my SL system) via USB, and indeed the drive was unreadable.


    Fun Stuff, this.


    I have been using G-tech drives for YEARS without issues.  I sent the drive back for replacement (before I realized it was a firmware issue), but the one I received, I've come to now learn, has the same issue!  So, looks like G-tech didn't get the ML memo to update something in their firewire drivers that seems to prove fatal.


    Hope this helps some of you out there.

  • revDAVE Level 2 Level 2
    Mac OS X

    ok - i guess I'll chime in too...


    late model MBpro w ML 10.8.2


    - connected new SEAGATE 3T DT backup plus with USB 3.0

    - disk util - formatted mac guid - 1 partition

    - right away diskutil first aid on partition = no problem

    - but first aid on root partition (what ever you call it ) was dreaded =

    Error: Partition map repair failed while adjusting structures to fit current whole disk size.


    - so there was no time to sleep or get corruption - it was instant






    i copied about 4.2 gigs


    Macbook (7200 rmp drive) to seagate (also 7200 they say) = 55 sec


    seagate to Macbook = 46 sec




    Macbook to FW 800 - 7200 DRIVE = 2 min 27 sec


    7200 FW 800 to Macbook = 2 min 14 sec




  • revDAVE Level 2 Level 2
    Mac OS X


    Krutsch wrote:





    So... all of my problems went away when I performed the following steps (I found these on a Seagate support forum):


    1. Connect the drive (I use FW800)


    2. Install the included Seagate Drive Settings software and make sure you reboot your computer afterward



    >>>---- DONE - mine called Seagate Dashboard Installer.dmg and got update also


    --->>> BUT SEEMS LIKE USELESS bloatware for social networking that is meant for 10.6!!!! not 10.8.......????????????? nothing about firmware related info..............



    (Software also available from Seagate with your drive)


    3. Seagate does not make the next steps obvious, you have to search for them.


    Confirm that your drive is connected directly and correctly.


    The drive must be connected directly to the Mac's USB or Firewire port to ensure that the spin-down command is sent to the drive. Do not connect the drive to a USB or Firewire port on the computer monitor or on the keyboard.


    Click on the Apple > Choose System Preferences.


    Click on the Energy Saver Icon.


    There is Check box that says Put the hard disk(s) to sleep when possible.

    Check the box here to set the drive(s) to sleep after 10 min of inactivity.

    (Removing the check mark will disable disk sleep.)


    Check what the disk sleep settings are now (if desired).


    Click on the Apple > About this Mac.


    Open the System Profiler.


    Click on More Info.


    Click on Power in the left column. The current Disk Sleep time is displayed in minutes on the right.


    4. Another absolutely critical step that Seagate does not tell you anywhere is that in order for the firmware update from the last step to actually take effect (regardless of what the System Profiler says), you must power the drive down (disconnect the power supply from the hard drive and wait 10+ seconds) and then plug it back in.


    5. Erase the drive using Disk Utility and partition as desired (you may be able to get away without this but this is what I did and it worked)


    Hi I did all these steps - but no improvement


    - i am NOT using TM


    - but after all your steps done - I went back to D-U and STILL has SAME EXACT ERROR - so none of this helped anything for me.......


    ALSO - YOU SAY TO CHECK so DRIVE WILLL SLEEP IN 10 minutes - but isn't that the OPPOSITE of what others say = NEVER SLEEP?


    So which is it?


    BTW: I tried both and neither got rid of the error........



    HMMM .... not happy about about this.........