Previous 1 3 4 5 6 7 Next 98 Replies Latest reply: Dec 8, 2013 9:46 PM by Patrick123 Go to original post
  • Patrick123 Level 1 Level 1

    I got my new 27" a few weeks ago and I just got a 3TB Seagate Backup+ drive.  I can go into ML Disk Utility, set it to one partition (meaning, wipe what was there), and hit Apply.  When that finishes, if I do a Verify Disk on the drive itself (not the 1 partition), I immediately get that error.


    I can hook it up to my mini with Lion, do the same thing and there is no problem.


    If I take the ML-formatted disk and plug it into the mini, the Lion Disk Utility finds 400MB of unused space at the start of the disk when I repair it, but then starts complaining about not enough space for a boot area or something (sorry, didn't write it down).


    This is an old thread...Apple needs to fix this.  I wonder if TM will work across the network with the drive connected to my mini.



  • Patrick123 Level 1 Level 1

    Update...if you do 'diskutil repairDisk <device' from Terminal, I get more infomation...a root cause, perhaps:


    Error: -69697: Partition map repair failed while adjusting structures to fit current whole disk size

    Underlying error: -5341: MediaKit reports partition (map) too small


    Mountain Lion has some issue with the partition map it created being too small, I guess  Or, more likely, there is a bug in diskutil that thinks it's too small.


    Additional FYI, if I initialize the Seagate Backup+ 3TB drive on ML, I get a 315MB EFI partition.  Lion only creates one that is 210MB (which, perhaps oddly, is the same size as the EFI partition on ML's internal hard drive).  At any rate, with the 315MB one, Lion complains that the EFI partition is too big.


    I have not had any corruption issues.  But, I hope Apple resolves this soon.

  • William Beecham Level 1 Level 1

    I found the following Terminal command: sudo  gpt -r show /dev/disk2



    I got the following data on my Seagate drive:


    start       size  index  contents

              0          1         PMBR

              1          1         Pri GPT header

              2          4         Pri GPT table

              6      51200      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

          51206  201332309      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC

      201383515     191460      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC

      201574975   30442599        

      232017574  500516298      4  GPT part - 48465300-0000-11AA-AA11-00306543ECAC

      732533872      32768        

      732566640          4         Sec GPT table

      732566644          1         Sec GPT header



    I repeated the command for my startup disk with this result:


           start        size  index  contents

               0           1         PMBR

               1           1         Pri GPT header

               2          32         Pri GPT table

              34           6        

              40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B

          409640  1952853344      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC

      1953262984      262151        

      1953525135          32         Sec GPT table

      1953525167           1         Sec GPT header


    The error we get must be about the above parameters.


    I notice that most disks have a start value of 40 for the first partition. But, the Seagate partition starts at -6. This does not look right.


    Any comments?

  • revDAVE Level 2 Level 2
    Mac OS X

    In addition, a buddy just checked  his 2 newer LaCie 3T externals w usb3.0 on ML and he has been running for weeks with no problems - but they had the VERY SAME ERROR when you repair the TOP volume like (no indiv. partitions) - he was surprised...


    There seems to be 2 separate issues:


    1 - the ERROR in DU =

    Error: Partition map repair failed while adjusting structures to fit current whole disk size.


    2 - actual data going bad for some - but not others - possibly related to time machine for some...


    I wonder if anyone think the error might be unrelated and maybe just cosmetic or or bug in ML disk util.... as other disk apps dont' seem to show the problem...?

  • organima Level 1 Level 1

    Thanks, Krutsch -

    I was able to mount my 3T Seagate GoFlex Firewire 800.

    Hope it keeps working.


  • revDAVE Level 2 Level 2
    Mac OS X

    FYI... here's the the part that is NOT working when the error happens... Below is a succesful run of the top - partition map... looks pretty important! I wonder if this means these drives are bad or disk util has some kind of bug?



    Verifying and repairing partition map for “OEM”

    Checking prerequisites

    Checking the partition list

    Adjusting partition map to fit whole disk as required

    Checking for an EFI system partition

    Checking the EFI system partition’s size

    Checking the EFI system partition’s file system

    Checking all HFS data partition loader spaces

    Reviewing boot support loaders

    Checking Core Storage Physical Volume partitions

    Updating Windows boot.ini files as required

    The partition map appears to be OK

  • dahmooser Level 1 Level 1

    Okay, some more info on the 4TB G Drive 0G02537 part number issue, which produces the same aforementioned error messages.


    I formatted my drives via FireWire on a Snow Leopard system.


    IF you then take them to a Mountain Lion system,


    • Plug into the USB port.
    • You'll get a "not recognized, do you want to initialize?"
    • Say "NO!" and cancel that.
    • Run the G Drive Firmware updater (which you can only get by CALLING G-TECH, because it's NOT posted as a download on their site)
    • Firmware update successful.
    • Unplug your hard drive.
    • Wait 30 seconds.
    • Plug it back in.


    NOTE: I only know that THIS worked on THREE drives.  If you've formatted your drives any other way, I am uncertain what the results will be. G-tech said that retaining the data is rare... so, I was lucky I had formatted them via FW on Snow Leopard.


    Hope this helps someone out there.

  • Sparkyhodgo Level 1 Level 1

    Likewise getting this error with Mountain Lion and a 3TB Seagate GoFlex Desk via USB 3.0.  I've tried reformatting with every combination of filesystem (HFS+, NTFS) and partition map (GUID, old Apple) to no effect.  Unfortunately, I have no Lion or Snow Leopard machines handy to try to repair that way.


    Vote for escalating.

  • revDAVE Level 2 Level 2
    Mac OS X

    Also - I just took the NEW SEAGATE 3T DT Backup Plus drive to a snow leopard MBP and reformatted from scratch and ran repair disk to the whole partition map and partition with no errors. Then brought it back to ML MBP and SAME ERROR SHOWS for the partition map.


    Hopefully this will help show that this has nothing to do with sleep mode or time machine and more to do with...


    1 - a bug in disk utility

    2 - an incompatibility with the controller card

    3 - something else?

  • Patrick123 Level 1 Level 1

    Any word on a solution?  How does one file an issue with Apple?

    Regards, Patrick

  • Michael Gebert Level 1 Level 1

    I ran into this same problem the other day on a Time Machine drive that, thankfully, I had just used to restore my system.


    I bought a new drive and the first attempt at backing up to it failed as well. It didn't give the same error message, so I don't know why it did, but it did.  (I wish TM wasn't an all or nothing program. Maybe it could back up, you know, all except whatever gives it trouble? That would be a start.)


    I've read the whole thread, though much of it is beyond me. If there's a consistent solution here, I didn't see it. What isn't beyond me is that TIme Machine used to work just fine and now it doesn't and Apple has yet to do anything about it. I don't know, to me Time Machine is a pretty big feature and backing up is a pretty important priority and yet Apple does not give any sign of taking it seriously any more. Do we even know that anyone at Apple knows about this problem and cares in the slightest? How do we get them to pay attention? Or do we just take it for granted that we have to find a third party solution because a major Apple feature doesn't actually work?


    This is massively disappointing on Apple's part.

  • Scott Newman Level 2 Level 2

    There is no consistent solution for a user.  Apple has to supply it.  All you can do is submit a bug report to



    And, there is really no excuse for this bug.  It's not as if 3TB and 4TB drives are something new.  It reminds of the problems users had when Apple first included USB3 ports on computers.  There were a large number of problems interfacing with external drives using a USB3 interface.  And again...Apple started including USB3 ports very late into the game.  There was no excuse for those problems.


    I'm as loyal a Mac user as there is and I owned one of the original 1984 128K Macs.  More and more I think that Mac OS X is just an afterthought.


    I recently had to replace one of my 2TB external drives used for media storage.  I really wanted and needed a 3TB drive but decided on a new 2TB drive specifically because of this bug.

  • Mike Stand Level 1 Level 1

    I just got a new mini a couple weeks ago with ML of course. I've just experienced this issue with a 3tb USB 3 Freeagent Goflex Desktop after mounting fine the past week. I have it formatted GUID as one whole partition. I never use or install any software that comes with hdd, BTW.

    Like they're doing us a big favor with that junk, right. ;-)


    But when I booted today it didn't mount. Like everyone else if I do a check with DU on the partition, its all a-ok. But the root disk gives me the 'partition fail' thing. I also did Disk problems.  Re-booting once or twice the drive mounted again.


    Don't appear to have any problem accessing any of the files on it. This is used as a backup of my archived stuff.  I have the same files on an Hitachi 3tb usb3 Touro. I guess I'll hook that one up one of these days and see if it has this error as well.



  • Cowtipper Level 1 Level 1


    >>There is no consistent solution for a user.  Apple has to supply it.  All you can do is submit a bug report to




    Thanks, Scott. I have made a bug report on this issue. Maybe a few other folks could, too?


    I mean, really I've been involved in this thread since AUGUST and nothing has been done. I know people are losing data and work and I have a lovely 2TB Hitatchi Touro doorstop I'd like to use as a backup drive someday.....

Previous 1 3 4 5 6 7 Next