8 Replies Latest reply: Nov 18, 2012 4:47 AM by c2ric
AnalogKid Level 1 Level 1 (10 points)

Within ML Server.app, I've created a new group.  When I select "Edit access to services...", the spinner in the bottom right goes forever and never returns.  There is no text next to the spinner.  The services check boxes don't appear.  Both cores on my Mini are at about 80% load, and Activity Monitor reports that that is split between opendirectoryd and servermgrd.  Neither log file shows activity while this is happening. 


The cancel button in the sheet remains active, and closes the sheet.  I can only get out of this by quitting server.app and reopening.  I get a warning that some changes will be unsaved if I quit, but there really isn't much choice.


I can edit services for the Workgroup group, but not for any self created group.

  • AnalogKid Level 1 Level 1 (10 points)

    Well, I did a clean install of ML and then of Server.app and started over.  I can edit these group access parameters now, but that's a pretty draconian solution once this server has been deployed.


    Anybody know where the groups to services mappings are held?  I suspect a file went corrupt somewhere, but I don't know which one.

  • Ben Pirozzolo Level 2 Level 2 (165 points)

    I can only say that i've got the same problem. I unfortunately don't have the luxury of clean installing ML. Just like you, i can edit the default 'Workgroup' group, but the second i try and edit groups created by me, i get the same symptoms as you, the spinner at the bottom right of the server app just carries on spinning while saying nothing, and while the 'Edit Access to Services' box appears, all that is in there is a white square. When that happens, i then can't even edit the 'Workgroup' group, or even touch anything else Open Directory related until i've restarted the machine, as it's clearly stuck doing a task in the background.


    Is there anyway to even debug the server app so i can see what it is doing? As you say, the logs don't seem to be much help.

  • Ben Pirozzolo Level 2 Level 2 (165 points)

    Just an update in case anyone else in the future has this problem and

    can't work out what the **** to do.

    I managed (after a lot of heartache) to finally stop the service hanging

    by going into the 'Directory Utlity' app, then using the 'Directory

    Editor' to access the /Local/Default node. In there go to the 'Groups'

    section and there is a list of service access records called

    com.apple.access.nameofservice. I deleted all of them, and this fixed the

    hanging. Of course if you had setup any server access settings, you will

    have to do this again. But that's a small price to pay.



  • AnalogKid Level 1 Level 1 (10 points)

    I can't replicate the problem because I've rebuilt my server from the ground up, but I really appreciate you reporting back on this.  I've been quietly worried this problem would crop up again and it's good to have a solution at hand.


    I'd call this a bug and report it to Apple.

  • AnalogKid Level 1 Level 1 (10 points)

    Just hit this one again on server 2.1.1.  Your fix seems to have helped-- did you encounter any lasting complications from this?

  • Ben Pirozzolo Level 2 Level 2 (165 points)

    Nope, none at all. In fact it was the only thing in Mountain Lion Server that seemed to have a relatively easy fix with no complications.

  • jcorreiad Level 1 Level 1 (0 points)

    Followed your advice. It worked. Only thing to add is that i recommend to restart Open Directory or restart the mac if you wish.

  • c2ric Level 1 Level 1 (20 points)

    Thank's to you

    it's worked!