2 Replies Latest reply: Dec 13, 2012 1:46 PM by Vashspike
Vashspike Level 1 (10 points)

Hello all,


I have a 6G iPod Nano that I currently use as my primary watch. A week or so ago I started to experience a blank white screen when I press the "sleep/wake" button instead of the watch face (I have it set to wake from sleep to display the clock). When I hard reset it, it will come back fine and the screen will respond and work as normal, as soon as I manually put it to sleep by pressing the "sleep/wake" button and then try to wake it the same thing happens and I have a blank white screen that doesn't respond to touch gestures or anything.

What I have tried so far to no avail:

  1. Numerous hard restarts (holding the "sleep/wake" button with the volume - button).
  2. Tried this: iPod nano (6th generation): Hardware troubleshooting
  3. Changed the watch face to display.
  4. Recharged the device overnight (without full discharge).


Since none of this works I'm out of ideas. Eventhough I have a 6G Nano it should no longer be under warranty since I was sent it as a replacement for a different (older) product.


Any ideas? Is this a known problem? Thanks in advance for any insight any of you could provide. Also, what time is it??



Allen (Vashspike)

  • cosmicflood Level 1 (0 points)

    I have just experienced exactley the same issue. Working fine one minute and the next a white screen and nothing happening.


    Did you have any success?

  • Vashspike Level 1 (10 points)

    I ended up being covered by the limited warranty and they swapped it out. Upon further inspection I discovered that if I put pressure on the screen in just the right spot the screen would sometimes come back. I attribute this to a loose ribbon cable possibly.