Previous 1 2 3 Next 38 Replies Latest reply: Jul 27, 2013 11:14 AM by leeraymond78
chronicfathead Level 1 (35 points)

After rebooting my 2011 13" MBP, due to corrupt images (certain image previews looked like a block of random coloured dots), I seem to have lost the Wifi, Spotlight and battery icons form my menu bar.  I have tried adding/removing the icon through system prefs, but all it does is add a blank space.


I ran a repair disk permissions on the drive and it did say it had repaired the coregraphics.framework (?), but the icons have not reappeared.  I will reboot and see what happens again, but chances are they will come back normally again.


missing icons.png

MacBook Pro (13-inch Late 2011), OS X Mountain Lion, i7, 16GB, 750GB HDD
  • mende1 Level 10 (92,201 points)

    It could be a damaged permission

  • chronicfathead Level 1 (35 points)

    Just rebooted, and my icons are still missing.  Running Disk Utilities repair permissions did not find anything apart from the message below:


    Warning: SUID file “System/Library/CoreServices/RemoteManagement/ ent” has been modified and will not be repaired.



    Prior to this the laptop had been put to sleep a week ago, and it has gone into hibernation mode itself when the battery got too low.


    The install of ML was over a one month old install of Lion.  I run Filevault 2 to protect the drive's content while on the road.  I ran DU repair permissions and Cocktail all maintenance scripts before running the ML installer.  Cocktail has not been run since the install of ML.



    Just noticed that my Finder icons have also gone.

    finder icons.png

  • chronicfathead Level 1 (35 points)

    Creating a new account has cured the problem, but left me with a big headache of migrating everything off my old 10.7 backup, or moving everything manually from the old user account.


    It has to be related to the core graphics services, but I can't see anything on repairing them.

  • mende1 Level 10 (92,201 points)

    The preferences could be damaged

  • chronicfathead Level 1 (35 points)

    I've done a search for corrupt preferences using Cocktail, but it doesn't come up with anything.  There is a chance it doesn't look at core preferences?

  • leroydouglas Level 6 (17,787 points)

    I would think it is a corrupt plist.


    delete the following Finder>Go>Go to folder:




    Then in terminal:


    killall SystemUIServer



    This maybe enough,  if not proceed with Rebuild LaunchServices Database to repair problems with incorrect icons in OS X


    Open the Terminal application in your Utilities folder. At the prompt paste in the following command in its entirety:


    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user


    hit return and let the process run it's course,  it will put you back out at the prompt when complete.


    Then in terminal copy and paste:


    killall SystemUIServer



    Follow up by restarting your computer.

  • chronicfathead Level 1 (35 points)



    Thanks for the suggestion, but... I still have missing icon's, in fact I think I've also now lost the icons next to the main folders in the left section of the finder.


    I'm backing files up now, with a view to doing a fresh install, unless anyone else can think of anything.

  • leroydouglas Level 6 (17,787 points)

    I would try a safe boot first to clear the dynamic loader cache.  Then reboot as normal.


  • chronicfathead Level 1 (35 points)



    Never tried safe boot before.  I hear the chime, press shift, because I'm using filevault 2 I have to release and then type my password in and press enter.


    I continue to hold shift down till the Apple logo shows up and I get a bar moving across below the logo.  After it has gone all the way across the screen goes black and then it reboots on its own.


    I thought you should log in as normal, just without all the crap running, as you do with safe mode in  Windows.


    I can guarantee this will be fixed in the first point release, which will come at some point in the next week knowing my luck!

  • chronicfathead Level 1 (35 points)

    I ended up booting using Command-R and then running the ML installer.  After the ML software had downloaded and then installed, it booted into my account, with virtually all my apps, and all my documents etc.


    All the menu bar icons and Finder icons have reappeared, and the system is running fine again.  Doing the reinstall was painless, and I'm running Filevault 2!

  • leroydouglas Level 6 (17,787 points)

    Glad to hear all is well, even if you had to take the long road. Good computing!

  • chronicfathead Level 1 (35 points)

    I spoke too soon.


    Upgraded to 10.8.1, and all has been fine.


    Put my Macbook Pro to sleep on Friday with a lowish charge.  On Monday I had to plug it in to get it to power on, after which Excel kept crashing, so I thought I would reboot.  While it was powering off the screen filled with corruption (covered in multi colured dots), but it did shutdown and restart.


    When it cam back, I noticed that my icons had dissappeared again.


    I'm wondering if this is the Crucial 16GB kit that it came with (New, special deal), or if it's something to do with ML not hibernating correctly, and causing corruption.


    Anyone have any suggestions again, before I wipe again!



  • ilewy.mac Level 1 (0 points)

    I have the same problem, My Macbook hav 128GB SSD and turn on FileValut. After hibernate Mac, my menu icon dissappear. :/ Any one have sollution for this?

  • chronicfathead Level 1 (35 points)



    I realised that I was in the 90 day software support period,  so I called Apple.  We have done most of the above so far,  and he has just had me disable filevault so we can test safe mode.   I have a call booked for Monday,  so hopefully I should have an answer then.

Previous 1 2 3 Next