Previous 1 2 3 Next 38 Replies Latest reply: Jul 27, 2013 11:14 AM by leeraymond78 Go to original post
  • chronicfathead Level 1 (35 points)

    Steps I took that resolved the issue.


    1. I disabled Filevault.
    2. I rebooted into Safe Mode (hold SHIFT down and boot)
    3. I did remove a couple off apps (Apps on Sale Light + 1 other app but can't remember what it was).


    I think it is the process of going into Safe Mode that clears certain caches, and Filevault doesn't allow you to go into Safe Mode as a security precaution.  The Apple support technician was convinced it was caused by an installed App, as other user accounts worked fine.


    Try removing Filevault and rebooting into Safe Mode, then reboot normally and see if it cures it.

  • Fatboylarry Level 1 (0 points)

    So glad it's not just me!


    Just posted a similar question but looking at the posted pictures mine is exactly the same. If any help, this started after bring the MBP out of Hibernation....


    Will try a restart in Safemode and see what happens...



  • brandonpoc Level 1 (0 points)

    That is down right silly that FileVault v2 doesn't allow a boot into safe mode. If you have entered the correct key, booting into Safe Mode should not present any kind of "security" issues as you stated. The decryption will be provided for anyone with the key, so booting into Safe Mode AFTER the boot partition is decrypted would be the same as any booting with the decrypted file system. Besides it can't boot into Safe Mode, or any mode for that matter, without the file system being decrypted at boot with the key (or your user password).


    Having to decrypt the boot disk in order to run Safe Mode and alleviate this is in itself a security concern as we are having to decrypt the file system for a simple task. This has the potential (and will in practice) to leave large chunks of the file system in unencrypted, plain text form on solid state (SSD) disks, the SSD portion of fusion disks, and their ilk as these types of media cannot be relied upon to over-write existing data due to their design and nature.


    Thanks Apple.

  • snazy Level 1 (0 points)



    I have the problem with my MBP/Retina running 10.8.2 since yesturday.


    Graphics get corrupted after the macbook resumes from hibernation and interaction with the mac is ****.

    After a power-off (reboot did not work) and cold-boot, all icons (menu bar, finder, mail, safari, preferences etc) were gone. Clearing preferences folder did not solve the issue.


    Only a boot into safe mode, login and reboot solved the issue.


    Reproduced this 2 times now.


    Trying to disable automatic hibernation for my Macbook... will use shutdown and power-on until Apple is eventually able to solve this bug in OS X 10.8.x.


    Same issue in

  • percolated Level 1 (0 points)

    Hi all


    Been having the same problems, seemingly since upgrading to latest ML update.


    Have had graphics corruption issues, which I have been tolerating, for weeks.


    Then since update, the computer will not turn back on from hibernation, and a restart is required.


    Now since yesterday, there are multiple missing icons in finder and above at the top menu (Bluetooth, Wifi icons).



    Have tried a host of things, repairing permissions, deleting finder & sideline and SIMBL plist files, to no avail.


    Will now try restarting in Safe Mode to see if that works.  Interestingly, the issues don't seem to be a problem when logging into the Guest Account.

  • percolated Level 1 (0 points)

    The booting into Safe Mode and then restarting seems to have fixed the issue for now.


    It seems appropriate that Apple find a solution to this bug that is effecting so many people.

  • David Ganster Level 1 (0 points)

    Same thing here. Nothing worked (deleting Caches/specific .plist files specifically etc), but Safe Mode fixed the problem as it seems...


    Definitely reproducilble, has happened to me after the latest updates only (10.8.2, all graphics updates for MacBook Pro 2012).


    VERY annoying - one would think with the limited amount of hardware that apple has to support, they would at least get something as basic as hibernation right...

  • daraosn Level 1 (0 points)

    I was able to solve this issue (and all related with file permissions, buggy sleep, hibernation & restart, etc.) by deleting and restoring my User Account. It is a bit tricky, but your account is set up as brand new while keeping all your files, preferences and configurations.


    1. You have to enable the root account (google for it).

    2. Login as root.

    3. Open a Terminal window and run:

    cd /Users

    dscl . remove /Users/yourusername

    4. Go to Users & Group preferences (you will not see your user anymore, but your folder and files are still there so don't worry!).

    5. Add your user account again.

    6. When it ask, tell to use your old folder for the "new user".

    7. Wait some seconds and then run in your terminal:

    chown -R yourusername /Users/yourusername

    8. Reboot and login with your fresh account.

    9. Optional: Disable hibernation or 'deep sleep' (it really ***** on OSX) with this:

    sudo pmset -a hibernatemode 0


    Why using "dscl" instead of just removing it from the Pref. panel?

    I realized that when using the User preference panel the user doesn't get removed, but rather "hidden" somehow. I noticed this since after restoring the user, it would use the older UNIX user UID. This method ensures that the user will use a different user id.


    Hope it helps.

  • David Ganster Level 1 (0 points)



    it seems to have been my own fault - I had foolishly disabled Swapping since I read somewhere that you should do so if you have a SSD. I re-enabled swapping and have never had any problems since - seems like unloading the pager daemon is not such a good idea, it's probably also responsible for other things related to memory management...


    Take this as a warning to not mess with your system on a kernel-level. Nothing good will come from it.

  • brandonpoc Level 1 (0 points)

    To sum up this post thus far, so that new-comers get an idea of the current status ...


    Throughout the course of this discussion, we have found a work-around for my originally posted issue by either re-creating the user account or re-booting into safe-mode, logging in, and then re-booting again. This is not a fix! This is a hack and a work-around only and NOT a fix. My laptop entering hibernation while encrypted with Filevault v2 will again have its icons effectively "erased" from my its interface!


    I am surprised to have not seen any Apple response nor anyone stating that they were in contact with Apple. This is a nasty, computer usage affecting bug that needs to be addressed quickly before the next patches are released so that it may be included. It is ridiculous that such a bug occurs that affects the beautiful and friendly user interface that Apple has pioneered; yet Apple has not responded to any of us nor acknowledged this bug. How can it be that none of their quality assurance and testing team have not run into this set of circumstances? The amount of activity in this post has shown that these circumstances are far more common than I originally thought.


    Indeed there are other posts on the Apple discussions site that have asked for help or advice about this same bug. However it was not described in such detail and, until I posted mine and included my screenshots, I fear that they did not receive much response. Apple needs to be aware of this bug so that they may fix it. It is driving me nuts! I must use an encrypted filesystem (in this case Filevault v2) and would like to be able to hibernate without permanately losing my icons until I conduct a strange voodoo ritual, and then after sacrificing an apple to the divine Macintosh spirits, decrypting my hard disk, boot into safe-mode, login and re-encrypt! Safe mode cannot be entered when the hard disk is Filevault v2 encrypted which is itself a nasty bug, or a "feature" or "limitation" perhaps, that should be addressed. This leaves me having to use the delete user method described by daraosn and it too is a major pain in the @$$.


    Someone please make Apple acutely aware of this issue. They seem to not acknowledge me despite my repeated attempts to contact them; and the Apple "Geniuses" at the "Genius Bar" are utterly worthless for matters such as this. Despite my pestering they apparently haven't enough sway and influence to get Apple to at least look at the bug.


    Here's to a quick fix!


    - Brandon

  • brandonpoc Level 1 (0 points)



    Where did you read that you should disable swapping if you have an SSD? You disable swapping if you have enough physical memory (RAM). Pages are swapped to the hard-disk (HDD) or solid-state-disk (SSD). If you don't have enough memory, then the least used memory pages are written to disk and retrieved when needed. If you have disabled swapping and there is no free physical memory, it is very possible that your system will crash. At the very least, applications will start to close.


    Besides, I don't understand why disabling swapping would cause this issue. The paging daemon writes out the least-used memory pages to hard disk in the case that there is not enough physical memory available and then reads them when it needs them. It is a very slow replacement for physical memory, even with an SSD! Although of course swapping to SSD is much better than swapping to a normal HDD .


    The computer on which I am having the issue described in this topic, my Macbook Pro laptop, has 16GB of RAM and had never swapped out a page to hard disk prior to disabling it; as such, considering this happened prior to disabling swap, this couldn't be the cause for this bug. Besides, that part of the system would not be tied in any way to the GUI being able to find icon sets. If this were the case then there would be a major problem with the swapping daemon as it would have some bug involving the pages being read in being corrupted. Swapping exists to make loading more than what the physical memory can handle possible. I also have swapping disabled on my Mac Pro with 64GB of RAM as it truly never swaps out even with a dozen large programs running .

  • Bram Linssen Level 1 (0 points)



    Thanks for the suggestion.

    I've been having exactly the same problems,

    missing icons, corrupted graphics after waking up from hibernation and bad interactions.


    Repairing permissions, deleting user preferences, deleting user accounts and reinstalling  OS X all didn't help


    But I did have swapping disabled all the time. I just turned it back on. Let's see if that soves the issue here as well.

  • David Ganster Level 1 (0 points)

    Hi Brandon,


    I don't have a link ready (and am too lazy to look for it now), but OS X (like most OSs) starts to swap even when there's plenty of ram available - thus increasing the r/w load on you SSD, which decreases its lifespan.


    Anyway - I have 8GB RAM in my MBP and at this moment, 2gb are free, yet a 70MB swapfile has been created.

    It's probably not needed as in "crucial", but is still part of the systems memory management system.


    I don't think disabling "Swapping" per sé is where the issue comes from, but unloading the PagerDaemon.

    We don't know what exactly its responsibilities are, but it seems to have something to do with writing RAM to disk and reading it back; that sounds a lot like what hibernate does to me.


    If I were to write an operating system (which I do for university btw), I would not call my SwapManager "PagerDaemon", for me the name suggests there might be more to it than just swapping...

    But of course, we can't know for sure since none of us have seen the kernel of OS X and Apple has never bothered commenting on it.


    Anyway - if your computer, as you say, has no need for swapping anyways, disabling it will certainly not gain you any performance, it will, however, decrease system stability.

    In conclusion, to any of you who disabled swapping - try re-enabling it and see if it helps. It did the trick for me

  • brandonpoc Level 1 (0 points)



    I had watched my swap and didn't see any page outs for a good duration of time. The swap-file may be created, but look (via the Activity Monitor application) at how many page outs you're dealing with.


    As for looking at the source code for the pager daemon (dynamic_pager), the source code to Darwin is available. Check out the daemon itself at .tproj/dynamic_pager.c. This is the front-end / daemonizing interface of the dynamic_pager of course and a lot of the action is handled by the kernel it seems. Of course, in all honesty, nobody is going to be analyzing this (and the system calls it makes to interface with Mach and the Darwin BSD memory subsystem) in detail as a result of this . unless, of course, this is where the problem lies.. then Apple, get off your duff and do it!


    I disable swap because of security reasons -- even though it may be encrypted, it can obviously be read while the system is on and the interface for accessing it is able to read the data. I think on OS X it has been encrypted by default for a while now, and the option has been there for quite a few versions. In that dynamic_pager.c source code you can see an argument to paging_setup() called encrypted, a boolean, that if true encrypts the swap. A lot of applications have data that should not be swapped out. But I don't trust it when the system is on.


    And, if it is paging out when not needed as you claimed, then it does indeed impact performance and life-span with an SSD as you mentioned , since there is a maximum number of write cycles per "sector" or whatever they call the individual units of memory in the SSD.


    I don't think the pager is responsible for the hibernation; hibernation does indeed write out the contents of memory to disk and fetches it on reboot to present the user with the exact same state it was in when it hibernated, but this is handled differently than swapping out pages to memory as part of a VM.


    Regardless, if this were truly causing the issue, then there is some serious underlying bug with OS X's memory manager, and other things would be seriously corrupted rather than solely the icon sets.


    I will however try enabling swap. Did you see it corrected immediately after wards and rebooting, or did you have to also do the safe boot or user delete dance in order to restore the icons?


    BTW What kind of OS are you developing? I am a student of Andrew Tanenbaum's MINIX operating system and his book for it, "Operating Systems Design & Implementation 3rd Edition" which is an awesome teaching tool, and of course years of experience with UNIX-like OSes and with writing BSD and Linux kernel modules. Always a pain in the arse but good fun.





  • David Ganster Level 1 (0 points)

    Hi Brandon,


    thanks for the link, I just quickly looked over the code - but you're right, I won't bother trying to reverse engineer what exactly it does.

    My theory is that something inside the pager daemon may ensure memory integrity when reading/writing ram (maybe as a side-effect even)...


    About things other than the graphics being corrupted - we can't actually know if everything else is resuming correctly. The OS might be able to deal with broken caches etc by simply rebuilding or cleaning them, the user won't see anything if that's the case. My point being: just because the graphics are the most obvious problem, there might be other issues that the kernel can handle more or less gracefully.


    I rebooted into safe mode to fix the graphics first, and then enabled swapping after booting normally and I did not have to delete my user account.


    We are not working on a true UNIX-like operating system, but rather a small (more or less) POSIX-conform kernel. It's called SWEB (german "Schon wieder ein Betriebssystem" - "Yet Another Operating System" in english) and has specifically been created from the ground up to be used for educational purposes. My current focus is on creating virtual memory btw, which is why I tried disabling swapping in the first place