Previous 1 2 3 Next 38 Replies Latest reply: Jul 27, 2013 11:14 AM by leeraymond78 Go to original post
  • homo_faber Level 1 Level 1 (0 points)

    After upgrading to Mountain Lion (10.8.2) from Lion I just noticed the exact same issue ("C" file icon applied to executables appearing in the Spotlight search box). Restarting in Safe Mode (shift key held down after tone) and logging in, then restarting again normally fixed the issue.

  • David Ganster Level 1 Level 1 (0 points)

    Hi Brandon,


    I wanted to ask if enabling swapping fixed the issue for you?




  • Eldeeone Level 1 Level 1 (0 points)

    I have the exact same issue, running 10.8.3 at the moment.

    I'll love to be able to do the safe mode hack but rebooting in safe mode didn't work (the progress bar keep stuck around a 1/4 of it) any idea will be appreciated guys

  • Gandalff99 Level 1 Level 1 (0 points)

    Had the same problem. A safe reboot resolved it for me.

  • ennmartin Level 1 Level 1 (0 points)

    I have the same issue, running 10.8.3. Rebooting in safe mode didn't work (the progress bar keep stuck around a 1/4).  Tried to update to 10.8.4, but after downloading and applying the update, about this mac still shows me running 10.8.3.   And icons are still missing.


    Apple Support is telling me to empty my calendars....

  • B. Phillips Level 1 Level 1 (0 points)

    Safe Mode (holding shift when booting) did the trick for me. 


    I let my battery run out and subsequently my computer went into hibernation mode.  Upon plugging into a battery source and coming out of hibernation I had lots of pixelated, "snowy" looking icons and windows.  I rebooted to find some toolbar icons missing or blank in Finder,, and my menu bar.  This happened once before and didn't resolve itself until I installed the update to go from 10.8.3 to 10.8.4.  This is obviously only a fix for the missing icons, but it's a start.  Hopefully, Apple has a fix to the hibernation issue in the works.

  • Filius Level 1 Level 1 (0 points)

    Ok, so I've had this problem a couple of times on my MacBook alu 13" late 2008 (not pro), OS X 10.8.4, FileVault enabled, swap disabled.


    When I woke the machine from hibernation I got the UI artifacts described in this post. Tried all the normal stuff like rebuilding caches (Onyx), fixing permissions, installing combo update. Nothing worked. First time I got it I ended up just reinstalling the OS (it was time anyway after uprading it from 10.5 through to 10.8).


    This time I resolved to fix it.


    Follwing the instructions in this post I performed the following activities with a reboot after every step. None of them fixed the problem.


    1. Disable FileVault and reboot to single mode (Cmd+s)

    2. Enable swap (boot to single user mode and launch the dynamic pager agent)

    3. Fix permissions (Disk Util) and delete system and user cahces in Onyx

    4. Delete from ~/Library/Prefrences and ~/Library/Prefrences/ByHost


    Finnaly I downloaded the 10.8.4 Combo update and installed it. Whent the machine came back up all my menu items where back!


    I am absolutley certain that I tried to install the Combo update the others times I met this problem without it having anny effect.


    Anyway, there it is. All is well that ends well and hope this helps somone. Lets just hope apple fixed the root cause

  • homo_faber Level 1 Level 1 (0 points)

    I need to correct my own statement. The problem came back so the Safe Mode restart was not enough.

  • leeraymond78 Level 1 Level 1 (0 points)

    this solved my issue,  but it wasnt worked in normal mode, i did it in safe mode after, then the icons are back!!!

Previous 1 2 3 Next