5 Replies Latest reply: Dec 15, 2012 6:48 AM by aloe
mduke2 Level 1 (0 points)

My ipad screen is slow to respond to touch.  I'm having to touch everything twice to get the screen to respond.


iPad (3rd gen) Wi-Fi
  • Diavonex Level 9 (66,545 points)

    You have probably enable VoiceOver.

     

     

    http://support.apple.com/kb/HT4064

  • Demo Level 10 (88,767 points)

    Do you have Voice Over turned on? Settings>General>Accessibilty>Voice Over>On. If you do - turn it off. You may have to flcik with three fingers to scroll. You can try triple tapping the home button as well to get to the settings.

     

    If that's not it - Reboot the iPad by holding down on the sleep and home buttons at the same time for about 10-15 seconds until the Apple Logo appears - ignore the red slider - let go of the buttons.

  • Ditto2u Level 1 (0 points)

    This is also happening to me.  The touch keyboard works fine, but clicking hotspots takes two clicks.  My VoiceOver setting (whatever that is) is set to off.

     

    Is there a known problem with the touch screen?

  • Ditto2u Level 1 (0 points)

    P.S.  the problem is intermittent.  For example, when I clicked to submit the above comment, one click sufficed.  But hotspots often (>50% of time), take multiple clicks.

  • aloe Level 1 (0 points)

    I turned off ALL notifications and it's somewhat back to the norm.. typing and touching screen is sensitive again!