12 Replies Latest reply: Mar 1, 2013 4:49 PM by IPadSlow
masanfe Level 1 Level 1 (0 points)

Very slow wifi connection


iMac, Mac OS X (10.5.7)
  • 1. Re: slow wifi internet
    BDAqua Level 10 Level 10 (116,465 points)

    How slow?

     

    Open Network Utility in Applications>Utilities>Info tab, select Airport (en1 usually), & what is the Link Speed & are there any Errors/Collisions on the right?

     

    What do you get for raw speeds here, for both Java & Flash, DSL Reports...

     

    http://www.dslreports.com/stest

  • 2. Re: slow wifi internet
    masanfe Level 1 Level 1 (0 points)

    Link speed 54Mbps, no errors or collisions

     

    Download Speed: 473 kbps (59.1 KB/sec)

    Upload Speed: 467 kbps (58.4 KB/sec)

    Latency: 157 ms

     

    Speed Test #102465769 by dslreports.com

    Run: 2012-08-21 00:27:49 EST

    Download: 151 (Kbps)

    Upload: 358 (Kbps)

    In kilobytes per second: 18.5 down 43.7 up

    Tested by server: 56 java

    User: 2 @ dslreports.com

    User's DNS: rima-tde.net

     

    I have reported an incident to the adsl supplier...

     

     


    Test (From Central USA)LossMin
    Latency
    Avg
    Latency
    Max
    Latency
    Pass
    Fail
    basic ping
    10s of 40 byte packets, 2 per second
    0%179ms183ms190ms
    pass
    low bandwidth stream
    10s of 512 byte packets at 56 kbit
    0%181ms190ms262ms
    pass
    medium bandwidth streamwas not performed
    higher bandwidth streamwas not performed
    your first hop ping
    stream of 40byte pings to 80.58.86.58
    100% lossunknown reasonYou are 179ms
    to your first hop

    high
    Jitter/loss with small packets tested from Central - USA:
  • 3. Re: slow wifi internet
    BDAqua Level 10 Level 10 (116,465 points)

    Great work!

     

    80.58.86.58 is rima-tde.net, and returns no ping here either!

     

    Try these DNS nimbers...

     

    For 10.5/10.6, System Preferences>Network, unlock the lock if need be, highlight the Interface you use to connect to Internet, click on the advanced button, click on the DNS tab, click on the little plus icon, then add these numbers...

     

    208.67.222.222

    208.67.220.220

     

    Click OK.

     

    Also, turn off IPv6:

    System Preferences » Network » AirPort » TCP/IP tab » Configure IPv6

     

    Or whatever Interface you use.

  • 4. Re: slow wifi internet
    Augend Level 1 Level 1 (5 points)

    There are several causes for WIFI slow down.

    1- First check if your speed differs when connected to Ethernet ( Cable) .  ( go to www.speedtest.net and make 3 speed tests with WIFI and 3 other with Ethernet, finally if their average differ more than 5% consider connection problems including:

          1- You are far from the router or something is impeding the connection ( as microwave oven, a near lamp      ,...)

     

         2- A Wifi from one of your neighbours is on the same channel of you. you can find it as follows:

           go to http://istumbler.net  and download iStumbler99. now check if any STRING  Wifi of your neighbours is on the same channel of you. if so, change your channel with optimally 3 channels far from that one.( weak channels are of least importance)

     

    2- Find best DNS for your connection.  there are 2 fine DNS finders: DNS Namebench ( from Google) and DNS Benchmark ( both are free).  Find best DNSs and change them in your network preferences > Advanced >DNS

  • 5. Re: slow wifi internet
    masanfe Level 1 Level 1 (0 points)

    Thank you, I run stumbler  andnamebench, add new DNS  and improved. I also learned a lot.

  • 6. Re: slow wifi internet
    masanfe Level 1 Level 1 (0 points)

    Thank you after running namebench I found DNS you recomended is one of the results.... Improved speed. Thank you.

  • 7. Re: slow wifi internet
    Augend Level 1 Level 1 (5 points)

    Nice to hear that. I was not sure how experienced you are but I see you can setup for some more advanced settings:

     

    1- Set your wifi authentication to WPA2-Personal ( AES ) with a very strong password.  If someone is using your network, you would see a slow down.

     

    2-Set you modem 2.4 GHz to 802.11 b/g/n

     

    3- channel  to "Auto"

     

    4- DHCP  enabled

     

    5- make sure only one NAT and one DHCP server is enabled on your network ( no other routers)  also check by iStumbler if there is other network with the same name as you have selected.

     

    6- Change channel width from standard ( 40 MHz) to 20 MHz. ( narrower channels cause less interference )

     

    7- find best MTU.  most PPoE networks work best on MTU=1492.   You should BETTER change it both on router ( it must be somewhere in your internet interface ) as well as your laptop ( Network preferences >Advanced > Hardware tab :   change configure from automatically to manually, and enter exactly the same MTU as you set for your router)

     

    Finding best MTU is more an art. some guidelines are here but you should test and compare to find best. bigger MTU results in higher speed , but in congested ISPs or ISPs with packet loss, it has an adverse effect. lower MTUs are better for low quality networks. some guidelines are here:

    MTU=

    • 1500. The largest Ethernet packet size; it is also the default value. This is the typical setting for non-PPPoE, non-VPN connections. The default value for most routers, adapters and switches.

    • 1492. The size PPPoE prefers.

    • 1472. Maximum size to use for pinging. (Bigger packets are fragmented.)

    • 1468. The size DHCP prefers.

    • 1460. Usable by AOL if you don't have large email attachments, etc.

    • 1430. The size VPN and PPTP prefer.

    • 1400. Maximum size for AOL DSL.

    • 576. Typical value to connect to dial-up ISP

     

     

    Hope that helps !

  • 8. Re: slow wifi internet
    masanfe Level 1 Level 1 (0 points)

    Thanks again. I put the channel to auto and width to 20Mhz. The rest is OK, I think now I have the best I can get from Wifi.

    I learned a lot of managing it.

    However I am surprised of the huge difference in the speed you can get with direct cable conection.

    To wire the house is a pain in the neck due to the difficulty to hide it...

     

    We will see in the future if there is an alternative or a more powerful wifi I heard is to be announced.

    Regards

  • 9. Re: slow wifi internet
    Konstantin_A Level 1 Level 1 (0 points)

    Try switching off "photostream" in system preferences - icloud


    The photostream service took 2/3 of my download capacity.

     

    Best regards

    Konstantin

  • 10. Re: slow wifi internet
    masanfe Level 1 Level 1 (0 points)

    Very little use of fotostream yet. I will take care in the future.

     

     

    Now exploring to set up an internet private network through electricity net in house

     

    Thanks

  • 11. Re: slow wifi internet
    dervishtheviolinist Level 1 Level 1 (0 points)

    I always use opendns but I never noticed about IPv6 and thanks a lot it really WORKED.

  • 12. Re: slow wifi internet
    IPadSlow Level 1 Level 1 (0 points)

    This is related to a poor quality upgrade by apple. Not our ISPs