Previous 1 2 3 Next 37 Replies Latest reply: Sep 27, 2013 4:21 AM by Cowan Pettigrew Go to original post
  • Mark23 Level 3 (975 points)

    Please run Disk Utility and repair permissions.


    Disk Utility can be found in the utilities folder within your applications folder (/Applications/Utilities/Disk

    Double click it and choose Repair Disk Permissions.

  • clerge Level 1 (0 points)

    I repaired the Disk Permissions, but it's still the same. Is there something missing? Or what do you think?



    [Proces voltooid]

    Last login: Wed Sep  5 20:07:46 on console

    server:~ delsup$ clear


    server:~ delsup$ sudo /bin/launchctl unload -w /Applications/ mavis.amavisd.plist


    launchctl: Dubious ownership on file (skipping): /Applications/ mavis.amavisd.plist

    nothing found to unload

    server:~ delsup$ sudo /bin/launchctl load -w /Applications/ mavis.amavisd.plist

    launchctl: Dubious ownership on file (skipping): /Applications/ mavis.amavisd.plist

    nothing found to load

    server:~ delsup$ sudo more /Library/Logs/Mail/amavis.log

    /Library/Logs/Mail/amavis.log: No such file or directory

    server:~ delsup$

  • clerge Level 1 (0 points)

    There is no /Library/Logs/Mail


    I also tried this:


    server:LaunchDaemons delsup$ more org.amavis.amavisd.plist

    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">

    <plist version="1.0">






















    server:LaunchDaemons delsup$

  • clerge Level 1 (0 points)

    YES YES,


    After Trying and trying again and again, it suddenly works!!!!! What would be happened?


    Many, many, many thanks.

  • clerge Level 1 (0 points)

    i was a little bit to quick. I tried with another email account and of course this worked. So i'm not a step further. What can I try more?

  • pterobyte Level 6 (10,910 points)

    Did you try a different account on your server or on some unrelated server?


    Could you please show me the output of:

    ls -l /Applications/


    ls -l /Library/Logs/Mail
  • clerge Level 1 (0 points)

    I have always sent the mails from (with a pop- and smtp-account of my ML-server) in a workstation that is in the same network as my ML-server to my own ML-account and to other unrelated accounts on external servers (like mobile-me or yahoo). But when i thought it was working, i sent the mail from another account (mobile-me) and than i received the mail in my yahoo-account.


    Here are the outputs:


    server:/ root# ls -l /Applications/ mavis.amavisd.plist

    -rw-r--r--  1 delsup  admin  702 Jul 26 17:51 /Applications/ mavis.amavisd.plist

    server:/ root# ls -l /Library/Logs/Mail

    ls: /Library/Logs/Mail: No such file or directory

    server:/ root#

  • pterobyte Level 6 (10,910 points)

    Something is not right with your server. Was this an update? Clean install? Did any service ever work?


    If you don't have any working services set up yet, I'd be inclined to recommend to re-install the server part. If for some reason this is not an option, we can take it from there.

  • clerge Level 1 (0 points)

    It was a clean install. DNS works, I installed UCC-records (a set of 5), I had Webmail and Wiki worked locally, Mail works too but only with Virus and JunkMail checked off (Blacklist Filter checked on). The was a download from the app-store per 20/8/2012. My Airport was updated by for Message and Websites (but it didn't make the update for the email-services; I can do it manually). It is an Airport Extreme 802.11n of the first generation with OS version 7.6.1.. What TCP-ports (udp-ports) do i have to open in that case?


    I only don't have a direct connection to the internet yet. It will come soon. At the moment there are 2 NAT's between the server and the internet. A NAT from my Airport and a NAT from my provider. But the one of my provider will disappear soon, so that my Airport will have directly an internet IP-number. I tried Wiki and Webserver from the zone between the 2 NAT's by surfing to the WAN-IP-address of my Airport. And I could also surf to the internet from the server and workstations behind the second NAT (the one of my Airport).


    I could make users. I could make network-users and normal users in What is the difference between them?


    I can make a complete re-install (including Mounain Lion), but do you have propositions for a good workflow-order for the activation of the services?


    Can I re-use (or export) the UCC SLL-certificates?


    I Could do the complete re-install during this weekend if I might have the above questions answered. And if you have some more tips, they are welcome.


    I'm extremely grateful that i have such a support from you.

    Thank you very very much.

  • pterobyte Level 6 (10,910 points)

    OK, let's see if you can avoid re-installing for time being.


    Stop mail services using


    Open Terminal and issue:

    sudo chown root:wheel /Applications/
    sudo mkdir -p /Library/Logs/Mail
    sudo chown root:admin /Library/Logs/Mail
    sudo /bin/launchctl unload -w /Applications/


    Now open enable virus and junkmail

    Using start mail services 

    Wait a minute or two and then check if amavisd is running by issuing:

    sudo ps U amavisd


    If it is now running, you should be set. If not, open Terminal and issue

    sudo /bin/launchctl load -w /Applications/


    Now wait a minute and check if amavisd is running by issuing:

    sudo ps U amavisd


    If it is now running, you should be set. If not, check the aforementioned system.log and amavisd.log (hopefully amavisd.log is now there) for clues.




  • clerge Level 1 (0 points)

    YES Thank you very very much Alex,


    I sent the mail from the right workstation and received the mails everywhere, just like it has to be.


    I had to do the load in Terminal too and than I became this:

    server:~ delsup$ sudo ps U amavisd


    16194   ??  Ss     0:04.65 /Applications/

    16983   ??  Ss     0:02.20 /Applications/ (master)   

    16984   ??  S      0:00.01 /Applications/ (virgin child)   

    16985   ??  S      0:00.01 /Applications/ (virgin child)   

    server:~ delsup$


    I suppose that's the right reply in Terminal, since my mails are working now with Virus and JunkMail checked on.


    Now I can try out the rest. And than testing all things when my Airport is directly connected to the internet. Maybe you have some more suggestions for me, but I think I can work further.  I'm very thankful.


    Many thanks, I won't forget you helping me so friendly.

  • pterobyte Level 6 (10,910 points)

    My pleasure. :-)

    Glad you got it sorted.



  • lepikouze Level 1 (0 points)

    Hello everyone,


    Since this morning, the amavisd was not working on my server, i follow your posts but nothnig change.


    So, i will tell about my story


    when i was reading the amavis log, the only thing was :


    Nov 15 00:30:24 ishtar newsyslog[88530]: logfile turned over




    I tried to find where was the bin folder then, i tried to lunch with the comand debug

    cd /Applications/

    sudo ./amavisd -d


    And i get this error :


    Error in config file "/Library/Server/Mail/Config/amavisd/amavisd.conf": Global symbol "@example" requires explicit package name at /Library/Server/Mail/Config/amavisd/amavisd.conf line 119.


    At this line on the amavisd.conf i read this


    $virus_admin              = "";  # notifications recip.


    and 4 lines later i get this


    $mailfrom_notify_admin     = "virusalert\@$mydomain";  # notifications sender


    So i change "" to "virus-alert\"


    i restart mail and now it's working.


    But this really strange that the email address is

    If someone can tell me why this email is not in my domain? Or if i can change this with someting like without trouble.

  • Michael Kennard2 Level 1 (15 points)

    Been following this thread with a similar problem. I have tried everything and the best error I got since I couldn't get amavisd working at all. Try this error...


    cd /Applications/

    mail:bin administrator$ sudo ./amavisd -d


    Config file "/etc/amavisd.conf" does not exist, at ./amavisd line 1992.


    It shouldn't be looking for a conf file in etc at all. Where do I fix this?

  • lepikouze Level 1 (0 points)

    Hello Michael,


    This is what you nedd to do :


    Open with MORE or VI /Applications/


    And go to the line 15639


    At this line you must have


    push(@config_files, '/etc/amavisd.conf')  if !@config_files;


    Comment this line and add this just under

    push(@config_files, '/Library/Server/Mail/Config/amavisd/amavisd.conf')  if !@config_files;


    Save exit and retry ./amavisd -d


    Watch the log of amavisd in console, to see if you have other problem.


    Maybe you will have to edit your amavisd.conf like my old post.