8 Replies Latest reply: Mar 30, 2006 2:01 AM by James Mol
James Mol Level 3 Level 3 (685 points)
Is it not responding to a "poll" activity monitor is taking of the process? Or not responding to its "parent"?

History
I have been using Activity Monitor to help track down a problem I am having with Compressor - have posted in that forum about that problem. After an hour or so into the encoding Activity Monitor shows the red words (Not Responding) behind the process "compressord", the CPU usage goes nearly to zero. Then after a bit the CPU usage shot up again, and Batch Monitor shows the percent done going up and the time remaining going down, but Activity Monitor shows (Not Responding) but it finished as it should. When it was done, the CPU usage went down, but Activity Monitor still shows (Not Responding).

Thank you for your insight

Power Mac Dual 1.4, Mac OS X (10.4.5), 2GB Ram, SATA RAID drives
  • Final Cut Pro Level 2 Level 2 (270 points)
    James,
    It seems like it might be an error with the Activity Monitor. Try repairing Disk Permissions in Disk Utility.
    Not responding means that the application isn't responding to the system.
    I could be totally wrong, but I'm not sure. That's just the way I think of it.
    Remember to mark as helpful or solved.
    BP
  • R C-R Level 6 Level 6 (16,750 points)
    FWIW, I sometimes see 'not responding' messages when apps are doing something intensive, like when Toast is compressing a DVD for burning. During this time, Toast won't allow any other commands (which is the way it is designed, I think), so I assume in this case 'not responding' means 'busy,' more or less.

    However, when the process is finished, the 'not responding' status goes away, so you seem to be experiencing something different. You might try trashing Compressor's .plist to see if it makes any difference.
  • James Mol Level 3 Level 3 (685 points)
    I see what you mean. Starting Word, for a time it shows not responding, but that disappears when it finishes starting up. But most of the time, when Batch monitor starts compressing it does not have the not responding, only after the CPU usage goes down.

    Thanks for your input
  • James Mol Level 3 Level 3 (685 points)
    Tried it but did not help.
  • Final Cut Pro Level 2 Level 2 (270 points)
    Thats really odd.
    Because I also am an editor, and have never had any problems with my Compressor and Batch Monitor.
    It could possibly be the Compressor, try downloading an update. By saying It could possibly be the Compressor I mean that maybe it is doing something with the system, Acitivity Monitor included. Maybe an update could fix those bugs.
    Best of luck.
  • Kiwi Graham Level 4 Level 4 (1,850 points)
    I'm not familiar with the inner workings of Unix apps to be an expert on this but in general any "good citizen" application should periodically check for requests/commands from the operating system. It should then send back an appropriate response. That's the tie in with "Not Responding". eg. For a typical GUI application such a request may relate to refreshing the screen display.

    From the programmer's perspective there are a couple of reasons for not responding.
    1) I'm doing something critical and things may go wrong if I take a break to respond to you. (eg. burning a disc)
    2) I'm just getting things organised so I can't respond to you in a meaningful way until I complete (eg. program launch)
    3) Oops, I've gone into a loop and I forgot to include a piece of code inside the loop to check for your message - but hopefully I'll be out of the loop soon.

    And of course there's the situation where the program follows a path through the code that it never gets around to checking for that message. And if that message happens to be a "please quit" it won't happen and the "force quit" option comes into play.

    Graham
  • James Mol Level 3 Level 3 (685 points)
    This is odd. I did not have any trouble during the volleyball season here in Michigan, would do several DVDs of the team a week. The last one I did was in the middle of February. Then came security update 2006-001 & 002. I need to see if there is a log that show other software I might have installed.

    Oh, for future reference, I did create another account to see if I had the same problem in that account. I started batch monitor and from the beginning it showed not responding in Activity Monitor. It did spool down after a while. I swtiched to the main account to do some things and noticed the CPU usage had increased and compressord was using most of it. When I switched back to my test account, it was running again, but still showing Not Responding.

    So, in the main account activity monitor shows it running normal and in the test account it shows Not Responding at the same time.
  • James Mol Level 3 Level 3 (685 points)
    Thanks for expanding my understanding. While there is the down side to Not Responding, the three examples you give indicate that it may not be bad when I see Not Responding. I need to wait it out, since I have experienced "compresserd" taking a break for a time and getting back to business.

    While I am marking this solved, I still invite any more insight on Not Responding.

    Thanks to all!