9 Replies Latest reply: Jun 22, 2015 10:07 PM by Mark K9
waitey1234 Level 1 (5 points)

i can't get mail to correct the spelling automatically as i type anymore. in system preferences i have the text set to autocorrect and also within mail there's a tick mark on "check spelling as i type". also in mail preferences i have the setting to check spelling as i type set. mail can see i've typed a word wrong and underline it but it won't autocorrect it even though the option to do so is turned on everywhere.


MacBook Pro, OS X Mountain Lion, Mail
  • sberman Level 7 (32,410 points)

    In Mail, use the menu to go to:

    Edit > Spelling and Grammar and click on "Check Spelling Automatically"

  • waitey1234 Level 1 (5 points)

    i have that turned on. it has a check mark at the side of it. i also have it turned on in mail preferences and in system preferences. safari will correct the spelling as i type, as will outlook. it's just mail that won't.

  • sberman Level 7 (32,410 points)

    Sorry, that's "Correct Spelling Automatically".

  • waitey1234 Level 1 (5 points)

    i've solved the problem. i trashed my mail preferences file and set it back up again. it works. i guess it must have been corrupted or something.

  • mnachbar Level 1 (0 points)

    I'm having the same problem. How'd you delete the preferences file and set it up again??

  • waitey1234 Level 1 (5 points)

    in the finder select go from the menu holding the alt/option key down and then select the library option.

    inside there is a folder called preferences and inside that was a file called com.apple.mail.plist

    i deleted that, rebooted mail, set my accounts up again and then the spell correcting worked.

    it does delete all your exisiting accounts and things though but it restored the functionality of the spell correcting.

  • CarisaC Level 1 (10 points)

    I finally got my mac mail to autocorrect as I type.  To do it, reply to any message in your inbox.  Then go to Edit/Spelling and Grammar and click on "Correct Spelling Automatically."  If you don't have a message open, this option will be grayed out.  But once you've checked this option for one message, it'll autocorrect in every message you send. 

  • BeverlyCA Level 1 (0 points)

    I also noticed that you have to click to the right of the word not on it! Thank you CarisaC!

  • Mark K9 Level 1 (0 points)

    CarisaC,

     

    You are a genius. I have been struggling with this failure to auto correct for months now and your solution worked perfectly, without the need to kill the plist and reset up all the accounts.

     

    Thanks so much for your post!!!

     

    Mark