Previous 1 2 Next 19 Replies Latest reply: Jun 19, 2014 2:44 PM by iPogo Go to original post
  • rkaufmann87 Level 8 Level 8 (48,830 points)

    Locate the Reset SMC and PRAM link I provided earlier and reset both the SMC and PRAM 2-3 more times. Then retest, if it doesn't work chances are it's your keyboard. You can test if it is by using ANY USB keyboard and see if they problem still happens, if it doesn't then you know it's the keyboard.

  • Patchlord Level 1 Level 1 (0 points)

    I did the SMC and PRAM reset once, but it didn't work. I'll try doing 2 or 3 times, but I took my keyboard to work and used it in the office's iMac and it worked without a hitch. So it's like 123pleasehelpme's issue:

     

    The computer works fine with a different keyboard.

    The keyboard works fine with a different computer.

    The problem only happens when the keyboard and computer are together.

  • jc10o Level 1 Level 1 (0 points)

    My keyboard just started doing the same thing the other day. I have tried what has been suggested in previous posts and nothing has worked so far. Got any better ideas??????????

  • Patchlord Level 1 Level 1 (0 points)

    Since I couldn't fix the problem, I borrowed a USB keyboard from a friend and used it for about two weeks Then, last Monday, I erased the keyboard from the bluetooth panel, reset the SMC twice followed by a PRAM reset, and paired the wifi keyboard again. It worked and, so far, the problem has not come back.

     

    Tchau!

  • iPogo Level 1 Level 1 (0 points)

    This happened to my keyboard as well.

    It seems to be an issue with the (fn) key getting stuck in some way.

    If CMD+TAB isn't working, try pressing (fn+CMD+TAB) & you should get full functionality back.

    This will also see the SPACE & Caps Lock working again.

    The issue still happens intermittently but the (fn) key will set things right.

Previous 1 2 Next