6 Replies Latest reply: Jul 31, 2013 10:11 AM by cclatten
True Vine Level 1 Level 1 (0 points)

When I open several pdf documents that I recently added to my website, the images on the documents do not show up when I view them through Safari?


Safari, Mac OS X (10.7.4)
  • Linc Davis Level 10 Level 10 (169,395 points)

    Back up all data.

     

    Quit Safari. In the Finder, select Go Go to Folder... from the menu bar, or press the key combination shift-command-G. Copy the line of text below into the box that opens, and press return:

     

    /Library/Internet Plug-ins

     

    From the folder that opens, remove any items that have the letters “PDF” in the name. You may be prompted for your login password. Then launch Safari and test.

     

    If you still have the issue, repeat with this line:

     

    ~/Library/Internet Plug-ins

     

    If you don’t like the results of this procedure, restore the items from the backup you made before you started. Relaunch Safari again.

  • True Vine Level 1 Level 1 (0 points)

    I do not have any items with PDF in the name. When I search with "~/Library/Internet Plug-ins" all I have is 2 Webex plugins. Should I remove them?

  • Linc Davis Level 10 Level 10 (169,395 points)

    Select Help Installed Plug-ins from the Safari menu bar. Besides the following, what plugins are listed?

     

    iPhotoPhotocast

    Java

    QuickTime

    Shockwave Flash

    WebKit built-in PDF

  • True Vine Level 1 Level 1 (0 points)

    Flip 4 Mac Windows Media

    Realplayer

    Silverlight

    WebEx general

    WebEx 64 general

  • Linc Davis Level 10 Level 10 (169,395 points)

    Are you having problems only with the PDF's on your site? If so, it's a site issue, not a Safari issue.

  • cclatten Level 1 Level 1 (0 points)

    My problem seems to be with Safari, not the sites.  Chrome shows the pdfs and there are various sites I have tried to show pdfs.

     

    I tried your fix, but as someone from another thread mentioned, I have nothing in ~/Library/Internet Plug-ins or /Library/Internet Plug-ins, that has "PDF" in it.  Not in the name or the suffix.