Skip navigation

cannot connect to itunes store on ipad

234815 Views 294 Replies Latest reply: Dec 10, 2013 2:51 AM by Whydoesthishappentomeeeeeee RSS
  • sadonathan8839 Level 2 Level 2 (210 points)
    Currently Being Moderated
    Aug 22, 2012 9:29 PM (in response to nj9800)

    Are you absolutely sure you are using the apple id to do updates that it was purchased with? Sounds like that is the issue. To verify click the app icon and then selected purchased and see if that app is on there.

  • nj9800 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2012 9:37 PM (in response to sadonathan8839)

    Yes, I am sure the IDs are correct. I can make new purchases, but get the error on updates.  I tried updating with each account I used to log into the store.

    BTW... If you make purchases on a device using multiple Apple IDs, you will be prompted for the correct one when updating (assuming you can connect to the iTunes Store). 

  • BeersYourFriend Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 22, 2012 9:39 PM (in response to sadonathan8839)

    acually, purchased did not work either. so i logged out of my apple id, then reset me network settings. it went through a reset, and reentered my modem password. tapped the apple store, typed in my password, then i was able to access the PURCHESED section again... But not the Update section............... it must be apple fooling around. IDK what to do from here. did the same thing on my iphone, and am still getting the message..

  • araczynski Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 7:27 AM (in response to boltond)

    same thing, purchases work, downloading works, just not updates (tried in multiple different locations/offices/homes).  since its apple (we can do no wrong) I don't expect any updates/confirmation, just have to keep on trying for a few days i guess.

  • tigres Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 11:31 AM (in response to araczynski)

    I too cannot update any apps (23).  I can purchase new, see purchases and install, but when I select update- Cannot connect to iTunes Store.

     

    iPad 1.

     

    Frustrating.

    Reset network settings.

    logged out of account

    Hard reset

    logged into itunes account

     

    I give, nothing I have done requires more troubleshooting for updating apps.  Strangely, the update list continues to grow; so the mothership is sending out the required updates, she just blocks me from getting them.

     

    just doesn't work

  • nickwill20 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 11:43 AM (in response to boltond)

    I had the same issue and it was due to me changing the date on the devices.

    If the date was 2 months ahead when downloaded it won't let you apply them until it reaches that date.

    I had to change the date on my devices to dec this year and then it let me connect to iTunes store.

     

    Once downloaded and applied change the date back to the connect date.

     

    Cheers nick

  • Virtualhawk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 12:04 PM (in response to tigres)

    Exact same problem for me. Weirdly, I can connect and get updates on my iPad 2, but on the iPad 3 (same account, password,of course) I get this damned "cannot connect" message you are all experiencing. All other aspects of the iTunes store work.

     

    WILL SOMEBODY FROM APPLE PLEASE READ THESE POSTS??!?

  • phxflyboy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 12:37 PM (in response to boltond)

    Add me to this list as well. The ONLY thing I can't due is UPDATE apps on iPad 2. Everything else (purchase, search, etc.) works fine. Tried every suggestion on the entire Internet, no help. Same account, same apps on iPhone 4, update works fine. I'm beginning to agree with the poster who referenced Apple tweaking things for iOS 6.  Hopefully this will get straightened out soon.

  • his1987 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 2:53 PM (in response to phxflyboy)

    You can add me as well.  I can buy new apps, just can't update existing on my iPad first gen.  There is some comfort in knowing I am not alone with this issue!  I've heard negative tweets work in getting companies attention. 

    May need to try that.

  • Roecks-N-Effect Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 2:59 PM (in response to boltond)

    My iphone wouldn't connect to the itunes store for updates. I tried every solution I could find online, nothing worked. Today I tried changing the date to 2 months ahead (not sure why... something I read I think) and it connected to the itunes store. I switched back to auto date and time and it still connects.

  • ReverieRevel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 3:33 PM (in response to boltond)

    I just had this issue (and found this thread on a search). I was able to do everything but updates... I think I fixed it by setting my time ahead August 23 2013, and then tried to connect to the updates - it said there was a security issue with the date, so I changed it back to today... and then went back to the updates, and everything worked!

     

    A few weeks ago I was playing around and had set my system forward by a few months - that's when my issues with the updating started.

  • Virtualhawk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 4:15 PM (in response to his1987)

    Ok - I've tried setting the date a coupe of years in the future and tried to access the app store, but it wouldn't let me because of "security issues" arising from the date being wrong. I then took it back to automatic time and date and - hey presto!!! - I can do my updates now! No idea why this should work, but IT DOES!!!!

  • annfromhilliard Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 4:33 PM (in response to boltond)

    I tried all available fixes and they didn't work--except for changing the date.  Changed it to two days ahead--voila! Everything is updating.

  • ddarby08 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 5:57 PM (in response to nickwill20)

    changing the date ahead worked - thx!

  • cohojones Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 7:03 PM (in response to Roecks-N-Effect)

    This also worked for me.  Many thanks for the solution.

1 2 3 4 ... 20 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.