Previous 1 2 3 4 5 6 Next 296 Replies Latest reply: Mar 9, 2016 11:28 AM by Aujouret Go to original post
  • Drumersgrl Level 1 Level 1

    Sorry it's not resolving for you! I have gotten lots of emails and everyone has resolved their issue by changing the date. If I come across another solution I will post it here.

  • Drumersgrl Level 1 Level 1

    R u getting any type of error code?

  • tagood7 Level 1 Level 1

    Only a pop up when I hit the update that says cannot connect to iTunes.

  • tagood7 Level 1 Level 1

    Oops I mean "cannot connect to iTunes store"

  • Drumersgrl Level 1 Level 1

    Have you tried signing out

    Settings>Store>Sign out

     

    Cut off the iPad, wait 10 seconds, turn it back on.

    Change the date to 2022, go to the app store and try to update. After it tells you to check date and time. Go back and manually set the correct date and time.

     

    Let me know if that still doesn't work. I will keep searching for another option just in case.

  • Drumersgrl Level 1 Level 1

    Also make sure you have no running apps in the background. Double click the home button. Sub screen will pop up, hold one of the icons til the red minus pops up and delete them all. Do that before you turn off the iPad

  • tagood7 Level 1 Level 1

    Didn't work, thanks.

  • Drumersgrl Level 1 Level 1

    Sorry, your issue must not be the same ad every one else's. I didn't find any other possible solutions. Hopefully you find a fix soon. I know how frustrating it is!!

  • Drumersgrl Level 1 Level 1

    Last effort. Try them all LOL let me know which one if any fixes it.

     

     

    Solution #1

    Navigate to Settings > General > Restrictions.

    Enable Restrictions for about 5 seconds and disable it back again.

    Check if you can connect to iTunes now.

     

    Solution #2

    Reset your network settings by Navigating to Settings > General > Reset > Reset Network Settings

    Restart your iPhone.

     

    Solution #3

    Navigate to Settings > Wifi > {YourWiFiNetwork}

    Tap the blue arrow and tap Forget This Network

    Reboot your iPhone and try again.

     

    Solution #4

    Check if your date and time are correct.

    Navigate to Settings > General > Date & Time.

    Disable Set Automatically.

    Check if the time zone and time is correct, adjust if necessary.

    If they correct, enable Set Automatically.

     

    Solution #5

    Uninstall iBooks and install it back again.

     

    Solution #6

    If you have a jailbroken device, SSH to /private/var/mobile/Library/Caches/com.apple.mobile.installation.plist

    Delete the file and Reboot.

  • Drumersgrl Level 1 Level 1

    Solution #7:

     

    - Go to Settings / Store and “touch” your Apple ID

    - In the pop-up menu select View Apple ID

    - Set the Country / Region setting to United States

    - Hit the “DONE” button in upper right corner of “pop-up” screen

    - Sign Out of Apple ID

    - Sign back in

  • MattGraal Level 1 Level 1

    I read over 20 how to fix this can't connect to iTunes crap is something wrong with the sever? And how can someone unquee apps without the apple tech team?

  • BeersYourFriend Level 1 Level 1

    Awesome man!

    Worked like a charm!

     

    Thx!

  • TexMom Level 1 Level 1

    Date change worked for me as well.  Makes no sense at all (I hadn't made any date changes previously, and my settings  included automatic date and time, not manual), but I am so grateful that someone figured this out. Thanks!!!

  • Copperjake Level 1 Level 1

    I tried all 7 of your suggestions with no result. Not sure what to do next. Still get the cannot connect to iTunes store message.

  • Drumersgrl Level 1 Level 1

    How far in years did u go? Most people found that going up to 2022 or higher fixed the issue

Previous 1 2 3 4 5 6 Next