1 2 3 Previous Next 39 Replies Latest reply: Oct 25, 2013 1:16 AM by ando999
Maurinho Level 1 Level 1 (0 points)

Hi Support,

please save me.

 

After the update to Lion first and Mountain Lion after, Wi-Fi just won't turn on.

Then sometimes, randomly, it works.

 

I tried ihe remove battery - press power technique but it does not seem to work. I got a MacBook 13' End 2008

 

Thanks!

 

Screen Shot 2012-08-23 at 20.26.35.png


MacBook, OS X Mountain Lion (10.8.1)
  • 2. Re: After update to Lion, Wi-Fi does not turn on
    chillboy100 Level 1 Level 1 (0 points)

    I'm having the same problem and I just reset my PRAM with no success. Still not able to turn on my Wi-Fi. It was working until I updated from the App Store.

  • 3. Re: After update to Lion, Wi-Fi does not turn on
    Maurinho Level 1 Level 1 (0 points)

    @mende1

     

    This does not solve any problem at all as chillboy100 said...

  • 4. Re: After update to Lion, Wi-Fi does not turn on
    2yb Level 1 Level 1 (0 points)

    I have created a startup/shutdown/restart script which will disable the wi-fi on shutdown/restart and re-enable the

    wi-fi on startup.  This has fixed the issue on my 2008 MB where the wi-fi would not turn on after installing Mountain Lion.  The script must be owned by root with permissions set to 755.  Do the following in terminal.

    1. sudo passwd root (enable root password)

    2. su root

    3. cd /Library/StartupItems

    4. create the following 4 files/directories:

      Wi-Fi_Fix/Resources/English.lproj/Localizable.strings

      Wi-Fi_Fix/Resources/version.plist

      Wi-Fi_Fix/StartupParameters.plist

      Wi-Fi_Fix/Wi-Fi_Fix

     

    Here's the file contents:

    Wi-Fi_Fix/Resources/English.lproj/Localizable.strings:

     

    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist SYSTEM "file://localhost/System/Library/DTDs/PropertyList.dtd">

    <plist version="0.9">

    <dict>

            <key>Starting Wi-Fi_Fix</key>

            <string>Starting Wi-Fi_Fix</string>

            <key>Stopping Wi-Fi_Fix</key>

            <string>Stopping Wi-Fi_Fix</string>

            <key>Restarting Wi-Fi_Fix</key>

            <string>Restarting Wi-Fi_Fix</string>

    </dict>

    </plist>

     

     

    Wi-Fi_Fix/Resources/version.plist:

     

    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">

    <dict>

            <key>BuildVersion</key>

            <string>0</string>

            <key>CFBundleShortVersionString</key>

            <string>2.5.2</string>

            <key>CFBundleVersion</key>

            <string>2.5.2</string>

            <key>ProjectName</key>

            <string>Wi-Fi_Fix StartupItem</string>

            <key>SourceVersion</key>

            <string>675</string>

    </dict>

    </plist>

     

     

    Wi-Fi_Fix/StartupParameters.plist:

     

    {

        Description = "Wi-Fi_Fix";

        OrderPreference = "Early";

        Provides = ("Wi-Fi_Fix");

        Messages =

        {

            start = "Starting Wi-Fi_Fix";

            stop = "Stopping Wi-Fi_Fix";

        };

    }

     

     

    Wi-Fi_Fix/Wi-Fi_Fix:

     

    #!/bin/sh

    #

    # Bug fix for Wi-Fi not connecting

    #

     

     

    . /etc/rc.common

     

     

    StartService ()

    {

      networksetup -setnetworkserviceenabled Wi-Fi on

    }

     

     

    StopService ()

    {

      networksetup -setnetworkserviceenabled Wi-Fi off

    }

     

     

    RestartService ()

    {

            StopService

            StartService

    }

     

     

     

    #

    # main script

    #

     

     

    # must make sure we are on a system with the RunService() function

    # implemented (not implemented on Mac OS 10.1.x)

     

     

    foundRunService=`grep -c RunService /etc/rc.common`

    if [ $foundRunService -a $foundRunService -eq 1 ]; then

            RunService "$1"

    else

            case $1 in

                    "start") StartService;;

                    "stop") StopService;;

                    "restart") RestartService;;

                    *) echo "$0: unknown option: $1" > /tmp/wi-fi_fix.out ;;

            esac

    fi

     

     

    5. cd /Library/StartupItems

    6. chmod -R 755 Wi-Fi_Fix 

    7. exit and close terminal

    8. reboot computer 2 times.

     

    The Wi-Fi_Fix needs 2 reboots to take effect.  On the first shut-down of the reboot, the program hasn't been loaded, so it won't disable the wifi.  After first reboot, it will appear as if the problem still exists, but the program is now loaded, and wi-fi will be shut-down and enabled correctly upon the second reboot.

  • 5. Re: After update to Lion, Wi-Fi does not turn on
    GH_779 Level 1 Level 1 (0 points)

    Many thanks for posting! The old MB31 is running again on WiFi.  OS 10.7.4.  Will update if I run into any issues.

  • 6. Re: After update to Lion, Wi-Fi does not turn on
    bhvilar Level 1 Level 1 (0 points)

    I tryed your solution, but when I reboot the computer a message shows up in the screen stating that "Library/StartupItems/Wi-Fi_Fix" has not been started because it does not have the proper security settings. Any tips?

  • 7. Re: After update to Lion, Wi-Fi does not turn on
    2yb Level 1 Level 1 (0 points)

    Hi bhvilar.

     

    I am not sure what may be causing your issue with the "proper security settings".

    My best guess is that the script is not owned by root with permissions set to 755.

    If I do the following:

    1. cd /Library/StartupItems

    2. ls -la    -- I have the following owner, group and permissions:

    drwxr-xr-x   5 root  wheel   170 Dec  2 23:44 .

    drwxr-xr-x+ 68 root  wheel  2312 Dec 24 00:59 ..

    drwxr-xr-x   5 root  wheel   170 Dec  2 22:16 Wi-Fi_Fix

     

    Notice that the user is root, the group is wheel, and the permissions are set to 755.

     

    3. ls -la Wi-Fi_Fix

    total 16

    drwxr-xr-x  5 root  wheel  170 Dec  2 22:16 .

    drwxr-xr-x  5 root  wheel  170 Dec  2 23:44 ..

    drwxr-xr-x  4 root  wheel  136 Dec  2 22:17 Resources

    -rwxr-xr-x  1 root  wheel  196 Dec  2 22:16 StartupParameters.plist

    -rwxr-xr-x  1 root  wheel  688 Dec  2 22:13 Wi-Fi_Fix

     

    4. ls -la Wi-Fi_Fix/*

    total 8

    drwxr-xr-x  4 root  wheel  136 Dec  2 22:17 .

    drwxr-xr-x  5 root  wheel  170 Dec  2 22:16 ..

    drwxr-xr-x  3 root  wheel  102 Dec  2 22:19 English.lproj

    -rwxr-xr-x  1 root  wheel  469 Dec  2 22:17 version.plist

     

    For #3 and 4, the owner is root, user wheel and permissions are 755 as well.

     

    The script will not run correctly without being owned by root and permissions set to 755.

    If the owner is not root, here is a way to enable the root user:

    http://support.apple.com/kb/HT1528?viewlocale=en_US&locale=en_US

     

    So,

    1. enable the root user and password

    Then in the terminal:

    2. su root

    3. cd /Library/StartupItems

    I don't know what the group is on your system, but you should make it match whatever the group is for the ". and .. directories.  Mine is wheel so I'll use that in the next step, but replace wheel with whatever your system is using.

    4. chown -R root:wheel Wi-Fi_Fix   

    -- Note: you can also do "man chown" on the command line to read about other chown options

    5. chmod -R 755 Wi-Fi_Fix

    6. exit from terminal and try rebooting system 2 times.

     

    Hope that helps.

  • 8. Re: After update to Lion, Wi-Fi does not turn on
    hibisrat Level 1 Level 1 (0 points)

    Thanks man your codes worked for me finally. I just copy paste the code after the sudo process.

     

    Thanks again

  • 9. Re: After update to Lion, Wi-Fi does not turn on
    nayan159 Level 1 Level 1 (0 points)

    I have the same problem in MBP mid 2010 13 inch 2.6GHz.

    after updating to OSX Mountain Lion 10.8.4 it finds network. but everytime shows connection time out. tried to join various wifi routers but no hope.

    all solutions on internet I have tried but no success.

    system profiler showing this:

     

    Card Type:          AirPort Extreme  (0x14E4, 0x8D)

      Firmware Version:          Broadcom BCM43xx 1.0 (5.106.98.100.17)

      MAC Address:xy;xy;xy;xy

      Locale:          APAC

      Country Code:          X1

      Supported Channels:          1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165

      Wake On Wireless:          Supported

      AirDrop:          Supported

      Status:          Off

     

     

    Can I use your script for MBP mid2010?

    do i need any  modification ?

  • 10. Re: After update to Lion, Wi-Fi does not turn on
    2yb Level 1 Level 1 (0 points)

    I am not sure if my script will solve your issue, but it's worth trying.

    I don't think anything will need to be modified. It worked on 2012 Mac mini as well.

  • 11. Re: After update to Lion, Wi-Fi does not turn on
    saul_eye Level 1 Level 1 (0 points)

    Hi 2yb,

    I wondered if you could help me - I'm new to these discussions, but tearing my hair out with frustration with the internet problems. I've tried everything else (PRAM etc), but not tried your script, and would like to try it. However, I'm very inexperienced with Terminal, so not sure how to follow your script.

     

    I'm guessing, that instructions 1-3 are typed into terminal.

    Then you say create the following 4 files/directories. Where do I do this? Is this also in Terminal, if so how?

    After this, can I just copy and paste the extensive script into Terminal

    Finally, do I just follow instructions 5, 6, 7 and 8?

     

    Sorry - these are probably such basic questions, but I'd be hugely grateful for your help.

  • 12. Re: After update to Lion, Wi-Fi does not turn on
    2yb Level 1 Level 1 (0 points)

    Hi saul_eye,

     

    1. Here's directions on how to enable the root user if the owner is not root, here is a way to enable the root user:

    http://support.apple.com/kb/HT1528?viewlocale=en_US&locale=en_US

     

     

    2. Do the following commands, steps a-i in the terminal

       do step "a" if you didn't follow steps from #1 above to enable root password

       a. sudo passwd root

     

       for step b, this will ask for a password.  If you followed #1 above, I think your login password will work if you are also the administrator.

        b. su root 

        c. cd /Library/StartupItems

     

       steps d-i will create the following 4 files/directories ("mkdir -p" will create directories, "touch" will create file):

       d. mkdir -p Wi-Fi_Fix/Resources/English.lproj
       e. touch Wi-Fi_Fix/Resources/English.lproj/Localizable.strings
       f. touch Wi-Fi_Fix/Resources/version.plist
       g. touch Wi-Fi_Fix/StartupParameters.plist
       h. touch Wi-Fi_Fix/Wi-Fi_Fix
       i. cd Wi-Fi_Fix

    3. Using an editor, you can open the 4 files, and paste the contents of the scripts into the files.
       In terminal, you can use the vi editor.  It's not the easiest to use, but is always available.
       Note: The vi editor has different modes: edit  and command mode.  

       You can also google search "vi commands" for reference

     

       Here's the steps to do it.  Right now, you should be in the Wi-Fi_fix directory.
       Do the following for the Wi-Fi_Fix, StartupParameters.plist and version.plist files:
       a. vi <file name>  -- This will open the file and be in command mode.
       b. press the "x" key.  This will put the vi editor in edit mode
       c. paste contents of file from earlier post on Dec 2, 2012.
       d. press the "Esc" key. This will put the vi editor back in command mode
       e. press ":" then "x" then "Enter" keys.  This will save and exit vi.

     

       After you have done this for the 3 files in the Wi-Fi_Fix directory do the following:
       aa. cd Resources/English.lproj
       bb. vi Localizable.strings
       repeat steps b through e above.

     

    4. In the terminal do steps a and b.
       a. cd /Library/StartupItems
       b. chmod -R 755 Wi-Fi_Fix

     

    5. exit and close terminl.
    6. reboot computer 2 times

     

    Hope that helps.

  • 13. Re: After update to Lion, Wi-Fi does not turn on
    saul_eye Level 1 Level 1 (0 points)

    2yb,

     

    Thanks so much for this.

    Bizarrely, after a week of this 'no hardware installed' business, and wifi pretending to be on but network connections saying it is off, it has just decided to start working again. Absolutely no idea why; Mountain Lion, is a strange and very poorly evolved animal.

    However, I have no doubt it will start up again, and thank you for such clear instructions, which I'll definitely be able to follow.

  • 14. Re: After update to Lion, Wi-Fi does not turn on
    saul_eye Level 1 Level 1 (0 points)

    Hi 2yb,

     

    Predictably, wifi is back up to its old tricks. I hope you don't mind, but one more basic question about the script:

     

    When using the editor to paste the contents of the script into each of the files, does the first line need to be pasted, i.e. should I paste in the line in bold below, or just the script after this?

    Wi-Fi_Fix/Resources/English.lproj/Localizable.strings: 

    (I couldn't work out if this line was a heading, or part of the script)

     

    Thank you so much for your help with this.

     

    For other novices out there, if, like me you are unable to make the cd commands work (it says the file doesn't exist), you can instead do this, by dragging the file from finder into terminal whilst holding the command key.

1 2 3 Previous Next