4 Replies Latest reply: Aug 23, 2012 1:29 PM by Johnny Logo
Johnny Logo Level 1 Level 1 (0 points)

The Aperture Library seems to be damaged. I have rebuild the database a number of times but after certain time the app crashes again and the whole process of rebuilding needs to start again. There are 25.000 pics in my library.

 

I use Mountain Lion, latest version Aperture.

 

Thanks for helping out


Aperture 3, OS X Mountain Lion (10.8)
  • Frank Caggiano Level 7 Level 7 (25,715 points)

    Does it crash during the rebuild or after the rebuild when you are running Aperture?

     

    If it is after the rebuild when you are running Aperture try pressing the shift key as soon as you start Aperture. This will prevent preview generation. If there is a corrupted image in the library this should allow Aperture to run. If this works then we;ll need to hunt down the corrupted image.

     

    Post back the results.

     

    good luck

  • Johnny Logo Level 1 Level 1 (0 points)

    Frank, thanks. This works and I did identify a couple of corrupted images in a 'recovered project' file. Does it suffice to just delete those images?

     

    Thanks

  • Frank Caggiano Level 7 Level 7 (25,715 points)

    Deleting those images from Aperture should let you get Aperture running normally again.

     

    Once you delete them in Aperture and empty the Aperture trash they will be put in your system trash. If they are images you might want to try and rescue  I would recommend taking them out of the system trash and putting them somewhere, say your desktop.

     

    Then you can try opening them in say Preview to see what happens and what they look like. Depending on what Preview does it my be possible to save them.

     

    regards

  • Johnny Logo Level 1 Level 1 (0 points)

    Frank, terrific! Works like doodle again. Happy!

     

    Many thanks