3 Replies Latest reply: Apr 11, 2006 8:19 AM by peptoabysmal
peptoabysmal Level 1 Level 1 (0 points)
Hi,

I can't get any of my browsers Safari, Firefox or Netscape to run a simple applet such as a version checker applet.

Netscape says Java is turned off, and it's not.

I have the latest Java updates from the software update for Tiger.

Before I do a clean install, I thought I'd try here.

From the terminal, java -version gives me this:
java version "1.4.2_09"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_09-232)
Java HotSpot(TM) Client VM (build 1.4.2-54, mixed mode)

iMac G5, Mac OS X (10.4.5)
  • scapesuiter Level 7 Level 7 (27,660 points)
    peptoabysmal, the problem with Netscape is that it needs Java 1.3.1. For it to use 1.4.2 you can download the MRJ plugin from VersionTracker.com. You can test your java and javascript at these sites:

    Java and Javascript

    Java Virtual Machine

    If these don't work you probably need to reinstall Java.
  • peptoabysmal Level 1 Level 1 (0 points)
    Thanks for the links. I have been using several other Applets on the web that are supposed to report the java version or say hello world or whatever. They all work on my PC, but not the iMac.

    I tried the Java embedding plugin from source forge, which contains some kind of MRJ library.

    I have tried re-installing Java several times by downloading installers from Apple. Maybe I should look for the 1.3 installer?

    The main reason I have this machine is to test compatibility with our sites that use Java applets and now I can't even get a simple hello world going. If I can't get it running soon, I'll have to nuke the hard drive and start over and be very careful about what updates and so forth I accept. I pretty much have been automatically accepting the Apple update software and everything was working until a couple of days ago. I think there was a security update or some such, but I don't really have any hard evidence as to what caused this.

    I have the latest versions of all three browsers. This is OSX Tiger, the only "MRJ" installer I can find is the old OS 9 one.
  • peptoabysmal Level 1 Level 1 (0 points)
    I went through the steps of a clean install and checked that Java applets worked in Safari, Firefox and Netscape on Tiger (all the latest vrersions)

    I did all of the Mac OSX updates and it turns out that the Java runtime parameter was causing the problem. One of our Java applets uses sometimes big images and I had the Xmx runtime parameter incorrectly entered. I had it as Xmx 256 and tried -Xmx 256, but it should be -Xmx262144. (1024 X 256) or -Xmx[bytes] (The default on Mac is 64 M)
    At least according to this:
    http://developer.apple.com/documentation/Java/Conceptual/JavaPropVMInfoRef/Artic les/JavaVirtualMachineOptions.html#//appleref/doc/uid/TP40001974-DontLinkElementID14

    My guess is that the older version(s) of Java ignored or guessed at an improper runtime parameter, because it worked before.

    Now it works with all the latest updates on all three browsers.