Previous 1 2 Next 19 Replies Latest reply: Oct 25, 2013 6:27 PM by baopham
Yoyor94 Level 1 Level 1 (0 points)

Hi all,


I'm experiencing some weird issue with Mission Control (it was with Lion ... and Mountain Lion did not correct this) :

You can see a video I've taken yesterday (sorry for the poor quality) :


As you can see :

- Mission-Control makes some of my windows (all windows in the example video) disappearing : they're reduced to "0" pixel

- Sometimes, the App icon stays visible (but I cannot select the windows as it is 0pixel size ...). Sometimes, even the App icon is not shown (often with Safari)

- Sometimes : only Safari is experiencing the issue ==> all other windows stay OK (Finder, etc... can be selected in Mission Control and Safari is the only 0 pixel sized). In the enclosed video, all apps are affected which is quite rare.


if I close the impacted app(s) and relaunch it, mission control handle the re-opened app(s) correctly.


Is there any way to fix this ?

I was hoping it was a 10.7.x issue but as 10.8 (incl. 10.8.1) is not fixing this, I'm losing patience.


Thanks in advance,



iMac, OS X Mountain Lion (10.8.1), iPhone 4 4.2.1
  • Yoyor94 Level 1 Level 1 (0 points)



    The issue occured again this afternoon (as usual).

    - Now, only Safari was concerned (this is mostly Safari being concerned by this issue : 90% of the occurences ...)

    - Everything came back to normal after closing (cmd-Q) and opening Safari again.


    VIDEO :

  • Yoyor94 Level 1 Level 1 (0 points)



    No One already faced this issue ?

    It's getting really anoying ... Exposé was working far more better !!!!

  • Yoyor94 Level 1 Level 1 (0 points)

    Help !!


    No one else has this issue ?!

    I'm getting crazy with this poor "Mission Control" ! 99% of the issue comes from Safari.

    I always have to close and re-open Safari !



  • bd297 Level 1 Level 1 (0 points)

    I'm having a mission control issue as well that may be the same... 

    When I do a 4 finger swip up on my touchpad, my safari windows goes to a tiny thin line.  I can see my other windows find, Finder, Mail, etc....  but the safari one all but dissapears except for a small line like a thread..  I cant choose this line to switch to safari so it is quite annoying

  • Yoyor94 Level 1 Level 1 (0 points)

    Yeah ! I'm not alone !!


    Question : if you close safari and then re-open it :it should fix (temporarily) the issue ? Correct ? If so, we have exactly the same issue.


    Sometimes, it affects some other applications, but -as you- Safari is 90% of the case the only app impacted.


    Still I never found any other solution than close/re-open.


    It's really annoying as this "mission control" becomes so useless with this issue !

  • bd297 Level 1 Level 1 (0 points)

    I'm not sure if that's a fix for me or not..but the next time it happens I will try...  Up till now it seemed to randomly occur and go away...

  • bispymusic Level 2 Level 2 (270 points)

    I believe that some of Mission Control's preferences are tied to your Dock settings. Try this and see if it fixes it:


    Open Finder.

    Press and hold the "Option" key and click on "Go" from the menu bar up top. Select "Library".

    From the Finder window, open your "Preferences" folder.

    Find a file called "". Rename it "".

    Restart your Mac.


    Does this fix your Mission Control issues?


    Also note that this will reset your Dock to it's original configuration. You may want to tweak the Dock back to your liking after this is done.

  • Yoyor94 Level 1 Level 1 (0 points)

    Thanks for the help.
    I Just tried : it does not fix the issue :-(


    I'm just wondering :

    - it looks like the issue comes once Safari is minimized before I shut the computer off : once restored (at next boot-up) Safari has the issue

    - it looks like the issue does not occur if Safari is closed or stays maximized before I shut-off.


    I will reconfirm above-mentionned hypothesis and let you know ...

  • Josh Passey Level 1 Level 1 (5 points)


    I'm sorry for such a late reply but this same problem happened to me today and I chanced upon this thread.

    As you said it is onl happening with Safari. I tried deleting the as well and restarting but that did not solve the problem so obviously its not tied to the dock preferences. Have any of you managed to find a workaround to this problem as this MacBook is pretty new and I'm getting very irritated with that horrible white line

  • Yoyor94 Level 1 Level 1 (0 points)

    Thanks for your feedback ... i'm feeling less isolated.

    I still have this issue without any workaround !


    This is really anoying as i'm (trying to) using "mission control" everytime ...

  • Josh Passey Level 1 Level 1 (5 points)

    Okay so I kinda found a workaround to it. Umm it had only started after I installed Windows 7 via Bootcamp and I think one of the drivers didnt install properly and then "something" happened

    I know this doesnt make any sense ^^^ but yeah i just reinstalled my drivers and the problems now permanently gone. I also deleted the yet again and this time before rebooting i switched off safari and cross checked it was closed by going into Apple Logo->Force Quit and then closing it from there and then rebooting. After that it worked properly and hasnt given me trouble since studying.

    So i dont know what sorted it out but something did and im happy

  • Josh Passey Level 1 Level 1 (5 points)

    Forget the earlier's started again! I'm getting seriously ****** with this bug now. I really hope Apple fixes it in the next update. Have a look at this! Now it's started doing it with other applications as well, not only Safari!


    Mission Control.png

  • Yoyor94 Level 1 Level 1 (0 points)

    Same for me ...

    Still have this bug.

    90% impacting Safari ... But might also impact other app as per your screenshot !


    This is really annoying as mission control get uncertain and it's unbelievable how this can impact our "productivity" on Mac with this random bug ...

  • Yoyor94 Level 1 Level 1 (0 points)

    still and still having this bug !!!


    I'm getting really disapointed as it looks like I'm not alone having this and absolutly NO feedback or proposal to solve it ...

Previous 1 2 Next