2 Replies Latest reply: Aug 24, 2012 9:45 AM by Sureshk0505
Sureshk0505 Level 1 Level 1 (0 points)

guys ...another Q...i am running G5 10.4.11 PPC, if i upgrade to Leopard ...can leopard run itunes 10, and then possibly connect to my ios 5.1.1 ? TQ 


Power Mac G5 (Late 2005), Mac OS X (10.4.11), Dual 2.0, 160GB, 1GBDDR2