3 Replies Latest reply: Nov 13, 2012 5:03 PM by Pat Gilmour
Pat Gilmour Level 2 (230 points)

I'm on Mountain lion 10.8.1 but 10.8.0 had same issue.


I use iCloud on my Mac, iPhone and iPad


The problem is: my Mial signatures disappear. I've seen this in other posts but no solutions worked for me (and they were generally pre-Mountain Lion).


What happens?


I create a Mail signature and add it to iCloud account in Mail through the Preference pane. It works.


I quit and relaunch Mail and it is gone.


I tried many steps to fix this:


- Kill Mail Preferences


- Delete ~/Library/Me/Mail/v2/Maildata/Signatures


- Delete ~/Library/Me/Mail/v2/Maildata/Signatures & Accounts.plist


- Delete ~/Library/Me/Mail/v2/Maildata


- Delete ~/Library/Me/Mail/v2/Maildata and recreate iCloud account



That didn't work so I looked in Console.



Multiple messages of librariand: unable to download file://path/path/etc.



The path was to the folder : /Users/pat/Library/Mobile%20Documents/com~apple~mail/Data/MailData/



So I did the above and deleted this folder and recreated the account. The folder is recreated by iCloud but still the signatures disappear.


I went to root/Library/Preferences/ and found a Mail pref there - killed it too.


No avail.


I'm pretty much at the end of what I know how to do with this. ANy suggestions?


I also disabled and re-enabled the account (as well as deleting it completely).





My hunch is because I have a long list of errors of the type [TIMESTAMP] librariand: unable to download file://path/path/etc.

It must be something to do with iCloud. But how do I reset this?


Any help would be really appreciated.