Skip navigation

iTunes match fails on upload, loops

9771 Views 37 Replies Latest reply: Apr 6, 2014 9:42 AM by Muffaletta RSS
  • JonD25 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2013 9:22 PM (in response to Geoff Fitch)

    Just thought I'd chime in and say I'm having the exact same issue. If I go to a coffee shop and use their wifi network, it uploads songs without any problems at all. If I come back home, the problem starts up again. I'm about to cancel my subscription and demand a refund if this doesn't get resolved soon.

  • rwthelen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2013 12:49 PM (in response to Geoff Fitch)

    I spent the past few days battling this exact problem and believe I have fixed it.

     

    I believe this actually is an ISP related issue (even if that sounds like BS at first). I do not have these problems when I use the internet at work, or use my personal hotspot on my phone, but I do have them on my home internet (Comcast).

     

    I believe that when iTunes Match begins uploading, it maxes out the uplink bandwidth of the Comcast connection, renders it useless and causes the connection to time out. iTunes Match thinks the connection died, and it stops, then restarts.

     

    The way I fixed it was limiting my maximum upload bandwidth via my router. My router (Netgeard WNDR3700) has a setting that allows me to set up maximum uplink bandwidth. Speedtest.net told me my connection had 4-5mbps up, so I limited it via my router to 2mbps.

     

    As soon as I did this, my uploads began working without timing out and restarting. They are slower than they could be, because I am limiting upload, but at least it isn't restarting!

  • JonD25 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2013 11:57 PM (in response to rwthelen)

    I can confirm what rwthelen said works. Someone suggested it in a thread I started on the same topic. Ever since I did that, I haven't had any issues whatsoever.

  • johnnyskyfox Calculating status...
    Currently Being Moderated
    Feb 11, 2013 6:25 PM (in response to Geoff Fitch)

    my problem also turned out to be the isp.  i have COMCAST.  no luck...  step 3 loop for about three days straight.  went to the in-law's place (much slower internet there), and step 3 uploads fine, just slow...  haha

  • coderc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 11, 2013 7:01 PM (in response to Geoff Fitch)

    If you've got a big data plan on your phone, I've found that works as well.  I connect my laptop to my iPhone's wifi hotspot and then run iTunes Match - with LTE the upload is even faster than my ISP.

  • Rawhouser Calculating status...
    Currently Being Moderated
    Mar 16, 2013 7:25 PM (in response to rwthelen)

    rwthelen is a genius - this worked perfectly for me.  I've been trying to solve this for months and was about to drop the match service as a result - even called apple and had them on the line for about an hour trying to figure it out to no avail.  They really need to get this info out there - I would imagine this would immediately fix the problem for most people (especially if Comcast is your ISP).

     

    Thanks - you just made my day.

  • Graham J Calculating status...
    Currently Being Moderated
    Mar 17, 2013 1:54 PM (in response to Rawhouser)

    Too late. I've waited a year for Apple to fix this or at least acknowledge the problem. Nada. My service expires today and I won't be renewing.

     

    I'm fine with syncing music to my iDevices manually, and in fact I prefer it anyway given that iOS provides next to no options for managing what remains on the device. Apple dropped the ball on this one.

  • KK4BCX Calculating status...
    Currently Being Moderated
    Jun 1, 2013 2:06 PM (in response to rwthelen)

    After months of utter frustration I saw rwthelen's post.  As soon as I turned on the VPN on my iMac (Hotspot Shield) everthing worked just like it's supposed to.  Not one singe restart. My provider is Timer Warner - RoadRunner. Thanks rwthelen!

  • flapinux Calculating status...
    Currently Being Moderated
    Jun 16, 2013 3:23 PM (in response to Geoff Fitch)

    I had this issue due to a song that was a 400mb lossless m4a file.  Deleted the song & it fixed the problem, converted the song to a mp3 (124mb) and all is well.  I'm pointing this out for 2 reasons. 

     

    First because I don't know if it was the bandwidth issue described by rwthelen or not but given others may not have a router with QoS features, it's an alternative work-around to try.

     

    Secondly, is there possibly a max song size for match?

  • Jimzgoldfinch Level 5 Level 5 (4,575 points)
    Currently Being Moderated
    Jun 17, 2013 12:00 AM (in response to flapinux)

    Hi,

    Max file size is 200mb.

     

    Jim

  • flapinux Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 17, 2013 8:36 AM (in response to Jimzgoldfinch)

    I did succeed with a 240mb file...  silly iTunes.

  • Greg Gallant Calculating status...
    Currently Being Moderated
    Jun 18, 2013 10:16 AM (in response to rwthelen)

    Thanks for this great tip.  I have been struggling for 4 days and both Applecare and Comcast could not offer any useful help.

     

    Your tip did the trick.  I set my bandwith to 256 Kbps and the upload went without a problem.

  • Noblehops Calculating status...
    Currently Being Moderated
    Aug 25, 2013 12:58 PM (in response to Geoff Fitch)

    If the cache deletion does not work for you, let me relay something that did work for me - and I was NOT the guy that figured it out. Reducing the upload speed from the problem computer was the trick - some folks do this in their routers with QOS settings, but I use a TimeCapsule and don't have that option. Download this free software:http://tools.chocoflop.com/entonnoir_en.html and then set the HTTPS port (443) to a maximum upload rate of 100 or so. Screenshot of my settings below. Some slightly quirky behavior in Entonnier though: You have to turn the throttling off to edit the settings, and once you enter a value into the text boxes below, you must hit <enter> or <return> on your keyboard for the settings to stick. Then turn throttling on with the button upper right, and watch iTunes. As I am sharing this solution my Mac is finally uploading the songs that have caused it to loop endlessly. It's quite possible that a higher setting would work but I only have 24 or so, so I'm not messing with it - it's working! Props to the guy that figured this out.

     

    P.S. You're going to want to then turn the throttling OFF when you finish, or things like Gmail and others that use HTTPS to upload are going to crawl.

     

    entonnoir_settings.jpg

  • dougadale Calculating status...
    Currently Being Moderated
    Sep 3, 2013 1:10 PM (in response to Noblehops)

    Thank you! I've been looking for a solution to this for a while and nothing worked until now!

  • hike the ball Calculating status...
    Currently Being Moderated
    Sep 24, 2013 6:47 AM (in response to Noblehops)

    iTunes Match was in an endless loop on my Mac also.  I followed the advice, downloaded Entonnoir, ran it as advised (throttling port 443--I used 128) and have finally had success.  Match went through steps 1 and 2 as before.  Step 3 has been running for 16 hours (yesterday afternoon, overnight, this morning) at this point and has pasted the point of failure.  It is "slow and steady".  Since other features of iTunes are available and the Mac can be used normally, I am letting it run to completion.

     

    Step 3 shows each file as its information is being uploaded.  This is neat to see and also caused me to rethink by "never throw anything away" practive.  (LOL!!!)

     

    Thanks for sharing your fix.  It surely looks like a solution to me.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.