1 2 Previous Next 27 Replies Latest reply: May 2, 2013 4:25 PM by bsandor
mart30lon Level 1 Level 1 (0 points)

Ever since upgrading to 10.8.1 server my windows clients now have issues copying to the share point on the server. "Network error, there is a problem accessing \\SERVER\WORK"

 

It's only with large file transfers 3GB and above. It also randomly shows the same warning when they are saving projects to the server occasionally and they have to manully reconnect.

 

Latest windows 7 64bit pro on all clients and latest mac os X on server.

 

The share point is an attached thunderbolt raid and has all permissions switched off, and is configured to RAID 0. This is backed up hourly by another drive.

 

Is there anyway of rolling back to lion? I no longer have a lion back up on my time machine.

 

Anyone else having these issues?

  • 1. Re: 10.8.1 Server and windows smb issues
    mart30lon Level 1 Level 1 (0 points)

    I have managed to answer my own question and no thanks to the useless AppleCare enterprise *****...

     

    You have to install this version of samba to fix the new poorly implemented apple version of smb:

    http://eduo.info/apps/smbup

     

    Apple have now officially abandoned pro users... Massive fail again!

  • 2. Re: 10.8.1 Server and windows smb issues
    Chris Marriott Level 1 Level 1 (80 points)

    Thanks for posting this.  We're supporting many SMB users, so this could be a big issue for us.  No question that Apple is abandoning pro users.  Mountain Lion Server is not fit for business.  We're not running it for any of our clients and frankly, it's scary to think that Apple is not interested in producing proper server software - let alone hardware.  How sad.  Seems like Apple is only interested in chasing the money with iOS.  The Mac has become a second class citizen.  Bitter disapointment.  The lack of new features, gutting of important existing features and lack of any advanced configuarion outside the terminal will haunt Apple one day soon.  Their lack of development, documentation and support for the Mac will force just about every pro user out over time.  Seems like this is what Apple wants because this pattern continues.

  • 3. Re: 10.8.1 Server and windows smb issues
    mart30lon Level 1 Level 1 (0 points)

    No problem I wouldn't want anyone else to waste their time expecting the pointless AppleCare enterprise team to help them... They actually left me with a broken server... And said I needed to pay extra for cross platform support!!! No mention that their smb doesn't work... If they didn't know it's incompetence and if they do know it's corporate fraud. Trying to juice me like an orange!

     

    I had been blaming the windows machines... Embarrassing to find out that it's mac os x that's now the elephant in the room now...

     

    We should all start a pro users group to perhaps offer the support thats so lacking now... Can't see them ever licensing mac os x to a pro computer manufacturer so we need to do something ourselves to take back some control!

  • 4. Re: 10.8.1 Server and windows smb issues
    exportgoldman Level 1 Level 1 (0 points)

    We have this problem too, both copying over 3GB Files from Server 2008 and Server 2012. We purchased a Mac Mini with a Promise Pegasus for our backup data from our Windows Servers.

     

    Don't we feel silly now! Should have stuck with a Pro product, instead of a $30 prosumer product.

  • 5. Re: 10.8.1 Server and windows smb issues
    itsamacthing Level 1 Level 1 (85 points)

    Apple's SMB implentation is weak and buggy.  I feel like I'm back in 10.3 trying to talk to Windows servers.  Those were horrible days. 

     

    To Fix.. go to your Mac and check to make sure that it has the correct WINS settings (network, advanced, WINS).  Your server has to be on the same workgroup (domain) as your windows clients.  For some reason, the setting does not stick on your Mac and that setting gets lost.  And that is the bug...

     

    To fix this (second part of your fix).. go ahead and turn off file sharing.  Then add your settings under WINS as stated above, then turn sharing back on and your networking from windows to mac will start to work fine. 

     

    Fun bugs... please call Apple about this, so they can follow up. My case number is 357016704

  • 6. Re: 10.8.1 Server and windows smb issues
    mart30lon Level 1 Level 1 (0 points)

    This problem has already been solved, please read the whole post!

     

    SMBUP 100% fixes all the SMB issues. This fix replaces Apple's samba with the open source version all other systems use.

     

    I wouldn't waste your time speaking to Apple, life is too short... Shame they have clearly decided to use their customers as beta testers now! They need another megalomaniac running them, someone who refuses to release anything until its perfect... I hold my breath everytime I install an update now... 10.7.5 just broke time machine...

  • 7. Re: 10.8.1 Server and windows smb issues
    itsamacthing Level 1 Level 1 (85 points)

    Hi, I did read it.  The work around you choose was something I also looked at, but it breaks the auto discovery going on in Finder.  This SMB situation is not really Apple's fault.  It was some sort of a licensing issue going back a few years ago while our brave leader was still alive. 

     

    Agree, OSX is buggier than ever in general. 

     

    I miss updates that did not require a reboot.  Being able to re-install and preserve all settings, and apps.  So many downgrades to the OS over the years.

  • 8. Re: 10.8.1 Server and windows smb issues
    chaoflux Level 1 Level 1 (10 points)

    i have this issue too on 10.8.2, just larger file transfers from windows to mac smb shares, only when writing to the smb shares, not reading....

     

     

     

    unfortunately SMBup isn't working OOTB at least for me, seems the server keeps crashing, spams my console log with org.samba.nmbd throttling respawn repeatedly

     

    i tried homebrewing samba and had similar results... it's all quite poorly documented so trouble shooting it is a PITA.... 

     

    really disappointing that i have to resort to this in the first place...

  • 9. Re: 10.8.1 Server and windows smb issues
    mart30lon Level 1 Level 1 (0 points)

    mac osx server app keeps crashing? or SMB?

  • 10. Re: 10.8.1 Server and windows smb issues
    chaoflux Level 1 Level 1 (10 points)

    the open source samba that SMBUp installs fails to start, when i try to use the SMBUp gui to start it just spams my console log repeatedly with error message.

     

    file sharing is turned off all together with the mountain lion server app &system preferences sharing just to make sure it wasn't interfering....  unfortunately logs aren't giving me any real clues as to why it won't start.

  • 11. Re: 10.8.1 Server and windows smb issues
    chaoflux Level 1 Level 1 (10 points)

    dude, it worked, i started getting curious and looked at the launchdaemons, they were pointing to smb.conf, so i went to the directory and noticed it wasn't there, adding my share through the gui wasn't creating it... there was however an smb.conf.sample so i renamed it to smb.conf and edited it manually and added what i wanted, after this it started up just fine....

     

    and the good news is now everything transfers beeautifully, have already moved about 100gb of large files w/ ease at 130MB/sec compared to apple's SMBX failing in a minute or so mid transfer.... huzzah!  goodbye SMBX apple garbage, hello real world

  • 12. Re: 10.8.1 Server and windows smb issues
    mart30lon Level 1 Level 1 (0 points)

    Nice one, I was about to say I could send you our config file. SMB has worked perfectly for us so hopefully you should be fine now... Although you've now joined the growing hoards of disgruntled Apple users!!!

  • 13. Re: 10.8.1 Server and windows smb issues
    chaoflux Level 1 Level 1 (10 points)

    ty, all seems well again... appears i'm disgrunted with everything anymore.. i have NFS set up on my macs, which works beautifully for various home theater and linux apparatus that I have....... but not Windows, the Windows Client for NFS (that comes with Windows 7 Ultimate) is painfully slow, 30MB/s tops (but to its credit is a stable functional product)...

     

    this is a big problem imo, i bought the '12 mini server to use as just that - and being stuck on Mountain Lion (i'd gladly take SL if I could), its functionality is quite crippled... but few seem to know or care.  blargh. /endrant

     

    thanks for the help though mate, cheers

  • 14. Re: 10.8.1 Server and windows smb issues
    Eduardo Gutierrez De O. Level 1 Level 1 (5 points)

    Hi.

     

    I'm confused. When you add shares SMBUp will tell you if smb.conf is not saved (and it should complain, since it was NOT saved). Were you having to add the shared drives every time you opened the app? The smb.conf file is not created by SMBUp until you save (which is independent of starting or stopping).

1 2 Previous Next