6 Replies Latest reply: Aug 26, 2012 12:20 PM by MiasJr
MiasJr Level 1 Level 1 (0 points)

Reposting from iMac community:


Hey, so I have a Mid-2011 iMac, 27'' high-end. I've got Windows 7 boot camped on 200 GB of the HDD, and for the past month it's been smooth sailing, switching between the two. Now today, for some reason, it decides not to boot.

Here's exactly what happed:

Played Minecraft for six hours in OS X, hosting a server

Closed down every program

Opened Settings > Startup Disk

Chose "Boot in Windows"

Computer shuts down, turns back on, and now it's stuck on the black screen right before it says "Starting Windows".

I've tried every combination of keys, also with a USB keyboard instead of the Bluetooth one, but I'm under the impression it's not even registering that the keyboard is there. All I can do it turn it off, then turn it back on. It makes the sound when it turns on, then cuts straight to black, no gray screen.

Any ideas on what to do here? Kinda need it to work for school.

iMac, OS X Mountain Lion, Mid-2011, 27''

iMac, OS X Mountain Lion, Mid-2011, 27''
  • The hatter Level 9 Level 9 (60,850 points)

    Microsoft Windows insalling an update.


    The first thing anyone should do, well first is to make a backup system restore image, so 2ND thing, boot from Windows DVD and rollback to last good boot point.


    Probably the same as the original iMac 27" black screen issue.

    But that is for install Windows not after.


    iMac displays a black screen during installation of Windows 7

  • MiasJr Level 1 Level 1 (0 points)

    The link doesn't help, literally the only screen I can get this iMac to make is black screen. No boot menu, no OS X. Just the startup noise, then black screen.

    As for the Win7 DVD, let's see if I can even get it into the thing.

    Update after the break.

  • MiasJr Level 1 Level 1 (0 points)

    Can't boot from the DVD. I can hear it making the reading-a-CD noises, but nothing happens. Screen's still black.

  • MiasJr Level 1 Level 1 (0 points)

    CD's stuck in it now. This just keeps getting better.

  • The hatter Level 9 Level 9 (60,850 points)

    Click and hold mouse down during startup to pause and open the optical drive door.

  • MiasJr Level 1 Level 1 (0 points)

    Still nothin', man. It's a two-button USB mouse that I use every day on both OSes, so it should work. I tried letting it run for a bit, then messing with the keyboard and mouse; neither are responsive. The keyboard won't show Num Lock as being on, the Apple keyboard won't activate either. The laser on the USB mouse is on, but holding either left or right click down does nothing when booting.

    There is no "startup" happening here, the screen is comletely off, makes the "your Mac is turning on" sound while the screen is off, then the screen turns on but is still black. None of the peripherals seems to be able to affect it, so I think I might just have to take it in as soon as I can, unless there's anything else you can think of?