13 Replies Latest reply: May 6, 2015 10:55 AM by Farst
ingrid.o Level 1 Level 1

I bought a new Mac BookPro 13 'Software Version 10.7.4. In the T-com I bought HUAWEI E353 wireless stick that says it supports MBP Software 10.7.4. I installed stick HUAWEI E353 MAC ga but does not want to load. Please Help ...

  • Fabio Pimenta Level 1 Level 1

    Same issue here Ingrid.


    I used to have a Huawei USB working on my older Macbook's Pro Mid 2010 and 2011 but at my new Macbook Retina 2012 it just doesn't work.


    Already tried several Drivers, Workarounds from here and there and the Unavailable / Disconnected Message always appears.


    I had to Plug Modem at a PC to copy the VIVO INTERNET.app (Provider here is called VIVO) cause at my Macbook it just doesn't Mount it.


    Apple : We urge a Response and Resolution for this Bug / Problem ASAP please.


    If anyone has a Solution PST


    E-mail : fabio_pimenta@yahoo.com.br

    Twitter : FabioPimentaBR

  • Nmarques Level 1 Level 1

    Hi guys, same problem here, after the 10.8.2 and the macbook pro retina efi update my huawei e586 was working through usb (as never before on my retina macbook pro). Surprisingly the next day, stopped working. Do not know what to do. I prefer to use usb than wi-fi.

  • cocoruiz Level 1 Level 1
    Mac OS X

    I have the same problem with my MBP retina OS X 10.8.2, It doesn't load my Huawei e353 stick. I've tried many different ways but still don't work, need help

  • Nora Dörr Level 1 Level 1

    Same problem. Huawei works properly via USB with Mac Bok Pro (early 2008) Mac OS X 10.5.8. But only Wi-Fi available on my new Mac Book Pro Retina (late 2012) Mac OS X 10.8.2.

    Don't want to open up a Wi-Fi and need to work via USB-Port.


    Any suggestions??? PLEASE!!!

  • LousyFool Level 4 Level 4

    From all your reports it looks as if the stick and/or its software (app and/or driver) is not compatible with Mountain Lion. Unfortunately, this is true for some other hardware and software as well. The only solution is to wait until the manufacturer updates its gear; eventually, some friendly "pushing" helps or at least produce a statement regarding when, if at all.



    Apple : We urge a Response and Resolution for this Bug / Problem ASAP please.



    Neither is it a bug in the OS, nor is Apple responsible for it. Again, please blame the 3rd-party manufacturer for it.


    Also, we here are not Apple but all users trying to help each other. Apple provides the forum, but don't expect them to respond here, they might not even read.

  • aira_25 Level 1 Level 1

    I've quitely got the same problem, but fortunately i've managed to solve it somehow:) I recently bought a macbook pro (mid2012) and got the same problem w/ the huawei e353. I've tried to inform about it and infact, someone told me that maybe this bug has something to do w/ the new usb 3.0 , which we know that's been installed into the recent models of mac. So this friend of mine suggested to use a usb2.0 hub, which can be bought by a low price, because it seems that this new usb 3.0 has some problem about "communicating" w/ the usb 2.0 of the huawei stick.. so he adviced me to use this hub, and luckily for now everything works fine:)

    hope it can be useful..

  • Antuloco Level 1 Level 1

    Aira... I live in South America and I am having the same problem. I think I know what to do after reading your post but I tried it and nothing. Maybe I do not have the proper usb2.0 hub. Is it one in particular?? Or is it because I see you use the windows operating system? (A pic of the hub would be nice...) Thanks.

  • SkilletZA Level 1 Level 1

    I can co firm that a USB2 hub solves the problem! Thanks for the advice!!

  • angelgarrasi Level 1 Level 1

    Dear Friends,


    In my case I have Macbook air and the usb 2.0 hub resolved the peoblem, the e353 modem is now discoerable by OSX lion.



  • iccsch Level 1 Level 1

    I've tryed the same way, using USB 2.0 HUB interface and it worked grate! Thanks for the support!

  • ramjo Level 1 Level 1

    I have a MacBook Pro retina from mid 2012. Mountain Lion OS X 10.8.3. Using a USB 2.0 hub solved the problem with connecting with a Huawei E353. Thank you for the tip.


    Apple please get your act together with some kind of software update. Looks a bit naff sticking an antiquated USB 2.0 hub, bought for 20 kroner, into a MacBook Pro costing 13.000 kroner!!

  • Farst Level 1 Level 1

    You have to add the modem manually. After install the modem and press connect:

    Enter System preference

    choose network

    press + to add connection

    choose the modem (huawei e...)

    choose advanced and insert the DNS data


    you will find them inside the huawei menu when open option.

    that's it

    It works for me with a new macbook pro 13,3 retina early 2015