Previous 1 2 3 Next 43 Replies Latest reply: May 9, 2015 8:02 AM by Kenneth Penkowski Go to original post
  • Joerg Daehn Level 1 Level 1 (0 points)

    And, what "pseabee" wrote seems to help/have helped in my case. But Apple needs to adress this problem soon!!

  • Joerg Daehn Level 1 Level 1 (0 points)

    And now It didn't wake up anymore. F*ck!

  • Run4Jesus Level 1 Level 1 (0 points)

    This didn't work for me. :-(


    Man. This is a really, really bad problem. One of the worst I have seen from Apple.

  • Barbara Passman3 Level 2 Level 2 (180 points)

    I am fussy, too

    i said an OnOFF switch WOULD be nice. (wishful thinking)

    Thought you meant manually pulling the electric cord but wnated to be certain



    well, I am workign with a second level apple tech person and problem May well be my display. (oy vey, I dread haviing to "shlep" the 30#  creature to an Apple Store.


    my issue is similar to what y'all describe. IF I put my MBP to SLEEP ( Apple command or simply close lid, clamshell style,most times when I reconnect my MBP to the monitor it does not waken and I cannot get my MBP(Retina) to wake up.Scary..Takes 10 or so minuts and many presses of power button on MBP and suddenly, bingo, my laptop wakes up - (laughing at me for worrying so much )

    Once awake,I can connect the Mac to the Tdisplay, put it to sleep and it wil awaken.

    I have  cleaned my prefs, reset the SMC,, set the MBP NOT TO waken for network calls(maybe that is wrong) and turned off Power Nap.

    So, with Apple now having my logs -console and system reports -  i hope we identify the miscreant.

    Will share here with  y'all.

  • Barbara Passman3 Level 2 Level 2 (180 points)

    Today my TB display started a new trick

    Sleep command, when Menu is assigned to the  TB, did not put the MBP to sleep

    But within minutes of trying  to use the sleep command, on its own the MBP suddenly went into deep sleep or did not wakeup

    Again, took a 15 minute wait before the Power button on MBP was effectve and re-started my MBP

    Sometning is really amiss- I hope that lag in the power button responding means something to the Apple folk I am working with= maybe provides a clue.


    Last night while using mt TB display hooked to my MBP, suddenly the "Mac is scheduled to sleep" dialogue came on and I could not get rid of it. Could not do any work around it

    Shut down my MBP

    IN AM the computer restarted and that dialogue was gone

    I quiickly went to sys pref,turned off the scheduled sleep ) and did a backup of my MBP - problems are getting more diverse and more frequent so I better be prepared


    Alll sorts of stuff related to sleepl

  • Joerg Daehn Level 1 Level 1 (0 points)

    Hi Barbara,


    try this, it worked until now: Open a finder window. Select Go to from the Menu and then Go to Folder. Enter Library/Preferences/SystemConfiguration" and when the new finder window opens delete "" and reboot. Then a new "" will be generated.




    J. Daehn

  • ed.line Level 1 Level 1 (10 points)

    Any fix to this problem yet?

  • Nepse Level 1 Level 1 (0 points)

    I have been away from my Thunderbolt display for some time, but I  decided that I would definitely try your suggestion about deleting the "" and reboot to have the system create a new plist when I came back. I returned yesterday, but unfortunately it did not fix the problem for me, the display still will not wake up when the harddrive is asleep. FYI I have the latest version (10.8.2) of Mt. Lion on my MBP. I totally agree with you that Apple needs to address this problem now, it is long overdue considering the fact that it is both widespread and has been a problem since this product was launched.

  • Joerg Daehn Level 1 Level 1 (0 points)

    Deleting "" didn't help for long.

  • dgreen99 Level 1 Level 1 (0 points)

    I've experienced the same problem.  After about 10 minutes of messing around with suggestions on this thread I was able to get the display to work, but the camera and usb hub continued to be non-functional. I disconnected and then plugged my mbp into another different Thunderbolt display, which worked perfectly.  When I plugged the mbp into the original Thunderbolt dislpay everything started to work properly again.  Not sure if this is a reliable workaround since the problem has only occurred once so far.

  • Rogo43 Level 1 Level 1 (0 points)

    I was having the same problem with my iMac 27" and my 27" Tbolt!!! I ended up having the power supply and logic board inside my Tbolt replaced. It worked great for a day and now..... It isnt waking up. I'm sending this POS back to apple and getting a different monitor I think.

  • ptys Level 1 Level 1 (0 points)

    Yeah this is definitely a software/firmware issue in my opinon. I've had it happen to me 3x now using an Mac Mini (Late 2012) with Thunderbotlt display. Have tried everything listed here more than once. PRAM, power managent.plist and full re-install which do work, but it keeps happening. My guess is that it's something to do with my original Time Machine transfer I did 2 months ago when I first purchased both units. The transfer upgraded me from Lion which was on my old system to Mountain Lion and there have been a number of performance issues like my screen freezing and application lingering which was apparent with my old system and has managed to bring itself over with the transfer.


    I'm no tech wiz but my guess it that there is a compatibilty issue with the Thunderbolt firmware on the OS. My Mac Mini runs fine through any TV over HDMI. As this is a new unit and I really love the display I hope Apple can provide a solution without me needing to replace it. I'm going to try Time Machine recover this time, will update any positive results.

  • Rogo43 Level 1 Level 1 (0 points)

    Yea the apple store replaced the power supply and logic board in the display with no luck and kept it for 3 weeks. I returned it and bought an ASUS monitor instead. 1/3 the price and much less of a hassle.

  • Amédée1 Level 1 Level 1 (0 points)

    I have the same problem!!! :/ Any solution?!

  • uaeute Level 1 Level 1 (0 points)

    PRAM reset did it. Thanks for the link!