Previous 1 2 Next 26 Replies Latest reply: Jul 5, 2013 5:46 PM by missive
jakie32 Level 1 (0 points)

Hi there,


Brand new retina MBP, running 10.8.1 (updated via the app store).


Tried accessing the App Store after the update and I'm consistently rewarded with the frustrating error message 'Cannot connect to the App Store. An internet connection is required'. My internet connection is working and I'm posting on the computer in question (The only perculiar thing is that Diablo isn't letting me sign in either - it was working earlier, I don't know if thats related)


I've been searching online for a solution for a few hours now and I've read almost every thread in this forum on the topic, to no avail.


I've turned my firewall off

I don't have an anti-virus

My 'Allow Applications' is set to Mac App Store and identified developers

I've deleted cache's and plists

I've reset my machine multiple times

I've reset my router

I've reset safari and its caches

Changed MTU size

I've changed the class 3 certificates to always trust

I've changed the class 3 certificates to system defaults

I've enabled debug mode and reset the App store


This whole situation is super frustrating for a brand new computer, I'm hoping someone can help me out.

MacBook Pro with Retina display, OS X Mountain Lion (10.8.1)
  • rrahimi Level 3 (615 points)

    Although not a guarantee, try this:


    Network Preferences -> Advanced -> DNS > DNS Servers


    Add these two entries:



    They are Google DNS servers.


    Remove everything else. Leave Domains as is.


    Try connecting to App Store. Maybe even restart and try.

  • jakie32 Level 1 (0 points)

    Hey that worked! Thanks!


    Do you know why would there be an issue with the DNS that I was using, and why would it let me browse the internet but not the App Store?

  • rrahimi Level 3 (615 points)



    DNS Servers do translation, think of them as Address Books.


    When you type in, your browser asks a DNS server for the IP address of Facebook. This way you won't have to remember every IP address.


    Chances are, your default DNS server is not updated and therefore has invalid IP addresses for the App Store and your game server, but correct ones for other things. It could be temporary but I suggest you keep using Google DNS servers. I've been using them for years on all my machines. They are fast and constantly updated.

  • jakie32 Level 1 (0 points)

    Thanks for your prompt support! Much appreciated

  • shines411 Level 1 (0 points)

    did not work for me, anything else?

  • rrahimi Level 3 (615 points)

    Are you in the US? Can you see this:



    If you can and click on "View in Mac App Store" does it opne App Store?

  • StJN Level 1 (0 points)

    I have the same issue.

    neither of the mentioned methodes worked for me, unfortunately


    No, I am not in the US


    the link worked perferctly for me

    the app store opens correctly

    but if I try to install the app nothing happens


    if I go to purchases it tells me that i need to sign in. When I click on sign in - again - nothing happens.


    Strange enough on my iPad all is fine.


    Many thanks for your help.

  • rrahimi Level 3 (615 points)

    The only other thing I can think of is to sign out, reboot, sign back in.


    If that didn't work, try a different network, not public, library or coffee shop type of Wifi as they frequently block iTunes, Netflex and the like.

  • shines411 Level 1 (0 points)

    I worked with Apple support for hours on everything under the sun (added DNS, checked for certificate errors, etc) and finally we had to do an erase of my HD and then a complete reinstall of my operating system OSX.  Only then were my issues resolved.

  • americandusk Level 1 (0 points)

    N/A. crashed again...

  • xdxaxsx Level 1 (0 points)

    I have this issue too. I can get on internet fine.All other aspects of Itunes store appear to be functioning but since upgrade to 10.8.2 (through the App Store in 10.6.8!!!!) I "can't connect to the App Store. an internet connection is

    required" HELP!!!

    Screen Shot 2012-10-05 at 4.07.44 PM.png

  • rrahimi Level 3 (615 points)

    Did you follow my instructions above?

  • xdxaxsx Level 1 (0 points)



    I've done everything except erase and clean install. I've sent a note to Apple so we'll see what happens there. Here's a list of what I e done already:





    Connected to App Store (via MacBook Air) running 10.6.8.

    Upgraded to 10.8.2 via App Store.

    I went to look for updates and I get the "can't connect,etc"


    So I restored back to 10.6.8 time machine backup...and verified I could connect.


    Tried to upgrade again: same result.


    All other wifi connections appear normal and App Store browsing is fine except in updates area.


    Steps I took to resolve:


    Through terminal...activated the debug menu--reset app, cleared cache


    Restarted --  no change


    Created admin test user account

    Verified that issue persists across users


    Accessed App Store updates loads normally using a different MacBook Air (connected to same network) running 10.8.2


    Repaired permissions on problem volume


    Verified that no firewall or parental controls are blocking anything

    Added alternate DNS entries -- no change




    I'm trying to avoid doing a clean install to obvious reasons. But sometimes that's what it takes.



  • WarrenOld Level 1 (0 points)

    Did you ever figure this out - I've got the same issue?


    Tried the DNS thing above - no difference.  I also connected to the Evernote page as rrahimi suggested - this works and opens in the App store.  The App store then works OK, I can click around on Purchases etc, until I click on the Featured tab. At this point the whole internet connection drops for about 5 mins - browsing, everything is affected.


    I actually have tried a full re-install (after a TM backup!) - it has made no difference - issue is the same on a clean install...

Previous 1 2 Next