9 Replies Latest reply: Sep 1, 2012 6:43 AM by xeqtv
xeqtv Level 1 Level 1 (10 points)

I changed the permissions on my hard drive from Everyone to No One.  I understand now that's a no-no.  Now I get the startup screen that's stuck at the apple and the sticks rotating in perpetuity.  I've tried everythign I could find, most unsuccessfully. 

Reset PRAM - fail

Reset SMC - fail

Boot in safe mode - didn't work.  I was going to try to boot from a clone on my external HD.

Boot as singel user and try CHMOD - fail

etc, etc


I'm working out of state and my recovery disk (whatever it's called) is back home.  Other than having my wife find it and sending it to me, is there a way download the disk and burn it to DVD and use that?  Do you think the geniuses at the apple store an hour away could help w/ that?  Do you have any other ideas?

MacBook Pro, Mac OS X (10.6.8)
  • Roger Wilmut1 Level 9 Level 9 (72,440 points)

    There is no way to download the disk. You could ring the Apple Store - if you quote the serial number of your Mac they should be able to supply you with a disk at a small charge, but you might just as well get your wife to FedEx it (or whatever).

  • Mark Jalbert Level 5 Level 5 (4,600 points)

    Boot as singel user and try CHMOD - fail

    In single user mode you are root, it should not fail. You did something wrong. Follow these directions:

    Boot into single user mode - http://support.apple.com/kb/HT1492

    Once you are at the prompt then:


    /sbin/fsck -fy /

    If the filesystem is clean then:


    mount -uw /

    Remore the ACL entry from the boot disk:


    chmod -N /

    And finally:



    If this does not fix the issue then a trip to the Apple Store would be a good idea.

  • xeqtv Level 1 Level 1 (10 points)


    Tried your method and still didn't work. It didn't like /sbin/fsck -fy /. When I tried it without the last dash, it ran checks and said ** The volume Macintosh HD appears to be ok. I followed the rest of your instructions and was met with the same start up screen.


    A lot of things just don't work: CMND-R, CMND -C,  any type of chmod... This is horrible with something I need done asap and a hurricane coming up.

  • roam Level 6 Level 6 (13,560 points)

    Start in Single user mode again like before, but use these commands,

    Note: there must be a space between the / and that which precedes it. The font I used is intended to show this.


    mount -uw /


    chmod 1775 /



  • xeqtv Level 1 Level 1 (10 points)

    Thanks, Roam.

    That did the trick after I screwed something up to where I got the startup screen w/ the verbiage in 5 languages.. I put in the install disk to repair permissions. 

    Now I have a new problem.  My MBP is now reset to original settings; but my HD still has stuff like the new CD I recently purchased before this fiasco.

    What do I do now?

  • roam Level 6 Level 6 (13,560 points)

    I'm glad you can access your disk again.


    "but my HD still has stuff like the new CD I recently purchased before this fiasco."

    "What do I do now?"

    I don't understand what you mean here.


    Message was edited by: roam

  • xeqtv Level 1 Level 1 (10 points)

    When I logged in it looked like it did when I first bought it. Nothing on desktop, the dock is totally changed and the aliases are dead...iTunes, superduper and other apps will not open from the dock. I see there are files I recently added are still on the hard drive so I know it's not a total wash. I hope.

    Even though I'm logged in and I'm the admin I had to change permissions to even access the /user folder and everything therein.

    My last back up was in June so I copied everything from my /user folder on my clone to the mbp. My dock is reset and items are back on my desktop but my settings are still off and apps still don't open. I can't even open Firefox or safari. I booted from my external only to see what appears the Mac in dual screen mode with my screen not the active one. Just came from Walmart and bought a video to hdmi cable but I only see a blue screen in the tv.    

    What do I do?

    The Mac store is closed due to power outage from Isaac.

  • xeqtv Level 1 Level 1 (10 points)

    Sheesh and now I'm seeing the screen saver.

  • xeqtv Level 1 Level 1 (10 points)

    And I tried to restore the HD, which I realize would have erased everything since June, but got this message: Not enough space on /dev/disk0s2 to restore