9 Replies Latest reply: Nov 16, 2012 6:40 AM by Barry Shortt
Barry Shortt Level 1 (15 points)

I've just bought a new MacBook Pro Retina running Mac OS 10.8.1 and installed iWork 09. There are problems with all three bundled applications.

 

Keynote

 

Opening Keynote results in two-to-three diaglogue boxes with the following error message:

 

"An unexpected error has occurred. Please quit and reopen Keynote."

 

Once I've clicked through the file display opens but when I try to open a file, it unexpectedly quits and suggests sending a report to Apple.

 

I've tried to address this by following advice in other threads, namely:

 

  1. Updated to latest version of iWork supporting the MacBook Retina
  2. Restarted laptop
  3. Deleted, re-installed iWork and repeated steps 1 and 2 above
  4. Located and deleted keynote.plist file, then restarted Keynote

 

Pages and Numbers

 

No diglogue boxes on opening, but startup is very slow (on the order of a minute). The file viewer opens and when I select a file, or a new document, the viewer disappears but the file fails to open. If I click on the Pages icon, for example, the file viewer re-opens.

 

Any help would be appreciated.


MacBook Pro with Retina display, OS X Mountain Lion (10.8.1)
  • chris2x Level 1 (20 points)

    I have had the same experience.

  • Barry Shortt Level 1 (15 points)

    Hi Chris,

     

    I don't suppose you ever figured out the solution to our iWork problems?

     

    I'm still stumped by it and thought the recent update would solve it (it didn't)

  • PicoTrain Level 1 (0 points)

    Same here. The recent update did not to dissipate the error screen.

  • Rich Cohen Level 1 (10 points)

    I had the same problem.  I just finished talking to Apple Support and they helped me fix it.  First we tried removing Keynote from the Applications folder and reinstalling iWork 09 from my original CD.  That didn't work.  The second time we removed the iWork 09 folder from the start-up disk:Libarary:Application Support folder in addition to removing Keynote from the Applications folder.  Then I did another reinstall and it fixed the problem.  The support guy told me that in some situations you might need to remove a folder from the user:Library:Application Support folder as well, but, in my case, there was nothing to remove from that folder.  Hope this helps.

     

    Rich

  • VIP Mac Services Level 1 (0 points)

    Hi Rich,

     

    could you explain me again, how the second time resolved the problem for you removing iWork folder from Application Support Folder if in the end of your explanation you said that in your case you didnt have anything to remove from that folder?

     

    I am having the same problem opening the Keynote and I just re-installed iWork '09 and I don't have iWork Folder in Application Support Folder. Any Help?

     

    Thank you,

     

    Ricardo

  • Rich Cohen Level 1 (10 points)

    Sorry for the confusion.

     

    There are multiple Libraries on every Mac.  One is in the root of the boot drive.  Others are in each user's folder.

     

    The first time we removed Keynote from Applications and looked in my user:Library:Application Support folder.  We didn't find anything to remove, so we did a reinstall and it didn't work. 

     

    Then the support guy rememberd that we also needed to check the Library:Application Support folder on the boot drive itself.  We did this and found and removed the iWork 09 folder.  Then we removed Keynote from Applications for the second time.  Finally we reinstalled Keynote from the disk.  This time it worked and I allowed Keynote to load an updated version.  Everything is OK on my Mac Pro now.

     

    By the way, I also have a MacBook Pro with 10.7.3 installed and I have had no problem with Keynote on that machine.

     

    Hope this helps.

     

    Rich

  • VIP Mac Services Level 1 (0 points)

    Hi Rich,

     

    thank you for your help. Now, all apps from iWork'09 works but some files from pages open others don't.

     

    Any idea? Remember that I just upgraded my HD and had to reinstall Mount Lion using external HD and restoring from Time Machine.

     

    Thank you.

     

    Ricardo

  • Rich Cohen Level 1 (10 points)

    Ricardo,

     

    If you purchased Mountain Lion in the past 3 months, I believe you get free support from Apple.  Try contacting them and asking for help.  There are a lot of different reasons why a file won't open each with different solutions.  I don't use Pages so I don't think I can be of much help.  On the other hand, try using Get Info on the files that don't open to see what the default application is.

     

    Rich

  • Barry Shortt Level 1 (15 points)

    Hi Rich,

     

    Great, thanks for this, it has solved all the problems I listed in the original post. I too was confused about the different libraries but once I found the root library, it was straightforward.

     

    Many thanks,

     

    Barry