4 Replies Latest reply: Aug 28, 2012 8:49 PM by jrnavid
cdv2007 Level 1 Level 1 (0 points)

iPhone 4 finds network, connects to router  but cannot access internet.



My old iPod touch does not have this problem.

  • paulcb Level 6 Level 6 (19,100 points)

    Try power cycling your router.

  • Soccerhick Level 1 Level 1 (0 points)

    Turn off router and turn off iphone and turn back on

  • whatheck Level 5 Level 5 (4,080 points)

    This Apple doc might help ya out -> iOS: Troubleshooting Wi-Fi networks and connections


    If you are unable to access the Internet while connected to a Wi-Fi network


    • If you are using a public or commercial network that requires a login or subscription, see this article for more information.
    • Verify that you are selecting the correct network if you are in a location with multiple Wi-Fi networks.
    • Verify that the Wi-Fi network settings are correct. You can view and configure Wi-Fi settings using the following steps:
      • Tap Settings > Wi-Fi.
      • Locate the Wi-Fi network you are currently using and tap The right arrow button.
    • If you've verified that your settings are correct and the issue persists, try the following:
      • Tap "Forget this Network" to reset settings for this Wi-Fi network, including the password. Then try connecting to the network again.
        Note: This can be useful if you identify a network issue and want to prevent the device from automatically using this network in the future.
      • Reset network settings by tapping Settings > General > Reset > Reset Network Settings. Note: This will reset all network settings, including passwords, VPN, and APN settings.

    Note: If the Wi-Fi network uses MAC address filtering, you will need to add the MAC address to the access list for the Wi-Fi router. The MAC address for your device is listed as the Wi-Fi address in Settings > General > About.


  • jrnavid Level 1 Level 1 (10 points)

    My phone is doing the same thing! For about 5 days now I cant access the interent on any wifi network and I also already reset network settings. It accesses for about 20 seconds and then stops and wont load anything.