Previous 1 2 Next 27 Replies Latest reply: Mar 24, 2015 11:43 AM by Csound1 Go to original post
  • travis27 Level 1 Level 1 (0 points)

    It's just the same for me.....icloud mail was working until today...i changed nothing.

    icloud mail works on my ipad and iphone and macbook, it's just my mac pro (runing 10.7.5 because it can't be upgraded to 10.8) which can't get icloud mail.

     

    I tried deleting the account in mail

    i tried deleting icloud off my mac altogether

     

    when i set up icloud on the mac again it also creates the icloud email account, but it doesn't put the incoming server or password in...and the incoming server is greyed out.

     

    I'm stuck

     

    Any ideas please?

     

    Thanks

     

    John

  • travis27 Level 1 Level 1 (0 points)

    and now i've just created another icloud mail account, this time i did it manually and filled in the server name and everything....then suddently the server field is greyed out and the password has gone!

     

     

  • travis27 Level 1 Level 1 (0 points)

    Finally trashed mail prefs and it's all fine. 

  • Csound1 Level 8 Level 8 (40,565 points)

    jazzfan_1 wrote:

     

    That's what I tried several times ... Unfortunaltely, my appleID adresse ends with @gmail.com ... So entering this adress, gives after hitting continue an error, this as he is trying to connect to the gmail imap server

    @Gmail is not an iCloud address, it may be used as an iCloud ID but the mail will still be handled by Gmail. Enter the GMail account at Mail, Contacts and Calendars (in System Preferences) and it will appear in Mail, it will not appear on iCloud.

  • Megs1331 Level 1 Level 1 (0 points)

    Travis- I am having the same problem...the incoming server field is greyed out and it won't let me type anything in. I am a Mac newbie so if you could give me detailed steps as to how you fixed this that would be super helpful! Thanks!

     

    Meghan

  • ChickenClogs Level 1 Level 1 (0 points)

    In my particular case, simply de-selecting the 'Mail & Notes' option in SystemPreferences->iCloud (leaving the account itself with Contacts and Calendars untouched) then going back and turning it back on did the trick.

     

    Apparently much the same issue as OP and others here: unable to connect to iCloud account in Mail 5.3 and unable to populate 'Incoming Mail Server' field, did note that authentication was set to Apple Token (and still is).

     

    So far just the one OS X 10.7.5 desktop has been the problem; iOS devices seem OK and I've yet to check the second desktop. No idea when it happened, hadn't used the machine in question for a few days.

  • brucefromqueenstown Level 1 Level 1 (0 points)

    For me none of the above has worked.

     

    I am trying to turn off "Show notes in inbox" When I try to save the setting I can't get past

     

    "Invalid Incoming Mail Server

    The “Incoming Mail Server” field cannot be empty."

     

    Any help appreciated.

  • g5q_si Level 1 Level 1 (0 points)

    I have similar problem... I have two icloud accounts, the second one will not let me edit the Mailbox behaviors i get the same

     

    "Invalid Incoming Mail Server

    The “Incoming Mail Server” field cannot be empty."

     

    and I cannot save the changes.... HELP

  • Tamarajean Level 1 Level 1 (0 points)

    Hi -this is the fix for those who have migrated from @mac to @me to @icloud...

     

    In my frustration I asked John (carcynic.com) who I work with and he told me to go to applications/terminal.  When the terminal window pops up type cd /Library/Preferences and look for the mail preference and copy it. (don't delete all preferences)  Then type rm (paste your mail preference file name here)

     

    you should have configured the icloud settings and it will start to download mail immediately.

  • Donald Betts Level 1 Level 1 (0 points)

    I am having the same problem.  I can not fill in the "Incoming Mail Server" for my iCloud account in the Mail accounts settings. 

    Just yesterday I installed a clean version of Yosemite and restored my stuff.  So I am working with a "clean" system. 

    Finally got it all restored last night and I did get iCloud mail to my laptop Mail.  But this morning .... nothing.

    I have an iPad and and an iPhone.  iCloud Mail is on both devices and working fine.  I can go to iCloud via my browser and get mail all fine.

     

    But now I can not even modify my iCloud preferences in System preferences?   Does this have to do with .mac versus .me versus .icloud?

     

    This really *****...

  • Csound1 Level 8 Level 8 (40,565 points)

    System Preferences>iCloud:

     

    Turn Mail off, restart the Mac, turn it back on.

  • Donald Betts Level 1 Level 1 (0 points)

    Thanks... yeah I finally did that.  Duh.  reboot. 

  • Csound1 Level 8 Level 8 (40,565 points)

     

Previous 1 2 Next