Previous 1 2 Next 18 Replies Latest reply: Aug 31, 2012 3:03 AM by peerst
peerst Level 1 (0 points)

My Retina Macbook Pro came with 10.8.0 preinstalled, I also have a normal boxed version of iWork '09 brought over from my old computer.


When the 10.8.1 Update was out I got the Notification box that there would be a new software to install, with the buttons "Details" and "Reboot".

I was curious so I clicked "Details" which brought me to the "Updates" pane of the Mac App Store App.


But here it said there would be no updates.


Since then there were no Updates shown there.


I was able to accept the preinstalled iLife Apps and also buy new Apps.  So the connection to the Mac App Store seems to work.


What doesn't work in addition is upgrading the bought as box iWork '09 apps.


Neither the preinstalled Mountain Lion nor iWork appears in the "Purchased" tab.


Apple Support told me to boot in Safe Mode (holding shift) but unfortunately Safe Mode hangs and doesn't boot.


I tried cleaning up a bit and removed old Startup Items and Lauchd stuff.


There was an article on the net that linked a corrupt Spotlight index to a similar failure so I tried and forced Spotlight to rebuild the index -> noch change in the behaviour.


How can I debug this situation further?  Is there any way to make Mac App Store output some diagnostic info to find the problem?


Is it known how the Mac App Store detects that there is a eligible Mountain Lion on the disk?  Any Ideas?


I'm very comfortable at the shell level, solutions using the commandline are welcome.

MacBook Pro with Retina display, OS X Mountain Lion (10.8)
Previous 1 2 Next