7 Replies Latest reply: Sep 10, 2012 2:21 PM by Erich Wetzel
Erich Wetzel Level 2 Level 2

Trying to set up a shared Library/Fonts folder.  Folder is the exact same one that was a shared Library in our Lion installation.


Set up as share with guest access, everyone can read, share as userhome via AFP.


Our Lion clients do not seem to automount the Library and as a result the fonts are not being picked up in applications that need them.


Any ideas?

OS X Server
  • Erich Wetzel Level 2 Level 2

    Has anyone else tried to set up a shared library?


    Our workaround was to install all fonts and other shared library items on each client.  I would prefer to get back to the centralized method if possible.

  • Mark23 Level 3 Level 3

    Why can't you get back to the centralized method like you did before?

  • Erich Wetzel Level 2 Level 2


    Thanks for looking at this.  I have a shared Library in the exact same location, mountable for userhomes in AFS (I assume that this is the selection for automount now), and permissions as with our Lion Server.  Under Lion the clients were able to show and use the fonts in the shared Library/Fonts folder.  I created the 10.8 server from scratch.  No changes in the Lion client machines other than to bind to the 10.8 OD.


    Our FileMaker database uses fonts that we kept in the shared Library.  On changing to the 10.8 server the fonts were not picked up automatically.


    One of the issues that I cannot go backwards and confirm without a lot of work is the actual location of the Library from the standpoint of the clients.  Right now it is at /Network/Servers/server.FQDN.com/Volumes/Data/Library/Fonts.  It is the exact same data drive as was used in 10.7 the only change is the server OS.


    Any suggestions would be great.


    An odd thing I have found is that there are two selections for this share Data/Library and Data-1/Library.  I assume that this may be an artifact from a mount problem that came up where the mount point for our Data drive reset to a Data-1 mount point.  I am not sure why the clients are mounting the shared files twice.



  • Mark23 Level 3 Level 3

    Can you ping the server on TCP port 548 from a client? If not, check port forwarding on routers and check if File Sharing was actually turned on in the Server app (green light next to file sharing).


    Double click the share to confirm once again that the Share with Mac cliens (AFP) checkbox was indeed checked and that all users and groups which had access to the share have access once more...


    Finish your inspection by checking whether all intended users or groups have File Sharing checked by right-clicking on the user or group and selecting Edit Access to Services... in the drop down menu.

  • Erich Wetzel Level 2 Level 2


    I like all of the ideas but everything is in order.  I have turned everything on and off many times.  Let me clarify one thing, in the past this particular share was not mounted by the users, it was automounted in the same fashion as Userhomes and did not appear on the desktop.  I can mount this share for the users manually but I do not want it to be a login item or something that shows on the desktop.


    In the past this setup showed guest logins from each client as soon as they were turned on.  I no longer have the guest login.  I imagine that there is a connection between the two.  There used to be a "Turn on AFP guest sharing" that was a general item for the AFP server itself.  Unless I am missing something, that no longer exists. 


    I am looking to solve the problem addressed here : https://discussions.apple.com/message/3450217#3450217 with today's server software.

  • Mark23 Level 3 Level 3

    You can tell the share to be open to guests by making sure the Allow guest users to access this share is checked.

  • Erich Wetzel Level 2 Level 2


    As I mentioned in the first post, it is indeed set up this way. 


    Guests can open this share manually without credentials.  All settings for AFP and this share duplicate exactly what was used in Lion and set up originally in Snow Leopard as in the link above.