10 Replies Latest reply: Aug 30, 2012 11:05 PM by maaribou
maaribou Level 1 (0 points)

the adapter shows a green light when plugged in and the side indicators show charging. when i press the power button, the mac starts i hear the hardrive but as soon as the white screen appears the macbook shuts down.




The Macbook just turned on. dont know why. but its on. everythings working. the batteries. the power plug. the wifi. sound. graphics. HDD. everythings working EXCEPT the mouse pad and the keyboard. when i attach an external mouse and keyboard, they work fine.

MacBook Pro, Mac OS X (10.7.2)
  • Brett@Userland Level 2 (155 points)

    Try reseting the PRam ( restart, on startup Hold down option, command, the leter P and the leter R. keep holding them down until you hear the start up chime for the 3rd time then you can let go)

  • maaribou Level 1 (0 points)

    hey. thanks for the quick reply. one question. would the mac restart again? cos i think if i restart it now, it might never turn on again. but im backing up my files right now. and will reset Pram as soon as i get done with the backup. hopefully it woould help.


    Also, im typing right now using the same macbook but with an external keyboard. does this mean the logic board is not fried and all hardware is working 100 % ? is this just a software issue. cos if its not, i dont know how the macbook is even working right now. charging and discharging normally. reply =)

  • Brett@Userland Level 2 (155 points)

    I Like your thinking to do a backup whilst you still can, whilst its not completely necessarry as All your data is stored on The Hard drive which should be fine even if your machine was to never boot again it is definetly better to be safe then sorry. While the machine still works with another keyboard and mouse it dosent necessaraly rule out your Logic board, though my first impression is (considering both the keyboard and trackpad are not working) it sounds more like it could be just a minor power issue in which case reseting the PRAM and SMC (Shut down simultaneously press the control, option, shift and power button (willing it is a unibody macbook pro). You should notice the light on the magsafe change colour.) Should fix the issue.

  • maaribou Level 1 (0 points)

    so i ended up restarting the mac.and did the smc reset. and it turned on again. works fine but keypad and mouse still not working. still charging and discharging fine. do you think checking the batteries by taking them out and taking a look at the connectors for the kb and mousepad would make any difference؟

  • Brett@Userland Level 2 (155 points)

    Is the macbook pro a unibody or can you see tha battery on the bottom? if you can see the battery take the battery out and see if it is swollen at all and try booting with the battery not connected (just the power adapter)


    To try and determine whether or not it is software or hardware, you could:

    1. Run Software update, install any updates ( I noticed your profile says you are running 10.7.2, OS is currently up to 10.7.4)


    2. Restart into Safe Boot- Hold down Shift Key upon start up until apple logo appears with a progress line. Does problem persist?


    3- Create a new user - System Preferences/Users &Groups/ click the + (you may need to unlock the padlock).

    - Log out of your user and log into the new user. Does Problem still persist?


    4.Boot into recovery Partition - Restart mac, upon startup Hold down Command + R Until the apple logo appears.

    Does problem persist in Recovery.


    If The Keyboard and trackpad Work in any of the above, Boot into Recovery Partition and reinstall OS.

  • maaribou Level 1 (0 points)

    hey. so i have done all the steps you have mentioned above. the macbook is a unibody. i updated the os and im currently downloading more updates that the mac has recommended for me. small updates for airport and some EFI firmware. safe boot did not work nor did the boot into recovery. but the keypad backlight is working now. mousepad and keypad still not working. i dont know what the problem is. shud i open the case and look for the conncetions of the keypad and mouse. i thnk these can be found under the battery.


    should i just reinstall the OS. maybe that could work. at this point i thnk the problem is hardware relatred. maybe the logic circuits for the keypad mouse are fried.


    EVERYTHING else still working fine.

  • Brett@Userland Level 2 (155 points)

    If the machine is under warranty ( you can check here ) I would definetly not open the machine as you could end up voiding the Warranty.


    Has the machine come in any contact with  liquid by any chance?


    If you have followed all the steps i have mentioned Then I agree that it is starting to sound like it is Hardware related, In which case i Think it might be worth while taking a visit to an AASP (Apple Authorised Service Provider), though it wont hurt to reset the PRAM again and reinstall the OS.

    If It is out of warranty and you realy want to open it up yourself then the Keyboard flex is the wide flex to the left (if your looking at it) of the RAM, there is a Fine locking leaver on the oposite side of the connector to where the flex enters, that you will need to flip up. you could try giving the flex a light clean (maybe just use a pensil eraser). Once again I would strongly suggest you take the Machine to an AASP though as its likely you dont have the apropriate enviroment to open the machine without the risk of causing more damage .


    Just out of curiosity when you reset SMC, PRAM, Boot into SafeBoot & Recovery, Were you able to use the built in keyboard to input the commands (eg P, R, Option, Command) or did you have to use the external?

  • maaribou Level 1 (0 points)

    Hey man. And YESS. I have been using the built in keyboard keys ever since i started going for the boot restart disk manager an safe boot. Even used them when resetting the SMC. If the keys are working than. Does it mean its a software issue?? Im not opening up the macbook on my own for now. I also found out that the console in the application utilities inside the OS is showing the applemultitouch device error for the past 2 days. I can post a screenshot for it if u want. 

  • Brett@Userland Level 2 (155 points)

    mmm maybe a Firmware issue?

    Also try

    Check System preferences/accessability -Keyboard- make sure sticky keys is not checked & Mouse & Trackpad - make sure "ignore built in trackpad when mouse or wireless trackpad is present" is not checked.

    Unfortunatly I Wont have any computer/internet access untill monday so If that doesnt work it might be worth while Taking to an AASP.

  • maaribou Level 1 (0 points)

    yup. maybe a firmware issue. i cant find the sticky keys or the other option you have stated above. anyways thanks for your help. i think i may have to get the macbook checked and get the keyboard mousepad control board fixed or replaced. have my fingers crossed.


    lemme know on monday if you think up of anything else