4 Replies Latest reply: Nov 18, 2012 5:39 PM by darboisit
thorsten_marketing Level 1 (0 points)

iTunes gives this really strange error from time to time " This movie requires QuickTime, which is not supported by this version of iTunes"


When a) I have the most up to date version of iTunes, Mac O/S, QuickTime, etc... and b) I already rented and watched several movies just fine.

Screen Shot 2012-08-29 at 13.22.23 PM.png


To to volume I moved the iTunes database to my TimeMachine and connect via wireless.

Sometimes it requires to first find and select the Data folder on the time machine because iTunes otherwise adds a new data folder locally.

This is the only potential problem that I can see, but it has always worked fine. Just from time to time I get this annoying quick time error when renting movies.


Please help.

MacBook Pro, Mac OS X (10.7)
  • b noir Level 9 (72,050 points)

    Try relaunching iTunes in 32-bit mode first, as per the instructions in the following document:


    iTunes for Mac: Older media files may require iTunes to reopen in 32-bit mode

  • Gregory Thomas1 Level 1 (10 points)

    My case is the same as above. Except, in my case the file was last week's new Doctor Who episode one. So I assume, it's a newer file. Any ideas?

  • thorsten_marketing Level 1 (0 points)

    Hello ,


    I found out some answers in the mean time.


    1) Cause of isse. It has to do with the WiFi transfer to the TimeCapsule or another NAS drive.
    In the TimeCapsule issue it is caused to not proper mounting. For NAS drive - not idea.


    2) Solution.


    a) Some say open iTunes in 32 bit (I think you right click iTunes and select open in 32 or so - google how to) , start watching the video and then pause, close and open in 64 bit and resume the video. It causes the file to be properly re-written/ recognized.


    b) Another tip is that you (THIS DOES NOT WORK WITH RENTALS) select the file. Delete from iTunes Library BUT NOT THE FILE. It usually asks you if you want to just kick it out of library or also delete the file. Make sure you do not delete the file. I suggest to find the file via FINDER and make a back up copy just to be save. After you deleted it from the library you select and re-import your file to iTunes again. Then it re-writes the connection and it can be found and played without any problem. This is what I recommend.


    c) I first find my TimeCapsule via Finder. Open a file that I have on DATA . Then I open iTunes. Check in Preferences under last tap that the Library location is .../data and not .../data-1 or my computer . I play a song in iTunes that I know is stored on the TimeCapsule. And only then I connect to iTunes store and buy a movie.

    It basically makes sure that the TimeCapsule is mounted properly.


    d) A last tip is to change the location of your library via preferences to your computer before renting movies.

    It also solves the issue but it opens another issue of keeping your library organized, you have to unselect copy files to avoid more filed being moved to your computer like automatic updated podcasts etc... I find that less desirable than doing the work in c)


    3) Conclusion


    If you want it to work perfect. Do d) . If you want to keep things as they are, do c). If you have the problem with your own files you can do b) . If you have that problem with a RENTAL MOVIE you can only try to do a) and in the future c) or d).


    4) Apple needs to fix this problem

    I also suggest you let Apple know that they have a systematic and rather annoying bug. Given the high price point for a TimeCapsule compared to other storage and router solutions, I expect flawless interconnectivity when paying such a price premium. The fact that TimeCapsule does not mount properly is absolute unacceptable and a basic issue. Afterall, that is the purpose of it to tranfer all heavy files such as movies, iTunes libraries, iPhoto libraries or third party audio / visual software.


    PS: Just thought of another solution. Take your laptop turn off WIFI and plug it into TimeCapsule with a LAN cable. Check the mounting and then you have a stable , secure mount that should not cause any problems. For the download duration you have to physically stay there, but your file still downloads to TimeCapsule, no need to do all the checks and after it is finished it can still be streamed (don't forget to turn on WiFi after you unplug the LAN cable). Give that a try and report back.

  • darboisit Level 1 (10 points)

    Hey! Just watched a rented movie with your help! Thanks a lot guys!

    And thorsten_marketing, you write really well!