Previous 1 2 3 4 Next 161 Replies Latest reply: Dec 10, 2014 1:04 PM by gd0 Go to original post
  • douglasehowell Level 1 Level 1

    I have experienced the same things......  A brand new MacBook Air 13".  I have two external USB hard drives.  One is for all my iTunes stuff and one is for Time Machine.  Both seem to eject randomly and causes the disks to disappear.  I have to either power cycle the drives, or some times I have to turn the drives off then reboot then power them back up.  I tried the "Caffeinate" terminal command (making sure to leave the terminal program running) and the same thing happens.  The first computer I had was a Mac Centris 610.  When I got my first real job, I got a Windows computer because everything at work was Windows based.  Recently my Windows machine died, so I decided to get a Mac again.  I'm not super happy so far.....

  • kiloran Level 1 Level 1

    Similar issues here. I have a number of external drives I use for offsite backups - 2 1TB WD Elements (2010) and a brand new 1TB Seagate Backup Plus drive.


    I'm finding that even though ML reports them as ejected often when I swap them to my Lion MBP they won't mount and need a repair using DiskUtility. Have also had a situation where they won't be detected by my Lion MacMini server. Shutting down the MBA running ML prior to ejecting seems to be the best option.


    I don't get the issue bringing the drives from my Lion MBP & server to the MBA though.


    And also the Lion server recently reported it couldn't mount or repair one of the drives. Thought it was going to be a reformat job but when I plugged it in to my MBA to do that it mounted fine and Disk Utility First Aid reported no errors.


    Going to try the switching off HD sleep and PowerNap in Energy Saver preferences and will report back.

  • imgathawa Level 1 Level 1

    Same problems here.


    Any USB memory device (whether flash drive, card reader, ext HD) will eventually get spit out by my Mac if plugged in long enough. (And the definition of "long enough" seems to vary greatly depending on the device. Some things get spit out quickly, other things take hours.) Then my Mac will chastize me, telling me I've improperly ejected it. So far, I've been unable to fully Time Machine back-up my system, because my Mac keeps spitting out my back-up! Super lame...


    Firewire drives seem to work for me... sort of. I have trouble getting my Firewrie 800 drive to simply be recognized by the system. I have to unplug it, and plug it back in several times before it eventually will be reconized by the system in the first place. The Firewire 400 seems the most reliable, going for hours. Eventually, access to data on the 400 seems to lock up, and I need to re-boot my whole system. But there might be some other problem going on. Not sure. But all of this started since Moutain Lion. I sure am not a fan of Moutain Lion...


    But, yeah, right now, I really need to back up my system without my ext HD being rejected by the OS. That's a huge issue.

  • Primula Vulgaris Level 1 Level 1

    Same issue here.


    Mid-2010 MBP with a 128GB SSD replacing the optical drive. I've had it for a few months now and for the last week whenever my computer goes into standby, upon waking up the SSD has been ejected. I have to restart to get it back - Disk Utility can't even see it until I restart.


    Really ******* annoying.

  • RRFS Level 5 Level 5

    So you have an internal drive that is being ejected? Are you running 10.8.2? Which build? (The number in the parentheses in System Report) Have you done a Disk Utility > Repair Disk on the SSD?

  • Bryce Graven Level 1 Level 1

    This problem was resolved by the update to 10.8.1. I'm on 10.8.2 and most of my issues with this os have been resolved. Thanks everyone.

  • Primula Vulgaris Level 1 Level 1

    Yep, 10.8.2 (12C60) and I've repaired the disk. Both the disk and the partition are reported healthy. Until it ejects, then DU can't see it at all.


    It's an OCZ 128gb Petrol.

  • Thomas Herbert Level 1 Level 1

    I've been having the same problem with Firewire drives dropping out - on an iMac with 10.8.2.  I have a G drive and a Mercury Elite daisy chained on Firewire.  Both work great until I power down the computer.  Sometimes, but not always, when I power up the computer and drives, one or both drives don't mount.  I've played with disconnecting the Firewire cable, powering up the drives before or after the computer is restarted, etc.  I haven't found any method that reliably keeps the external drives mounted on a first try but ... after some frustration, plugging in cables, etc, I can get both drives mounted  and stay mounted.  This trouble has only happened since upgrading to Mountain Lion. 

  • henry Galdamez Level 1 Level 1

    I know that lately there have been "usb updates" for mountain lion but have any of these updates fixed the random eject problem for you guys becasuse they haven't for me.  I use a usb interface for my guitar for garageband by line 6 but I also use it as a volume controler, it works as an output to my speakrs instead of the bult in audio.

  • michelange Level 1 Level 1

    I have a similar problem with a new macbookpro retina.

    - Connecting one single Firewire-800 drive (G drive) seems to work fine, but have not yet tried backing up.

    - As soon as I try to connect a second FW-800 G drive in daisy chain, when I turn the power on to the second: Mountain Lion ejects to first with the message "improperly ejected" and both drives are not visible. I do not use separate power supply for the FW-Drives.

    - The same thing happens with for the second drive instead of a true FW-800, it is an SSD 128 GB mounted on an enclosure with a FW-800 interface.

    Question: is it worth trying to use the second Thunderbold since my macbookpro has two Thund. ports? I would have first to buy a second interface Thund-Firewire though.

  • runrabbitrun Level 1 Level 1

    I have a recent mac mini running mountain lion with a 1 tb G-drive connected through firewire 800 and a 2tb Seagate drive connected through usb.  My full itunes library is on the g drive and i'm trying to make a copy on the seagate drive.  twice i've tried to consolidate library to the seagate and the gdrive has been spontaneously ejected midstream.  once after copying 27 gbs of media, the other after copying 64 gb (never made it past the "c"s for the music.)    Tried to just copy the original itunes file and not go through itunes and this process too suffered from spontaneous ejection.  Help!

  • Bill-Halstead Level 1 Level 1

    Another unhappy person. I too am having same problem with USB external hard drives staying connected on my MacBook Pro with the latest OS 10.8.2.  I have gone through at least three hard drives.  A brand new one cannot be used with Time Machine.  Keeps disconnecting.  Having tried new hard drives, different cables, Verify and Repair of DU with no luck.  I have had to resort back to one of my Firewire Hard Drives to get a Time Machine Backup up completed.  I have even tried Disk Warrior to no avail.  This definitely appears to be an Apple Software ISSUE.  It would be nice if Apple would provide a fix for this, since I am not the only one who is having this problem.  By the way, It DOES NOt matter if the hard drives are USB 2 or USB 3, they get ejected.  I NEED a backup hard drive for my iTunes library of close to 57,000 MP3s.

  • MacGLS Level 1 Level 1

    Same problem. Unexpected, spontaneous eject of anything (HDD, Flash, external camera cards and readers). MBP Retina, Mountain Lion 10.8.2. All drives and cards WORK PERFECTLY ON OTHER NON-MOUNTAIN LION, NON-USB 3.0 MACHINES. Good grief, Apple. What is wrong with you? Your response is abysmal. Something CLEARLY is wrong with your Mountain Lion code or your USB 3.0 implementation!

  • eosman Level 1 Level 1

    I having a similar issue with my retina macbook pro and my western digital 2tb USB 3 hard drive. However it only happens with the right port with that one drive. The left port is fine. My other drives those being usb 2.0 are fine with the right USB port and the left USB port. Started happening for me after 10.8.1 I believe.


    Hopefully this is resolved in 10.8.3. I have tried the repair disk thing and it hasn't helped.


    EDIT: If I use black magic speed test on the right port my drive gets disconnected. This however does not happen with my USB 2 drives on the same port nor does it happen to my USB 3 drive when connected to the left port of my retina macbook pro.

  • eosman Level 1 Level 1

    Fixed my issue with my retina macbook pro and my usb 3 western digital drive. The drive would disconnect on the right port when being written to. I just installed the latest firmware from western digital from their download section. It notes in there that the older firmware had issues with intels usb controller which the macbook pro retina uses.

Previous 1 2 3 4 Next