Previous 1 2 3 4 5 6 Next 161 Replies Latest reply: Dec 10, 2014 1:04 PM by gd0 Go to original post
  • orenn Level 1 Level 1 (0 points)

    for random ejection issue by ML:

    Try to remove any NTFS 3rd party and re install new.

    i uninsatlled tuxera ntfs and installed Paragon - worked for me

    ML upgrade not working good with 3rd party ntfs program i guess?

    good luck.

  • ernest255 Level 1 Level 1 (0 points)

    I've had a similar problem with my Glyph GPT50 in Lion and Mtn Lion. The drive periodically powers off and does not mount. If I unplug it for hours or overnight (as opposed to minutes) it powers on and mounts & then powers off again randomly. So far no damage to contents. Glyph examined the drive, found no flaw, returned it and said I had a power source problem. I replaced cables, etc., and still nothing. (I have a WD ext drive for backups & other USB-connected hardware, none of which have ever failed. They are all connected via USB. The Glyph is connected via Firewire. I have replaced Firewire cable & also the power cord, to no avail. The Glyph connection is the only firewire I have on my system - iMac 2012 10.8.3). Anyway, Glyph replaced the drive (though I can't prove it, other than taking their word for it because they looked identical; I know Glyph is very highly regarded). Others have told me there is a power-related hardware flaw in the Glyph drive itself and that Glyph owes me a replacement - but if they've already replaced it, why do I need yet another replacement? Glyph probably thinks I am insane.

     

    The difference btwn the problem in Mtn Lion and pre-Mtn Lion is that now, when Glyph shuts off, I get the error message "Disc was improperly ejected." This appears in the morning, probably as a result of the machine going into sleep mode overnight. But the problem is random. The Glyph can work for many days, and then w/o warning it shuts off.

     

    Any thoughts?

  • SuperArmy Level 1 Level 1 (0 points)

    Same

     

    I have a Seagate 3TB USB3 hardrive and that has just started to eject on my rMPC 10.8.3

     

    Odd because the Hard Drive works on a 2009 MBP just fine. Disk Utility repaired some stuff but no luck.

     

    Any ideas?

     

    May go back to apple when I can

  • orenn Level 1 Level 1 (0 points)

    Lots of problems since i upgrade from Lion to ML, so i reinstalled ML, and it did not solved anything, but after i format my mac and installed a fresh copy of ML, everything works smooth and no ejection issues.

  • ernest255 Level 1 Level 1 (0 points)

    The unpowering/dismounting problem predates installation of Mtn Lion. After Mtn Lion the problems were accompanied by an error message saying "disc not properly ejected" (whatever that means). An Apple technician suggested that I plug my Glyph into another Mac and see what happens. So it's now plugged into my home Macbook. No problem so far, even with shutting down the computer, restarting, putting in sleep mode. We shall see. Time will tell.

  • eosman Level 1 Level 1 (0 points)

    I did a complete reinstall of Mountain Lion but first formatted the hard drive however I still have the issue. It only seems to be with my sandisk card reader and my USB3 western digital passport hard drive. Its only the one port on the right side. Though my USB2 seagate works fine with that port but it has its own power supply as its a bigger desktop external so maybe that has something to do with it... I dunno.

     

    Would like to go back to Lion but Lion is laggy with the rMBP compared to Mountain Lion.

  • ernest255 Level 1 Level 1 (0 points)

    It has now been about a week since I transferred the Glyph external drive to my Macbook and so far it has not shut down or dismounted. This suggests a problem with my iMac which three technicians - one on site and two by phone - have been unable to pinpoint. Next I will again hook up the drive to the iMac and see how long it stays on. The problem may be related to the fact that eight other hardwares (all w/USB connections) are plugged into the iMac and one or more interfere with the Glyph, which is firewire-connected.

  • eosman Level 1 Level 1 (0 points)

    Ernest is your Macbook running Mountain Lion as well?

  • ernest255 Level 1 Level 1 (0 points)

    Yes. I disconnected the drive from the Macbook and will hook it back up to the iMac and see what happens. If recent experience is any indicator it will power off and dismount within a few days, if not a few hours. Then, if no one can figure out what is going on, I will have to eject/dismount whenever I'm not using it and keep it strictly as a storage unit to be opened and used only when I need to add or extract a video file.

  • Phil Geller Level 1 Level 1 (5 points)

    A Seagate Slim 500GB USB 3.0 drive that had been working okay started unmounting from a MacBook Air recently.  It would stay connected for less than a minute.  I was able to fix it by applying a firmware update from Seagate.  I couldn't find any more description from Seagate than this: 

    Firmware update for Seagate Slim for Mac USB 3.0

    This firmware update corrects an issue where disconnect messages are seen in Mac OS.

     

    http://knowledge.seagate.com/articles/en_US/FAQ/005519en?language=en_US

     

    So something has changed in Mt. Lion that brought on this problem.  And it seems to be fixable by the drive manufacturers via firmware.

  • ernest255 Level 1 Level 1 (0 points)

    After the series of problems I have described in earlier posts, I am now hooking up my Glyph GPT50 only when I need to add a video to it or copy one on it to my iMac. But today when I tried convert a video file's format via Wondershare directly from the Glyph, it powered off and the familiar message of "improperly ejected disc" appeared on my iMac screen. This is the second time it has powered off while I was attempting to convert a video file directly from the Glyph (as opposed to copying the file to the iMac h.d. beforehand). Now, as usual, the Glyph will not power back on. So, as usual, I have to unplug it and let it sit overnight or longer, and then it will come back on. I now know that in addition to periodically powering off and dismounting, it will also not allow me to directly convert files via Wondershare. I will now have to copy the file to my iMac hard drive, and THEN convert with Wondershare.

     

    Maybe the ultimate solution would be to spend hundreds of dollars for a USB-connected external h.d. of comparable capacity, transfer the contents of the Glyth to the new drive and if after a few weeks of operation the new drive functions w/o powering off/dismounting, etc., return the Glyph to the manufacturer and ask for a refund.

  • AMCarter3 Level 1 Level 1 (10 points)

    I'm in this boat too. I have a Macbook Pro using OS 10.8.3. I get "Disk not ejected properly" alerts about once or twice a day. The alerts relate to one of my two USB backup drives (usually the Western Digital 500GB Pocket Drive and not the LaCie 2TB external Drive). It  happens randomly and often at night when my computer is automatically being backed up. Sometimes randomly during the day. It is NOT associated with any physical action like pulling a hard drive's USB plug out suddenly.

     

    Each backup drive has 3 partitions and, sometimes, only one or two  partitions are ejected. That's pretty strange. Equally strange... the ejected partitions sometimes reappear on the desktop on their own. When they reappear, I've learned I can ignore the alerts with no adverse consequence.

  • mjd1980 Level 1 Level 1 (0 points)

    This is driving me nuts. I have lost 3 external HD's to this problem.

     

    I am running MBP 2012 with Mountain Lion and I have lost 3 Drives all connected to my photography. Each time I have replaced the drive at £100 each and they work for a while, then eject for no reason and then never mount again. It is really really peeing me off.

     

    Add this to the slowness problems with Mountain Lion and I am slowly losing faith in Apple.

     

    I am researching if I can put lion back on as it seem that it is Mountain Lion that is the issue.

  • AMCarter3 Level 1 Level 1 (10 points)

    Has anyone called and talked with a senior Apple tech person about this issue? 

     

    Also, just a further note, I have not experienced any damage to any of my 4 backup USB drives as a result of this "ejection" problem. It is just an irritant for me.

  • Blinksmom Level 1 Level 1 (0 points)

    I have been experiencing this problem for a while and now just lost my seagate external drive. I'm thinking about going back to lion. Gonna talk to support at apple store to see how it can be done. The funny thing is that ml at home has not had an ejection issue with my older Mac mini. But the new Mac mini without the cd port is the one ejecting drives. I wonder if there is a hardware issue in the newer versions of apple computers that does not play nice with ml and external devices. May be thats why it's so hard to pin the problem down. It's a three way ... More variables.

Previous 1 2 3 4 5 6 Next