Previous 1 2 3 Next 161 Replies Latest reply: Dec 10, 2014 1:04 PM by gd0
wjackman Level 1 Level 1

Has anybody else had this problem? Ever since I updated to Mountain Lion, my external hard drives are periodically and seemingly randomly ejected, giving me an error message about improperly ejected disks. I have two drives, daisy-chained in firewire on a 2012 iMac.


Any help would be welcome. Thank you in advance for your help.

iMac, Mac OS X (10.7.1), 3.4 GHz Intel Core i7
Reply by RRFS on Sep 3, 2012 11:49 AM Helpful

I would do a Repair Disk from Disk Utility, from there do a Repair Disk Permissions and see if the problem persists.

All replies

  • Sam Beaver Level 1 Level 1

    i have this problem too on the imac 2011. swapped all externals to connect with USB and used external power bricks/cords. external drives either connect a short time after connected or they don't.

  • Krutsch Level 1 Level 1

    I have a similar problem; however, when I reboot my MacBook Pro (or shutdown and restart later), one of the drives will be reported by Mac OS X that it cannot be repaired.  I have wiped, repartitioned and reformated a couple of times and this keeps happening.


    I have noticed that if I manually unmount (i.e. eject) the drive, prior to shutting down the drive, I don't have this problem.  Once in a while, however, the drive spontaneously unmounts or I cannot eject the drive at all and have to reboot - when the latter happens, the drive is corrupted.


    Mountain Lion ROCKS!

  • xenicuslongpipe Level 1 Level 1

    Glad I'm not the only one with this. Mountain Lion is constantly ejecting my external card reader. I think it also caused corruption to my external HDD which was ejected too.


    Any more word on this?

  • MSW_MAC Level 1 Level 1

    Me too. I have my entire itunes and Time machine on 2 external drives (one connect with Firewire 8000, one with  USB2.0) neither drive is partictioned. I was streaming everything to Apple TV too- but nbow nothing. Can't mount external drives, cant' backup and can't watch anything !!! Apple- say someting.

  • RRFS Level 5 Level 5

    I would do a Repair Disk from Disk Utility, from there do a Repair Disk Permissions and see if the problem persists.

  • MSW_MAC Level 1 Level 1

    Tried all of the above- repair everything and still nothing. Anything else i can try?

  • Sam Beaver Level 1 Level 1

    you say you have daisy-chained through firewire.

    what happens if you try one at a time, with the drives recieving power from their own cords?

  • RRFS Level 5 Level 5

    Do the drives have their own power sources? What baran are they? Some are not playing well with Macs especially USB 3.0 that are connected as USB 2.0. Do the FireWire drives show up in the list of Disk Utility? Are they formatted correctly?

  • wjackman Level 1 Level 1

    Thanks for the help so far. To answer some questions,


    1. I have two G-Drive Q hard drives, both fairly recent, MacOS Extended formatting.

    2. Both show up in disk utility, when they show up on the desktop.

    3. They are both powered with their own power cords.

    4. I have run Disk Utility on both, but just recently and don't yet know if that was a solution. The one that I use for Time Machine couldn't repair permissions, due to that command being grayed out. Not sure why?

    5. the problem onlly started when I switched to Mountain Lion, therefore I suspect OS problems.


    I will try switching the order of the daisy-chain, and see if that has any effect.

  • michaelfrommonterey Level 1 Level 1

    I, too, am having hard drive problems with my new Macbook Pro 15" Retina, specifically it won't unmount or eject one of my USB drives. I can shut-down the computer and remove the drive, but that's the only way to eject it without a "force quit." I also can't run Disk Utility on it because it won't unmount.

  • wjackman Level 1 Level 1

    Yes, after running with it for a few days, the disk repair seems to have helped. At least, the disks have not been ejected since I repaired them. Interestingly, I am still getting occasional "disk ejected improperly" messages, but the disks themselves remain on the desktop. Something is still wrong, but it doesn't seem to affect workings of the external HDs, at least.

  • wjackman Level 1 Level 1

    Oops, problem not solved after all - my external disks were just ejected improperly once again despite disk repair. Back to the drawing board, I guess.

  • Bryce Graven Level 1 Level 1

    Same thing over here.  Only seems to be an issue with my USB drives.  Happens about 1 out of 5 times I use the spotlight shortcut.  I have heard it is a problem with the drive controller but havent been able to fix.  Also seem to be having issues with my drives running really hot since updating.

  • kbford1 Level 1 Level 1

    I am having the same problem with a Seagate 3 TB Thunderbolt drive.  Drive gets improperly ejected, then wont show up on desktop or disc utility until I reboot.  My Firewire external drive is fine.  Even though not showing up on desktop, System Info still shows drive connected via Thunderbolt port.  And it will eject randomly, not just at sleep.  So far no problems when actively writing to or reading from drive.  Apple tech support tries zapping PRAM, didn't help.


    Anyone come up with a solution?  Or even a cause?

Previous 1 2 3 Next