Skip navigation

"open with" duplicate entries

42032 Views 86 Replies Latest reply: Oct 7, 2013 1:10 PM by mario.fornieles RSS
  • TOAO Calculating status...
    Currently Being Moderated
    Dec 4, 2012 11:27 AM (in response to bamajr)

    The following works with Mountain Lion.

     

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

     

    HOWEVER.... some notes should be applied.

    This "open with" duplicates occurs when a bootable system clone is made or used.

    What this means is that EVERY TIME a system backup is created this procedure will need to be run in Terminal.

    THAT is a problem and an inconvenience.

     

    The solution to this should be obvious but it is not.

    The final solution is incredibly simple.

    You may have to run this terminal command once but if you simply do the rest, this stops occurring.

    What is the rest you ask?

     

    After you have run the Terminal command and Relaunched Finder, do the following.

    Run Disk Utility.... Repair Disk Permissions.

    Reboot your computer.

     

    Since I executed these very simple steps, the problem has not re-occurred on my Mac Pro even after I made a bootable backup.

    (prior to "doing the rest" (Repair Disk Permissions) I had to run the Terminal command Every Time I made a system backup)

     

    It has long been a standing procedure to run Repair Disk Permissions after Installs on OSX.

    This now applies to making original bootable backup clones.

     

    Sadly, I did not run Repair Disk Permissions after making my first backup clone.

    It is possible that the need for this Terminal command is not required at all if Repair Disk Permissions was run first. Sadly, I can't say for certain. (perhaps somebody will verify this)

     

    All I can say for certain is that the Terminal command worked and Repair Disk Permissions stopped the problem from happening after the Terminal command was executed.

  • VikingOSX Level 5 Level 5 (4,675 points)
    Currently Being Moderated
    Dec 4, 2012 11:39 AM (in response to justin_case)

    And I have noticed that simply rebooting into Safe Mode, followed by a normal reboot clears up the repeated Open with menu entries.

  • TOAO Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2012 1:28 PM (in response to VikingOSX)

    The idea behind my post (no offense) is to create a solution that prevents further steps being taken such as reboot in safe then normal mode.

    In other words a solution that cures the problem.

    While this seems to be a bug in Mountain Lion that Apple will someday correct and does not exist in Leopard as a bug.... what is needed is a process that does not Force the User to perform extra (and annoying I might add) measures.

    I refuse to reboot in safe mode then reboot in normal mode if I can simply get rid of the problem entirely with Repair Disk Permissions. (anything less would be annoying)

    Since Repair Disk Permissions IS a standard procedure that has existed for a very long time as a standard procedure, it cannot be defined as annoying and IS a very good practice for all OSX users to perform on a regular basis.

    END POST

  • TOAO Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 8, 2012 2:03 PM (in response to justin_case)

    I WAS MISTAKEN!!!!

    My previous post defining how to eliminate this problem was not entirely correct.

    Specifically, the problem does recur.

    The following is specific to the Mac Pro mid 2012 and does not imply, infer, or suggest that this is empirical for ALL mac models.

     

    I followed my own previous post and produced a backup clone as I normally do.

    The problem did once again occur.

    Irritated by this I sought an alternate solution and discovered this.

    http://support.apple.com/kb/HT4718

     

    Here is the scenario.

    I made a Legal clone on an external drive and installed the clone internally.

    This caused the problem of duplicate "open with" to occur.

    The question is, how do I stop this from happening altogether?

     

    I managed to stop this altogether using this technique.

    (Before you use this technique you should realize the following.... this technique is for producing a LEGAL CLONE.... if you are the person who makes a clone and distributes the clone to your buddies thus violating copyright law, then this technique will most likely lead to your arrest as a Felon)

     

    You will need a high speed internet connection preferably Ethernet although WiFi will work albeit much more slowly.

    Place your Energy Saver Computer sleep settings to Never. (the montior settings remain as they are)

    Restart your computer holding down the Command and R keys.

    Select your operating system hard drive, you are doing a Reinstall Mountain Lion.

    Follow the onscreen instructions.

     

    This will take no less than 2 hours and in some cases more using an Ethernet connection and longer for WiFi and days for all other connections.

    Best advice is to start this process then go to bed. All will happen automatically including a self restart.

    This forces the newly Reinstalled system to create a new index file.

    (don't forget to reset your preferred Energy Saver settings once completed)

     

    I tested this procedure by once again making an externally bootable backup clone.

    The duplicate "open with" problem did Not recur.

    I then ejected and turned the external clone off and then remounted it.

    The problem stayed away and did not recur.

     

    I have NOT installed the external clone internally to test to see if the problem reappears, but if it does, this seems to be the safest solution.

    Fiddling with your executable code via Terminal commands is ALWAYS risky.

    This procedure has no risk.

     

    For what its worth.

    The reinstall procedure does Not erase or delete any installed applications or preferences.

    I once again make this clear, ALL of this is with reference to a Mac Pro mid 2012 running Mountain Lion.

    I cannot state for a fact that this is the solution for all Mac models.

    All I can say is.... it works for me.

  • Eric Root Level 6 Level 6 (13,830 points)
    Currently Being Moderated
    Dec 8, 2012 2:32 PM (in response to justin_case)
  • TOAO Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 8, 2012 3:42 PM (in response to Eric Root)

    No, that is perfectly useless.

    Why would I fiddle with executable code OR purchase a third party program to fiddle with executable code when I can eliminate the problem for good.

    Onyx simply solves the problem each time the problem occurs. (a treatment)

    My purpose was to eliminate the problem from occurring because I make regular clone backups.

    Its the difference between Treatment and CURE.

     

    There is more than one "treatment" to this recurring problem.

    What I demanded was a CURE.

     

    The procedure I posted has "cured" this problem (for my machine at least) without any extra or recurring steps placed upon the user and no extra programs or knowledge.

  • Eric Root Level 6 Level 6 (13,830 points)
    Currently Being Moderated
    Dec 8, 2012 4:40 PM (in response to TOAO)

    OnyX is free for your information and there is no need to get hostile with people trying to help you even if their suggestions don't meet your need.

  • TOAO Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 8, 2012 7:45 PM (in response to Eric Root)

    There was no hostility in my post.

    It is purely technical.

     

    I know that Onyx is free.

    I also know that it fiddles with executable code.

    I also know that neither Onyx nor Terminal commands CURE the problem.... it just keeps happening over and over again despite these "treatments".

     

    I will not be stunned if your psycho analysis processes define this post as "hostile" as well.

    I don't have a hostile bone in me.

     

    I simply submitted a process that cures the problem rather than treats it.

    Two mouse clicks and its cured.

    No more, no less.

     

    Your suggestion while filled with beneficial intent was "perfectly useless" to me.

    THAT is just honesty without any hostile intent.

    (but thank you for sharing your feelings in a technical discussion forum in a manner that passed Judgment based upon your emotions, sorry if you perceived my grammar as offensive, I don't even know how to type!)

  • patorv Calculating status...
    Currently Being Moderated
    Dec 17, 2012 9:09 AM (in response to justin_case)

    I was skeptical to use the terminal - no experience with that yet and Onyx doesn't work with Mountain Lion, so I just repaired disk permissions and my problem was solved!

     

    I did not have this problem until after I had a couple of cloned drives mounted to my macBook Pro. I believe that was the reason all the duplicate entries showed up in the "open with" box. When I repaired the disk permissions, the external cloned drives had been ejected.

     

    Hopefully by now you have had success yourself with this issue.

  • TOAO Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2012 9:35 AM (in response to patorv)

    I tried the same procedure on Mac Pro 2012 after having previously suggested repair disk permissions and had no luck.

    The procedure for curing this problme IS machine specific.

     

    In the case of the Mac Pro specifically the mid 2012 the problem keeps returning.

    In my case specifically.... the installation of Snow Leopard has caused to problem to return.

    Every application installed in Snow Leopard causes a duplicate "open with" to appear when booted in Mountain Lion.

    This BUG does not occur in when booted in Snow Leopard.

     

    Please NOTE that I mention a specific condition and specific machine.

    My previously defined "cure" DOES work on the Mac Pro mid 2012 IF..... there is only one operating system installed.

    I strongly suggest that Terminal commands be avoided unless you are a software engineer.

     

    It is always to good idea to perform repair disk permissions periodically.

  • Eric Root Level 6 Level 6 (13,830 points)
    Currently Being Moderated
    Dec 17, 2012 9:37 AM (in response to patorv)

    patorv - Onyx does work with Mountail Lion. I use it all the time on two computers. You need to download a newer version though.

     

    http://www.titanium.free.fr/download.php?sid=8731b94531049cb12f6944b9d368db7c

  • TOAO Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2012 9:50 AM (in response to Eric Root)

    WHY????

    Why would the user be forced to download or use third party software or Terminal commands to modify operating system function when the problem is an operating system BUG?

    That makes no sense.

     

    IF there is an operating system BUG then there is an operating system BUG that the operating system engineer should repair.

     

    Please do not take offense, there is no offense intended or implied.

    How many people must experience this BUG before it is repaired?

    What good does it do to keep fighting a BUG that keeps returning over and over again despite third party software and or Terminal commands?

    I do not enjoy constantly and repeatedly repairing this software BUG over and over and over again regardless of the methods that work.

    It is nothing more than flogging a dead horse with hopes that the horse will magically revive itself.

     

    Does Onyx and Terminal commands CURE this problem?.... NO

    A "cure" is not temporary, a "cure" is applied once and is permanent.

    Does Onyx and Terminal commands "treat" this problem?.... Yes.

    You simply have to accept that it must be done over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over over and over and over and over.... ad infinitum.

    Sorry if I offend.

  • Eric Root Level 6 Level 6 (13,830 points)
    Currently Being Moderated
    Dec 17, 2012 11:47 AM (in response to TOAO)

    TOAO - I agree. Since Apple doesn't monitor the threads, everyone needs to send feedback to Apple so they will know that there is a bug and it is affecting a lot of people:

     

    http://www.apple.com/feedback/

     

    You didn't offend me.

  • Saul T. Calculating status...
    Currently Being Moderated
    Dec 18, 2012 3:15 PM (in response to bamajr)

    For future searchers, there's an extraneous space in the command line above, between "/LaunchServices.fram" and "ework/Support/lsregister".

    Remove the space there and the command works fine.

1 2 3 4 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.